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Introduction 

Imagine that you are standing in front of a closed door. On 

the other side of that door is a world of information — news, 

entertainment, job listings, and updates from family and 

friends. You see other people enter that doorway, but you can’t 

find a way to enter. 

People with disabilities come up against locked doors in the 

digital world continually. 1 

This site offers resources to help you create accessible documents. 

When you structure your documents correctly, you make your 

content  easier for everyone to understand and use. The 

accessibility improvements that you implement — like adding alt 

text and using headings — have tangible benefits for users with or 

without disabilities. 

Assistive technologies, such as screen readers, empower people 

with visual, auditory, or mobility impairments to be productive and 

purposeful. As content creators, we have a responsibility to add to 

this culture of inclusivity. By giving others access to content, we 

leave the door open for opportunities. 

 

1. Adapted from Enabling Access Through Web Renewal: 

Handbook (PDF), Wilfred Laurier University. 
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How to Use This Resource 

The techniques covered in this resource will help you create 

accessible office documents. We have taken the application-specific 

instructions developed by the Accessible Digital Office Document 

(ADOD) Project and updated it with revised instructions and 

screenshots, where needed. Featured throughout this resource are 

“Editor’s note” boxes like the one below.  

Editor’s note:  When instructions diverge for later 

versions of an application, we’ve captured the updates in a 

featured box like this. 

Review the techniques in the specific application sections and 

follow the steps to make your documents more accessible. Due to 

the nature of this reference document, we encourage you to use the 

online version of this resource. 

Use the table of contents or the list of applications below to find 

the instructions you need. 

Microsoft 

Microsoft Word 2013, 2016, and 2019 

Microsoft Word for Mac 2011, 2016, and 2019 

Microsoft Word 2010 

Microsoft Word 2008 for Mac 

Microsoft Word 2007 

Microsoft Excel 2010, 2013, 2016, and 2019 
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Microsoft Excel for Mac 2008, 2011, 2016, and 2019 

Microsoft Excel 2007 

Microsoft PowerPoint 2010, 2013, 2016, and 2019 

Microsoft PowerPoint for Mac 2008, 2011, 2016, and 2019 

Microsoft PowerPoint 2007 

Google 

Google Docs 

Google Sheets 

Google Slides 

Apple iWork 

Pages for Mac 

Numbers for Mac 

Keynote for Mac 

OpenOffice/LibreOffice 

OpenOffice Writer and LibreOffice Writer 

OpenOffice Calc 

OpenOffice Impress 
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Adobe Creative Suite 

Adobe InDesign CS6 and CC 

Adobe Acrobat 11 Pro and DC 

Adobe Acrobat 10 Pro 

Adobe Acrobat 9 Pro 
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Accessibility Statement 

While we attempt to make all elements of this resource conform 

with international accessibility guidelines, we must acknowledge a 

few accessibility issues: 

• Some external resources may not conform with accessibility 

guidelines. 

• Third-party video content may not be captioned, or may be 

captioned poorly. 

• The heading order for some headings do not conform to 

logical heading order. 

Accessibility Tips 

• Links to other pages of the site will always open in the current 

window. 

• Links to external sites will always open in a new window. 

• Use your screen reader’s list headings feature to navigate 

through the headings within the content of a page. 

• Use the Previous and Next links found at the bottom of each 

page to navigate through the sequence of pages in the site. To 

access these links most easily, use your screen reader’s 

landmarks list to navigate to the content info region, then 

press Shift+Tab to back up to the Next links. 

• Depending on the operating system and browser being used, 

font size can be adjusted by pressing a key combination 

including the plus (+) and minus (-) keys. On Windows systems 

the key combination is typically “Ctrl+” and on Mac it is 

“Command+”. 
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A sidewalk ramp A pair of eyeglasses Video with subtitles 

About Accessibility 

If you’ve used a sidewalk ramp, eyeglasses, or video subtitles, you’ve 

used assistive technology which aids with accessibility. 

Accessibility, when it comes to digital content, is often compared 

to a sidewalk ramp or curb cut — it’s a feature that ends up 

benefitting all people, not just those with mobility issues. As 

document authors, you need to be aware of the different types of 

abilities to plan for when creating accessible documents. 

Here’s a breakdown of the different barriers and how we can be 

inclusive: 

• Visual 

◦ People with low or no vision. 

◦ Help them by structuring documents correctly. 

• Auditory 

◦ People with low or no hearing. 

◦ Help them by adding captions and subtitles to your audio 

or video. 

• Mobility 

◦ People with physical mobility impairments (or people 

using mobile devices). 

◦ Help them by making documents easy to navigate and 

scale. 

• Cognitive or Neurodivergent 

◦ People with situational or developmental disabilities. 

◦ Help them by ensuring content is written in plain 
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language. 1 

Your primary task when making accessible documents is to ensure 

documents are structured correctly so that people assistive 

technologies can interact with your digital content. In order to do 

this, follow the techniques detailed in this resource. 

The steps taken to ensure the accessibility of the documents that 

you create are often not laborious. In the end, it often makes the 

document easier for all to use. 

1. To learn more, see Diverse Abilities and Barriers from 

W3C Web Accessibility Initiative. 
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The Case Against PDFs 

When converting your office documents to PDF for distribution, 

it’s important to consider if PDF is the best choice. Compared to 

HTML, for example, PDF documents are harder to use and maintain. 

PDFs are useful in certain cases, like completing government forms, 

but be sure to understand the limitations of PDF files.1 

Here’s a summary of some problems with PDFs: 

• PDFs are not designed for reading on screens. Unlike a 

responsive website that will allow content to resize to fit 

different devices and browsers, a PDF is static and not 

designed to be flexible in layout. Also, reading a PDF on smaller 

device may require additional scrolling (both horizontal and 

vertical) as well as zooming, which may be a frustrating user 

experience. 

• PDFs are harder to access. Even if you create a fully accessible 

PDF (properly structured and tagged with alt text and so on), 

it’s still possible that the PDF will not meet the accessibility 

1. Why GOV.UK Content Should Be Published in HTML and 

Not PDF - UK Government Digital Service. 

https://gds.blog.gov.uk/2018/07/16/why-gov-uk-

content-should-be-published-in-html-and-not-pdf/. 
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needs of all users and the assistive technologies that they use. 

Providing content in HTML, for example, would allow users to 

copy and paste text easily. Users with low-vision would be able 

to to adjust text size and colour contrast in their browser 

settings to make content easier to read. 

• PDF use is harder to track and update. If analytics are 

important to you, PDFs might not be the way to go. You can 

track the number of times that a PDF file is downloaded, but 

not which content was accessed most or which links were 

followed. If content is locked into a PDF, it may be harder to 

revise and less likely to be kept up-to-date. 

Before choosing to distribute your content as a PDF, consider your 

audience and how they will use the content: 

• Will they be downloading and using the PDF for offline use 

only? If so a PDF file is a viable option. 

• Do you need to track how people use the content? Then, it 

may be easier to provide your content in HTML. 

• Is the content robust and require special training to make the 

PDF accessible? It may be best to provide the content in 

several formats, not just PDF, to make it easier for users to 

read and use. 

We recommend considering HTML instead of or in addition to 
PDF where appropriate. While PDF accessibility has improved over 

the years, accessibility support for PDF by authoring tools, viewers 

and assistive technologies (e.g., screen readers) is not as widespread 

as for HTML documents. 
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AUTHORING TECHNIQUES 
FOR ACCESSIBLE OFFICE 
DOCUMENTS: WORD 
PROCESSING 
APPLICATIONS 

Authoring Techniques for Accessible
Office Documents: Word Processing





Google Docs 

Usage Notes 

Google Docs lacks several features that enable accessible office 

document authoring, most notably, the ability to create complex 

accessible tables and a built-in accessibility checker. 

While there is no accessibility checking feature built into Google 

Docs, you can install a third-party add-on called Grackle Docs. 

Grackle is a third-party plug-in that includes an accessibility 

checker along with other features that enhance accessibility on 

Google Docs (see Technique 11). 

Due to the nature of Google Docs, some accessibility features, 

such as tables, are only fully accessible when exporting the 

document to another format, like a PDF file. 

What’s an “Office Document”? 

You should use these techniques when you are using Google Docs 

to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (i.e., reports, letters, memos, 
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budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

Google Docs does not have a default file format as it is a web-based 

authoring tool. Google Docs offers a number of word processor and 

web format saving options. Most of these have not been checked 

for accessibility, but some information and/or instructions are 

available for the following formats in Technique 12: 

• Microsoft Word (.docx) 

• OpenDocument Format (.odt) 

• Rich Text Format (.rtf) 

• PDF (.pdf) 

• Plain Text (.txt) 

• Web Page (.html, zipped) 

• EPUB Publication (.epub) 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 
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is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. Files are easily saved 

as various file formats (see Technique 12). 

Editor’s note: Since the content of this page has been 

heavily updated from the original article (Authoring 

Techniques for Accessible Office Documents: Google docs: 

Documents), the usual editor’s notes that flag new content 

will be omitted. The application-specific steps and 

screenshots were updated in December 2019. 

Technique 1. Use Accessible Templates 

Google Docs lacks support for some accessibility features, such 

as table headers that repeat. With this in mind, be cautious of 
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templates available in the Google Docs template gallery and be sure 

that they comply the techniques discussed here. 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

Google Docs’s default template for new documents is a blank 

page. The basic installation also includes a wide variety of templates 

ranging from blank business letters and memos to blank business 

cards and schedules. These are all accessible by virtue of being 

blank. It is possible to create your own templates from scratch 

in Google Docs. As well, you can edit and modify the existing 

templates, ensuring their accessibility as you do so and saving them 

as a new template. 

 Curb Cuts: Updating templates is also a good 

opportunity to improve document consistency, copy 

editing, and branding. 

To select a template 

1.  Go to Google Docs. 

2. At the top right, click on Template Gallery. 
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3. Select a template. 

4. A copy of the template will open. 

To create an accessible template 

1. Create a new document (from the default template or from an 

existing template). 

Note: If creating a template from an existing document, go 

to File > Make a copy. Type a name and choose where to save 

it, then, click Ok. 

2. Rename your document. Be sure to indicate that the document 

is an accessible template by using terms such as “accessible” 

(e.g., “Accessible Memo Template”). This will improve its 

searchability and promote its use as an accessible template. 

3. Ensure that you follow techniques in this document. You may 

also check the accessibility (see Technique 11). 

To share your accessible template as a new document 

You can share your accessible template, but it may be more useful 

to share the file as copy that other users can add to their Google 

Drive. 

1. Go to the address bar change the end of the URL before 

sending it. 
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2. Replace “edit” at the end of the URL with “copy”. 

For example: 

Before: http://docs.google.com/document/d/12345678/edit 
After: http://docs.google.com/document/d/12345678/copy 

3. Send the modified copy link. 

4. When the recipient follows the modified copy link, they’re 

instructed to click on Make a copy.

5. They can then work on a copy of the accessible template. 

For more information, see the resources below: 

• Google: Create document templates 

• Google: Share “Make a copy” links to your files 

Technique 2. Specify Document Language 

At this time (December 2019), Google Docs does not offer an explicit 

language selection mechanism to indicate the natural language of 

your document or changes in natural language at any point within 

the content. Google Docs defaults the natural language to the 

language selected for your Google Account. Users can change your 

typing language in Google Docs (see Google: Change Your Typing 

Language). 

When exporting to other document formats, there is no 
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guarantee that the natural language of your Google Account will be 

indicated as the natural language of your document. In order for 

assistive technologies (e.g., screen readers) to be able to present 

your document accurately, it is important to indicate the natural 

language of the document. If a different natural language is used for 

a paragraph or selected text, this also needs to be clearly indicated. 

Use Grackle Docs to specify document language 

While Google Docs does not offer an explicit language selection 

mechanism, users can set the document language when using the 

Grackle Docs plugin (see Technique 11). Using Grackle, users can 

set document properties including document title and document 

language. This is mainly needed if using Grackle to export to other 

file formats, like PDF. 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

Google Docs offers a mechanism for adding alternative text to 

images and objects where it can be readily accessed by screen 

reader users. While you can add alt text, you will need to ensure that 

you provide the longer descriptions in the body of the document, 

near the images and objects. While this solution is not optimal 

for screen reader users and will complicate your own accessibility 

testing, it is necessary until long descriptions are supported. 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 
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in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 
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alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

• Alternatively, you can include the same 

information conveyed by the image within the 

body of the document, providing the images as an 

alternate to the text. In that case, you do not have 

to provide alternate text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* on the image. 

2. Select Alt Text from the contextual menu. 
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3. Add your alt text to the Description field. 
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4. Press OK to saveNote: Enter a description in the Title field will 

show a pop-up tooltip when users hover over the image with 

their mouse.  However, it is recommended to put the image 

description in the Description field. 

Technique 4. Avoid “Floating” Elements 

When images and objects are inserted into Google Docs they default 

to being positioned “inline” with the text. There is also the option 

to attach images and objects to a fixed position on the page. A 

“floating” object keeps its position relative to the page, while text 

flows around it. As content moves up or down on the page, the 

object stays where it was placed. To ensure that images and objects 

remain with the text that references it, always position it as “inline” 

with the text at the end of the in-text reference. Similarly, avoid 

placing drawing objects directly into the document (e.g., as borders, 

to create a diagram). Instead, create borders with page layout tools 

and insert complete graphical objects. 
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Technique 5. Use Headings 

Any document longer than a few paragraphs could benefit from 

adding structure to make content easier for readers to understand. 

One of the simplest ways to do this is to use actual headings 
(or “true headings”) to create logical divisions between paragraphs. 

Using actual headings means applying a built-in heading style — 

rather than just formatting content with bolded, enlarged, or 

centered text. Built-in heading styles are structural elements that 

communicate order and levels, which provide a meaningful 

sequence to users of assistive technologies. 

 Curb Cuts: Using actual headings provides 

several important benefits: 

• Headings are used by Google Docs to auto-

generate a table of contents (see Technique 7.5: 

Use a Table of Contents). 

• Headings are used by the Outline function in 

Google Docs to create a navigation pane, 

especially helpful for long documents (see Google: 

Use document outlines); and you can update all of 

the headings of a particular type at once, which 

keeps them consistent. 
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Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, …, “Heading 9”). 

• Six (6) levels of headings are supported. 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.). Do not skip 

headings. 

• If you plan to create a Word document that will 

have an automatically generated table of contents, 

remember that text marked with “Heading 1” will 

appear in the table of contents. Therefore, you 

may want to mark the top-level title of the 

document, which typically wouldn’t be included in 

the document’s table of contents, with the “Title” 

style. On the other hand, if you plan to convert to 

HTML, the main title is usually marked with a 

“Heading 1” which will be mapped to an <h1> 
HTML element. 

To apply headings from the Format menu 

1. Highlight the text that you want to make into a navigational 

heading. 

2. Go to menu item: Format > Paragraph Styles. 

3. Select the desired heading you would like to apply to the text. 
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For details on how to modify a heading or text style, see Google: Set 

and change a default style. 

To apply headings using the Heading drop-down menu 

1. Highlight the text that you want to make into a navigational 

heading. 

2. Go to the Styles drop-down menu. 

3. Select the desired heading you would like to apply to the text. 
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To apply headings using keyboard shortcuts 

1. Highlight the text that you want to make into a navigational 

heading 

2. Select Ctrl+Alt+1 (for Heading 1),Ctrl+Alt+2 (for Heading 2), etc. 

For a complete listing of keyboard shortcuts, see Google: Keyboard 

shortcuts for Google Docs. 

Technique 6. Use Named Styles 

As with actual or “true” headings (see Technique 5), you should 

attempt to make use of the named styles that are included with the 

office application (e.g., “emphasis”, “caption”, etc.) before creating 

your own styles or using the character formatting tools directly. 

Named styles help your readers understand why something was 

formatted in a given way, which is especially helpful when there 

are multiple reasons for the same formatting (e.g., it is common to 

use italics for emphasis, Latin terms and species names). For more 

information on formatting using named styles, see Technique 9. 

Note: While office application suites support headings in much the 

same way, the named styles often differ. 

To use default named styles 

1. Default named styles can be applied the same way as headings 

(see Technique 5). 

Technique 7. Use Built-In Document Structuring 
Features 
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7.1 Tables 

At this time, Google Docs does not offer a mechanism that allows 

you to select and indicate headings for rows and columns. Since 

it is not possible to create complex tables in Google Docs that are 

accessible, avoid creating complex tables since table headers cannot 

be designated. 

If you use the Grackle Docs add-on, tables can be given structure 

and table headings can be indicated. While these fixes won’t be 

useful for making tables more accessible in Google Docs, it does 

allow you to export the document into another format with 

appropriate table tags intact. For more on Grackle Docs, see

Technique 11. 

When using tables, it is important to ensure that they are clear 

and appropriately structured. This helps all users to better 

understand the information in the table and allows assistive 

technologies (e.g., screen readers) to provide context so that the 

information within the table can be conveyed in a meaningful way. 

Since Google Docs does not provide a feature to repeat header 

rows at the top of each page, you would need to break your table 

into separate tables. Then, you would manually add a row at the top 

of the table and copy/paste header info at the top of each page. For 

detailed instructions on how to work with tables in Google Docs, see 

Google: Add and edit Tables. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 
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• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 
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7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Go to menu item: Format > List styles. 

2. Select the list style you want to use. 

7.3 Columns 

Use Columns feature for placing text in columns. Note: Because 

columns can be a challenge for users of some assistive technologies, 

consider whether a column layout is really necessary. 

7.4 Page Breaks 

Start a new page by inserting a page break (Windows: CTRL + Enter; 

Mac: ⌘ + Enter) instead of repeated hard returns. 

7.5 Use a Table of Contents 

Creating an index or table of contents to outline office-document 

content can provide a means of navigating the meaningful sequence 
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of content. You can see your document’s structure with a table 

of contents. Each item in the table of contents links to your 

document’s headings. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To insert a Table of Contents 

1. Position cursor where you would like to place the table within 

your document. 

2. Go to menu item: Insert > Table of contents. 

To update a Table of Contents 

1. Click within the table. 

2. Select the Refresh button. 

For more details, see: Google: How to add or change a table of 

contents. 

7.6 Use Page Numbering 

In Google Docs, you can add page numbers and the number of total 

pages to a document. 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 
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content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 

To insert page numbers 

1. In the top left, select Insert and then Header & page number. 

2. Then choose: 

Page number: Choose where you want the page numbers to 

go, and whether you want the first page to be skipped. 

Page count: The page count will be added wherever your 

cursor is placed in the document. 

3. The page numbers or page count will be added automatically. 

For more details, see Google: Add or remove headers, footers and 

page numbers. 

7.7 Document Title 

At this time, Google Docs makes use of a single document name. 

Within Google Docs, this serves well as a title, but when exporting 

to ODT, the document name is used to form the file name and the 

ODT “Title” properties field is left blank. Note: In case the document 

is ever converted into HTML, it should be given a descriptive and 

meaningful title. 

If using third-party add-on Grackle Docs, you can add a 

document title. After updating this setting, the document title  will 

be preserved in the document’s metadata when exporting to PDF 

using Grackle. It is one of the first checks that appears in the 

Grackle Docs sidebar after launching (see Technique 11). 
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To change the file name of the current document 

1. Go to menu item: File > Rename. 

2. In the Rename Document dialog, enter a new document name. 

3. Click OK. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is 

as accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• When creating bar charts, it is helpful to apply textures rather 

than color to differentiate the bars 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2) 
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 Curb Cuts: If the chart data is also provided in an 

appendix, it will be easier for all users to make use of the 

data. 

To add a chart to Google Docs 

Charts that you create in Google Sheets can be linked to a Google 

Docs document. 

1. Go to Insert >  Chart. 

2. Select the type of chart you want to add. 

3. When you add a new chart, it will link to a new Google Sheet. 

To update the the data in the chart, update the numbers in the 

linked Google Sheet. 

For more details, see the following: 

• Google: Link a chart, table, or slides to Google Docs or Slides 

• Google: Types of charts & graphs in Google Sheets 

• Google: Learn how to edit chart data 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 
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• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 
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Also, always use a single solid color for a text background rather 

than a pattern. In order to determine whether the colors in your 

document have sufficient contrast, you can consult an online 

contrast checker, such as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 
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should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Google Docs’s 

review functionality features to track changes, such as the 

revision history and TextFlow mechanisms. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted in 

Technique 3. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate, and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 
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• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Go to menu item: Insert > Link. Alternately, you can select the 

text you’d like to add a link to and press Ctrl+K (or Cmd+K on 

Macs). 

2. In the pop-up box, enter descriptive text in the Text display 

box. 

3. Enter the link address in the Link. 

4. Select Apply. 
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Technique 11. Check Accessibility 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

While there is no accessibility checking feature built into Google 

Docs, you can install a third-party add-on called Grackle Docs. 

Grackle Docs 

What is Grackle Docs? Grackle Docs is a third-party add-on that 

runs on documents created in Google Docs. It helps with checking 

and improving the digital accessibility of your document. Due to the 

nature of Google Docs, some accessibility features, such as tables, 

are only fully accessible when exporting the document to another 

format, like a PDF file. 

How does it work? After Grackle is launched, It scans the current 

document for accessibility issues and identifies and locates errors. 

Feedback appears in a sidebar that is docked on right-side of the 

screen. By exploring the sidebar, you can immediately learn about 

accessibility issues and find and fix the detected errors by 

interacting with the Grackle sidebar. 

Note: Grackle’s accessibility checker is free to use; however, the 
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ability to export and produce accessible HTML and PDF documents 

is only free for the first 30 days (as of December 2019). 

At present, Grackle Docs performs the following 22 accessibility 

checks: 

• Document 

◦ Document title is required 

◦ Document language should be specified 

• Images 

◦ Images should have alternate text or mark as artifact 

◦ Drawings should have alternate text or mark as artifact 

◦ Equations should be described 

◦ Images may need to be downsampled to reduce file size 

• Headings 

◦ Headings should be used 

◦ A single “Heading 1” should be used 

◦ Headings must be properly nested 

• Tables 

◦ Tables must be tagged or marked as layout tables 

◦ The use of merged cells is not recommended 

◦ The use of empty cells is not recommended 

• Landmarks 

◦ Headers and footers should be used 

◦ Footnotes should have ids and alt text 

◦ Lists should be used where appropriate 

• Content 

◦ Document should not contain unsupported content 

◦ High color contrast should be used 

◦ Fine print should be avoided 

◦ All-caps styling should be avoided 

◦ Adjusted alignment not suggested for non-heading text 

◦ Lengthy paragraphs should be avoided 

◦ Links should be informative 
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How to install Grackle Docs 

Grackle Docs can be installed from the Add-ons menu of a Google 

Docs document. 

1. Open a Google document. 

2. Select Add-ons > Get Add-ons. 

◦ Search for “Grackle” in the search field. 

◦ Select the add-on and click Install. 

3. Note: A message will appear requesting access to data that the 

add-on needs to work. Review the message and click Allow. 
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How to launch and use Grackle Docs 

Grackle Docs is simple to launch and is accessed from the Add-ons 
menu. Open a Google document 

1. From the Add-ons menu, select Grackle Docs, then select 

Launch. 

◦ A sidebar launches that identifies errors and warnings. 
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◦ Clicking on each error and warning will expand the 

selection and provide guidance on how to resolve each 

issue. 

◦ Select the “Locate” button on any flagged item will take 

you to that line of the document to review.

2. Continue to review and address each flagged item. 

◦ Select the “Re-Check” button at the top of the sidebar to 

update the report. 

◦ Continue to revise until all checks have passed. 

To view a sample Google Doc that will give you a sense of how 

Grackle Docs works, see Grackle Docs Walkthrough Document from 

Grackle. Automated accessibility checkers cannot be trusted to 

check for all accessibility concerns, so be sure to review the 

recommended techniques in this document. 

Evaluating Accessibility in Other Formats 

To evaluate HTML accessibility 

Save the document into HTML format and use one of the web 

accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 
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To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 
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Alternate formats 

1. Go to menu item: File > Download as 
2. Select format Note: documents saved as HTML format may 

require some cleaning up. The steps below will help you with 

this. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 . 

To clean up your HTML file 

1. Remove unnecessary styles, line breaks, etc. 

2. Remove unnecessary id, class, and attributes 

3. Remove font tags 

4. Remove styles in the <head> tag 

5. Ensure the <th> tags have a scope attribute 

6. Remove <p> tags nested inside <th> and <td> tags 

7. Check for accessibility (see Technique 11) Note: you may wish to 

use HTML editors or utilities to help with this process. 
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Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Grackle Docs 

• Using Google Docs with a screen reader – outlines how to 

navigate to the ARIA enhanced version of Google docs and use 

keyboard shortcuts. 

• Keyboard shortcuts for Google Docs 

• Google Docs Section 508 Compliance 

Accessibility Help 

If you are interested in what features are provided to make using 

Google Docs more accessible to users, documentation is provided 

through online articles and Help forums: 

1. Go to menu item: Help > Google Docs Help Center 

References and Resources 

1. Google Docs help 

2. GAWDS Writing Better Alt Text 
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Microsoft Word 2013, 2016, 
and 2019 

Usage Notes 

 This icon highlights “curb cut” opportunities 

in these techniques. “Curb cuts” are situations in which 

accommodations made for accessibility reasons will also 

result in significantly better and more efficient 

outcomes for everyone. The name comes from sidewalk 

“curb cuts” that were added for people in wheelchairs, 

but are commonly used by people with baby strollers, 

handcarts, wheeled luggage, and others. 

At the time of testing (December 2019), Word provides a set of 

accessibility features that is sufficient to enable the production of 

accessible digital office documents. In addition, Word includes an 

accessibility checking feature. This guide is intended to be used for 

documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e., without hyperlinks to other documents, 
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unlike web content), and 

• Typical of office-style workflows (e.g., Reports, letters, 

memos, budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Word is Office Open XML (DOCX). 
In addition, Word offers many other word processor and web 

format saving options (e.g., PDF, HTML, OpenDocument Text, Rich 

Text Format, etc.). Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available in Technique 11. 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 
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spacebar) or (2) Shift+F10. 

Disclaimer and Testing Details 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Microsoft Word 2013 and 

Microsoft Word included with Office 365 while creating a 

DOCX document. 

Technique 1. Use Accessible Templates 

WCAG 2.0 Applicability: 

• All success criteria 

All office documents start with a template. These can be as simple as 

a blank standard-sized page or complex nearly complete document 

with text, graphics, and other content (e.g., a “meeting minutes” 

template). Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 10. Check 

Accessibility). Word’s default template for new documents is a blank 
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page. The basic installation also includes a variety of other blank 

office-related documents. These are all accessible by virtue of being 

blank. It is also possible to create your own accessible templates. 

 Curb Cuts: Updating templates is also a good 

opportunity to improve document consistency, copy-

editing, and branding. 

To create an accessible template 

1. Create a new document (from the default blank template or 

from one of the prepackaged templates). 

2. Ensure that you follow all of the techniques in this document. 

3. When finished, check the accessibility of the document (see 

Technique 10. Check Accessibility). 

4. Go to menu item: File > Save As. 

5. Select Templates. 

6. In the Save as type list, select Word Template (*.dotx). 
7. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Memo Template”) may 

increase the prominence of the accessibility status. As well, 

filling in the text boxes labeled Tags and Title with the terms 

that include “accessibility” may improve the discoverability of 

the template as an accessible file. 

8. Select Save. 
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To select an accessible template 

Only use these steps if you have an accessible template available 

(e.g., one that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: File > New. 

2. Select Personal. 
3. Select your accessible template from the list. 
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4. A new document based on the template will be displayed. If 

you chose an accessible template, the document will be 

accessible at this point. 

5. As you add your content (e.g., text, images, etc.), ensure that 
you consult the sections that follow to preserve accessibility. 

Technique 2. Specify Document Language 

WCAG 2.0 Applicability: 

• 3.1.1 Language of Page 

• 3.1.2 Language of Parts 
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In order to enable for assistive technologies (e.g., screen readers) 

to present your document accurately, you must indicate the natural 

(human) language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

 Curb Cuts: The specified document language is 

also used by the spelling and grammar checker. In 

Canada, make sure to choose “English (Canada)” to avoid 

having to override American spellings of words such as 

“colour.” 

To change the default language 

1. Go to menu item: File. 

2. Select Options from the list in the left window pane. 

3. Select Language from the list in the left of the Options dialog. 

4. Under Choose Editing Languages, select the editing language 

you want to use. 

Note: To add an editing language, select the language from the 

drop down list labeled “Add additional editing languages.” 

5. Select Set as Default. 
6. Close all Office documents and open them again for the 

changes to take effect. 
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Word has an automatic language detection mechanism, which can 

automatically detect the language of your text. If you type a section 

of text in a different language than the rest of your document, Word 

should programmatically mark the language of that section of text 

appropriately. 

To turn on automatic language detection 

1. Go to menu item: Review. 

2. In the Language section, select the Language button. 

3. Select Set Proofing Language. 

4. In the Language dialog, select the Detect language 
automatically check box. 
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To apply a language directly to selected text 

1. Select the text. 

2. Go to menu item: Review. 

3. In the Language section, select the Language button. 

4. Select Set Proofing Language. 

5. In the Mark selected text as box, select the language from the 

list. 

6. Select OK. 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

WCAG 2.0 Applicability: 

• 1.1.1 Non-text Content 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This is done by adding concise alternative text to of each 

image. If an image is too complicated to concisely describe in the 

alternative text alone (e.g., artwork, flowcharts, etc.), provide a short 

text alternative and a longer description as well. 
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 Curb Cuts: Sometimes it may not be clear what a 

particular image is meant to convey and alternative text 

can provide that clarity. Also, alternate text has been 

shown to be included in search engines rankings. 

Tips for writing alternative text 

• Try to answer the following question: “What 

information is the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank. 

• If the image contains meaningful text, include 

all of the text in the alternative. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences. 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below. 

• Test by having others review the document with 

the images replaced by the alternative text. 
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Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question: “What information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone. 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* the object. 

2. Select Format Picture… 
3. Select the Layout & Properties tab. 
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4. Select the Alt Text option from the list under that tab. 

5. Fill in the Description field (not the “Title” field). 

When inserting a very small image (or resizing a larger image to be 

much smaller) and following it with text, Word sometimes assumes 

that the image is intended to be a bullet-point for a bulleted list. 

Once Word defines the image as a bullet, the option to add 

alternative text disappears. Select Undo, to redefine the bullet as an 

image. 

Editor’s note: For later versions of Word, the Alt Text 
menu is also available in the right-click, pop-up menu that 

appears when you right-click on an image. 

For more information, see these resources: 

• Microsoft: How to add alt text 

• Microsoft: How to improve accessibility with alt 

text (video) 
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Technique 4. Avoid “Floating” Elements 

WCAG 2.0 Applicability: 

• 1.3.2 Meaningful Sequence 

When certain elements (e.g., images, objects, text boxes) are 

inserted into Word documents they default to being an “inline 

object”. Inline objects keep their position on the page relative to 

a position in the text. This is beneficial for users of assistive 

technologies (e.g., screen readers), because the position of the 

object in the document order is clear, so the screen reader can 

read the object’s alternative content (e.g., Description field) when 

the user moves keyboard focus to that position. However, Word 

also provides the option to have these elements “float” outside of 

the text order, with text flowing around, under or over it. This is a 

problem because the position of the object in the document is no 

longer clear and the screen reader will often read the alternative 

text out of context, which can be confusing. These text flow options 

should be avoided. Similarly, avoid placing drawing objects such as 

arrows, lines and shapes directly into the document (e.g., as borders, 

to create a diagram). Instead, create borders with page layout tools 

and insert complete graphical objects (e.g., pictures). 

 Curb Cuts: In-line elements are often easier to 

work with than floating elements, which can end up 

being shifted into strange positions as editing earlier 

parts of a document cause repagination. 
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To prevent an image or object from “floating” 

1. Select the object. 

2. Go to menu item: Page Layout. 

3. Select Position from the Arrange section. 

4. Select In Line with Text. 

Editor’s note: In later versions of Word, you can also keep 

pictures in-line with text by selecting the object and 

choose a wrapping option from the pop-up icon. 
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Technique 5. Use Headings 

WCAG 2.0 Applicability: 

• 1.3.1 Info and Relationships 

• 2.4.1 Bypass Blocks 

• 2.4.6 Headings and Labels 

• 2.4.10 Section Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them easier for readers to understand. One of 

the simplest ways to do this is to use “True Headings” to create 

logical divisions between paragraphs. True headings are more than 

just bolded, enlarged, or centred text; they are structural elements 

that order and levels provide a meaningful sequence to users of 

assistive technologies. 
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 Curb Cuts: Using true headings provides several 

important benefits: (1) Headings are used by Word to 

auto-generate a table of contents (see Technique 6.5 

Use a Table of Contents); (2) Headings are used by the 

“Navigation Pane” which is especially helpful for long 

documents (see Word’s “Navigation” Feature); and you 

can update all of the headings of a particular type at 

once, which keeps them consistent. 

Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, …, “Heading 9”). 

• Nine levels of headings are supported. 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.). 

• If you plan to create a Word document that will 

have an automatically generated table of contents, 

remember that text marked with “Heading 1” will 

appear in the table of contents. Therefore, you 

may want to mark the top-level title of the 

document, which typically wouldn’t be included in 

the document’s table of contents, with the “Title” 

style. On the other hand, if you plan to convert to 

HTML, the main title is usually marked with a 

“Heading 1” which will be mapped to an <h1> 

62  |  Microsoft Word 2013, 2016, and 2019



HTML element. 

To apply headings to selected text 

1. Select text. 

2. Right-click* and select Styles. 

3. Select the heading style (Heading 1, Heading 2, and so on) from 

the list. 

To apply headings using the Styles toolbar 

1. Select text. 

2. Go to menu item: Home. 

3. In the Styles section, select the heading style that you wish to 

apply 

Note: You can scroll through the multiple heading styles using 

the arrows on the right side of the Styles section. You can also 

change the Style design by selecting the Change Styles button 

on the right. 

To modify heading styles 

1. Go to menu item: Home. 

2. In the Styles section, right-click* the style you wish to modify 

from the Styles Gallery. 

3. Select Modify. 
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4. In the Modify Style dialog, make your desired changes to style 

characteristics. 

5. Select OK. 

Adding heading style that is not listed 

Sometimes heading levels may not appear in lists described above. 

For example, the list might contain “Heading 1” and “Heading 2”, but 

not “Heading 3”. In this case, it is still possible to apply the unlisted 

style: 

1. Select text. 

2. Go to menu item: Home. 

3. In the Styles section, select the arrow to expand the list of 
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style options. 

4. Select Apply Styles. 

5. In the Style Name, enter the heading style (“Heading 1” to 

“Heading 9”). 

6. Select Apply button. 

Technique 6. Use Built-In Document Structuring 
Features 

WCAG 2.0 Applicability: 

• 1.3.1 Info and Relationships 

• 1.3.2 Meaningful Sequence 

• 2.4.2 Page Titled 
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 Curb Cuts: Using built-in structural features is 

much more reliable that trying to use typography for 

formatting (e.g., tabs to separate table cells, repeated 

new lines for a page break). 

6.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 
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• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g. “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4. Avoid “Floating” Elements). 

To insert a table 

1. Go to menu item: Insert. 

2. In the Tables section, select Insert Table. 

3. Select the Number of columns and the Number of rows you 

would like your table to have. 

4. Select the OK button. 
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To a heading row 

1. Place the cursor in the top-row of the table that you would like 

to make into the heading row. 

2. The Table Tools menu item should appear. 

3. Go to menu item: Table Tools > Layout. 

4. In the Table section, select Properties. 

5. Select the Row tab. 

6. Select the Repeat as header row at the top of each page 
checkbox. 

6.2. Lists 

When you create lists, it is important to format them as “real lists.” 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Go to menu item: Home. 

2. In the Paragraph section, select the Bullets icon for unordered 

lists or select the Numbering icon for ordered lists. 

To modify list styles 

1. Go to menu item: Home. 

2. In the Paragraph section, select the arrow beside the Bullets 
icon for unordered lists or select the arrow beside the 

Numbering icon for ordered lists. 
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3. Select Define New Bullet… to create a new unordered list 

format. 

4. Select Define New Number Format… to create a new ordered 

list format. 

5. In the New Bullet dialog or the New Number Format dialog, 

select the list characteristics. 

6. Select OK. 

6.3 Columns 

Use the Columns feature for placing text in columns. Note: Because 

columns can be a challenge for some users with disabilities (e.g., 

people using magnifiers), consider whether a column layout is really 

necessary. 

6.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 

To add a page break 

1. Go to menu item: Page Layout. 

2. In the Page Setup section, select the arrow beside the Breaks 
icon. 

3. Select the type of break to add. Page break is used to start a 

new page with the same page layout (page orientation, 

headers, page numbering, etc.). Section break is used if you 

want to start a new section of the document with a differing 

page layout. 
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6.5 Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. The best way to generate a table of contents is after 

applying the predefined heading styles (e.g., “Heading 1,” “Heading 

2,” “Heading 3”) as described above, to the headings that you want 

to include in your table of contents. After you apply these styles, 

you can then create a table of contents. Note: If you do not want 

the main title of the document to appear in the generated table of 

contents, mark it with the “Title” style. 

To insert a table of contents 

1. Place the cursor in your document where you want to create 

the table of contents. 

2. Go to menu item: References. 

3. In the Table of Contents section, select Table of Contents. 

4. Select the style that you want to use. 

To update a table of contents 

1. Select the table of contents. 

2. Go to menu item: References. 

3. In the Table of Contents section, select the Update Table 
button. 

6.6 Page Numbering 

Numbering the pages of you document helps those reading and 
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editing your document effectively navigate and reference its 

content. For users of assistive technologies, it can provide a valuable 

point of reference within the document. 

To insert page numbers 

1. Go to menu item: Insert. 

2. In the Header & Footer section, select Page Number. 

3. Select where you would like to insert your page numbers. 

4. Select the style of page number you would like to use. 

To format page numbers 

1. Go to menu item: Insert. 

2. In the Header & Footer section, select Page Number. 

3. Select Format Page Numbers… 
4. In the Page Number Format dialog, select the page format 

characteristics you would like to use. 

Note: These changes are applied to the predefined page format 

styles. It does not create a new page format style. 

6.7 Document Title 

If you plan to convert the document into HTML, it should be given a 

descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File. 
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2. Select Info from the list in the left window pane 

3. In the right window pane, select the Title text box and enter 

an appropriate title. 

Note: The Title defined in the properties is different than the 

file name. 

Editor’s note: For later versions of Word, follow these 

steps: 

1. Select Info, then click on Properties in the right-

most pane. 

2. Next, select Advanced Properties. 

3. From there, the Title text box can be updated. 

Technique 7. Create Accessible Charts 

WCAG 2.0 Applicability: 

• 1.1.1 Non-text Content 

72  |  Microsoft Word 2013, 2016, and 2019



• 1.3.1 Info and Relationships 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 

• All the basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 

color, rather than color alone, to convey information. 

◦ When creating line charts, use the formatting options to 

create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colours to differentiate the bars 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colours, 

ensuring that they align with sufficient contrast requirements 

(see Technique 8.2 Use Sufficient Contrast) 

• Consider providing the data that you used to create the chart 

in tabular form (e.g., as an appendix). 

 Curb Cuts: If the chart data is also provided in an 

appendix, it will be easier for all users to make use of the 

data. 
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Technique 8. Make Content Easier to See 

WCAG 2.0 Applicability: 

• 1.3.3 Sensory Characteristics 

• 1.4.1 Use of Color 

• 1.4.3 Contrast (Minimum) 

• 1.4.5 Images of Text 

• 2.2.2 Pause, Stop, Hide 

 Curb Cuts: All users will benefit from content 

that is easier to see. 

8.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) are typically easier to read than serif fonts (e.g. Times 

New Roman, Garamond). 
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• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such as the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable default level of accessibility. 

To change the text size for a default named style 

1. Go to menu item: Home. 

2. In the Styles section, right-click* the Style you wish to modify. 

3. Select Modify Style. 

4. Under Formatting in the Modify dialog box, select the 

appropriate font size. 

5. Exit with OK. 
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8.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. 

To help you determine the contrast, here are some examples on a 

white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 
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Also, always use a single solid colour for a text background rather 

than a pattern. In order to determine whether the colours in your 

document have sufficient contrast, you can consult an online 

contrast checker, such as the TPG Contrast Analyser or the 

WebAIM: Contrast Checker. 

8.3 Avoid Relying on Color or Sensory 
Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the colour 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the colour of text 

you have edited and noting the colour. Instead use Word’s 

“Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

8.4 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or colour combination), consider whether 

you can achieve the same result by styling “real text.” If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 
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Technique 9. Make Content Easier to Understand 

WCAG 2.0 Applicability 

• 2.4.4 Link Purpose (In Context) 

• 3.1.4 Abbreviations 

• 3.1.5 Reading Level 

• 3.2.3 Consistent Navigation 

• 3.2.4 Consistent Identification 

9.1 Write Clearly 

 Curb Cuts: By taking the time to design your 

content in a consistent way, it will be easier to access, 

navigate and interpret for all users. 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g. headings, footings, etc.), it 

should occur consistently each time it is repeated. 
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9.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Type (or paste in) a web address and press spacebar or “Enter” 

to convert into a hyperlink. 

2. Select the link and right-click*. 

3. Select Edit Hyperlink (Ctrl + K). 

4. Edit the text in the Text to display box. 

Technique 10. Check Accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1. Use Accessible Templates), Word offers an 

“Accessibility Checker” to review your document against a set of 

possible issues that users with disabilities may experience in your 

file. 

Important Note: No checker can detect all types of accessibility 

issues. For example it can tell if alternative text is missing, but 

it cannot tell if alternative text is actually correct. It also doesn’t 

test for some issues, including colour contrast. The Office website 
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provides more information about the Accessibility Checker, 

including the rules it uses to identify and classify accessibility 

issues. The “Accessibility Checker” classifies issues as 

• Error – content that makes a file very difficult or impossible 

for people with disabilities to understand 

• Warning – content that in most, but not all, cases makes a file 

difficult for people with disabilities to understand 

• Tip – content that people with disabilities can understand, but 

that might be better organized or presented in a way that 

would maximize their experience 

To use the “Accessibility Checker” 

1. Make sure the file is saved as a DOCX. (Note: Older DOC files 

are not compatible with the checker). 

2. Go to menu item: File. 
3. Select Info in the left window pane. 

4. Select the Check for Issues dropdown. 

5. Select the Check Accessibility item. 
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6. An Accessibility Checker task pane will open, showing the 

inspection results. 

7. Select a specific issue to see Additional Information. 

8. Follow the steps provided to fix or revise the content. 
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Technique 11. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Saving to PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 
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To evaluate the accessibility of your PDF document, see Technique 

10. Check Accessibility. 

1. Go to menu item: File. 

2. Select Save As. 

3. In the File name box, type a name for the file. 

4. In the Save as type list, select PDF (*.pdf). 

5. Select the Options button. 

6. Ensure that the Document structure tags for accessibility 
checkbox is selected. 

7. Select OK and Save. 

Microsoft Word 2013, 2016, and 2019  |  83



Saving to HTML 

1. Go to menu item: File. 

2. Select Save As. 

3. In the File name box, type a name for the file. 

4. In the Save as type box, select Web Page (*.htm). 

5. Check the title in the Title text box. To change it, select the 

Change Title… to open an “Enter Text” dialog box. 

6. Select Save. 

7. Check the HTML file for accessibility (see Technique 10. Check 

Accessibility). 

To clean up your HTML file 

1. Remove unnecessary styles, line breaks, etc. 

2. Remove unnecessary id, class, and attributes. 

3. Remove font tags. 

4. Remove styles in the <head> tag. 

5. Ensure the <th> tags have a scope attribute. 

6. Remove <p> tags nested inside <th> and <td> tags. 

7. Check for accessibility (see Technique 11, above). 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Other Application Features 

Word’s “Navigation” Feature 

After you have populated your document with content and true 

headings have been applied, you may wish to rearrange the content. 
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In order to maintain the integrity and accessibility of the altered 

sequence, you will need to ensure that structural information (e.g. 

heading levels) is adjusted accordingly. Word provides a 

“Navigation” mechanism which displays all parts of the document, 

such as headings, paragraphs, objects, etc. in sequential order. It 

helps you navigate, access, and manipulate the content. You can 

move headings or subordinate text up or down, rearranging their 

sequence in a way that can be programmatically determined and 

therefore accessible to assistive technologies. 

To use the “Navigation” feature 

1. Go to menu item: View. 
2. In the Show section, select the Navigation Pane check box. 

3. The Navigation pane will open to the left of your document. 

To jump to a location in a document 

1. Select one of three navigation options: 

1. Select HeadingsNote: select the heading to view 

hierarchical headings and content below it. 

2. Select Pages. 
3. Select the (Search) Results. 

2. Scroll through the sequential list and double-click* on the 

location you would like to jump to 
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To move content up or down in a document 

• Select and drag the content to a new location in the list. 

Accessibility Help 

If you are interested in what features are provided to make using 

Word more accessible to users, documentation is provided in the 

Help system: 

1. Go to menu item: File. 
2. Select Help from the list on the left. 

3. Under the Support section, select the Help icon. 

4. Enter “Accessibility” as your search term in the Help dialog 

box. 

References and Resources 

1. Microsoft Accessibility Page 

2. Microsoft: Use a screen reader to explore and navigate Word 

3. Microsoft Accessibility Tutorials 

4. Microsoft: Keyboard shortcuts in Word 

5. Ryerson University: Microsoft Word Accessibility Tipsheet 

(PDF) 

6. Microsoft Word: Video Tutorials 

Acknowledgments 

Authors: Jan Richards, Sabrina Ruplall 

86  |  Microsoft Word 2013, 2016, and 2019

http://www.microsoft.com/enable/
https://support.office.com/en-us/article/use-a-screen-reader-to-explore-and-navigate-word-a16a93f4-163f-4f48-a246-78c2573d8953?redirectSourcePath=%252fen-us%252farticle%252fAccessibility-features-in-Word-29ec3f51-7b78-49b7-b3da-7e869a931c8e
https://www.microsoft.com/en-us/accessibility/
https://support.office.com/en-us/article/keyboard-shortcuts-in-word-95ef89dd-7142-4b50-afb2-f762f663ceb2
https://www.ryerson.ca/content/dam/accessibility/guides-resources/tipsheets/Microsoft-Word-Accessibility-Tipsheet.pdf
https://www.ryerson.ca/content/dam/accessibility/guides-resources/tipsheets/Microsoft-Word-Accessibility-Tipsheet.pdf
https://support.office.com/en-us/article/video-check-the-accessibility-of-your-document-9d660cba-1fcd-45ad-a9d1-c4f4b5eb5b7d


This document was produced as part of the Accessible Digital 

Office Document (ADOD) Project. 

This project has been developed by the Inclusive Design Research 

Centre, OCAD University as part of an EnAbling Change Partnership 

project with the Government of Ontario and UNESCO (United 

Nations Educational, Scientific and Cultural Organization). 

Source: Authoring Techniques for Accessible Office Documents: 

Microsoft Word 2013 by the Inclusive Design Research Centre 

(IDRC) used under CC-BY-SA 3.0. 

Microsoft Word 2013, 2016, and 2019  |  87

https://adod.idrc.ocadu.ca/
https://adod.idrc.ocadu.ca/
https://adod.idrc.ocadu.ca/word2013.html
https://adod.idrc.ocadu.ca/word2013.html
https://idrc.ocadu.ca/
https://idrc.ocadu.ca/
https://creativecommons.org/licenses/by-sa/3.0/


Microsoft Word for Mac 2011, 
2016, and 2019 

Usage Notes 

At the time of testing (December 2019), Word for Mac provides a set 

of accessibility features that is sufficient to enable the production 

of accessible digital office documents. However, Word 2011 for Mac 

does not include an accessibility checking feature. 

Editor’s note: Later versions of Word for Mac include an 

accessibility checker (for 2016 and later versions). For more 

information, see Technique 11 or review how to make your 

Word documents accessible to people with disabilities. 

This guide is intended to be used for documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 
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For more information on creating forms, web pages, applications, or 

other dynamic and/or interactive content that are accessible, you 

should consult the W3C-WAI Web Content Accessibility Guidelines 

(WCAG 2.0) because these are specifically designed to provide 

guidance for highly dynamic and/or interactive content. 

File Formats 

The default file format for Word for Mac is Office Open XML 
(DOCX). 

In addition, Word for Mac offers many other word processor and 

web format saving options, however most of these have not been 

checked for accessibility. 

Disclaimer and Testing Details 

• The following techniques will increase the accessibility of your 

documents, but it does not guarantee accessibility to any 

specific disability groups. In cases where more certainty is 

required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Microsoft Word 2011:Mac and 

Microsoft Word for Mac 2016 (version 16.16.16) while creating a 

DOCX document. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. If 

errors are found, please report them to: adod-

comments@idrc.ocad.ca. 
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Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. 

Microsoft Word for Mac’s default template for a new documents is 

a blank page. It is possible to create your own accessible templates 

from scratch in Word for Mac. As well, you can edit and modify the 

existing prepackaged templates, ensuring accessibility as you do so 

and saving them as a new template. 

To create an accessible template 

1. Create a new document ( from the default blank template or 

from one of the prepackaged templates) 

2. Follow the techniques in this guide. 

3. Go to menu item: File > Save As. 

4. In the Save As box, insert a name for the template.Tip: Using a 

descriptive File name (e.g., “Accessible Memo Template”) may 

increase the prominence of the accessibility status. 

5. In the Format box, select Word Template. 

6. Select Save. 
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To select an accessible template 

Only use the following steps if an accessible template is available 

(e.g. a previous templates that is already created). Otherwise, simply 

open a new blank document. 

1. Select the template icon (top left corner). 

2. Under Templates, select My Templates (in the word document 

gallery). 

3. Select the template from the scrolling gallery. 

4. Select Choose. 
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Technique 2. Specify Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present the document accurately, it is important to indicate the 

natural language of the document (e.g., English, French). If a 

different natural language is used for a paragraph or selected text, 

this also needs to be clearly indicated. 

To change the default language 

1. Go to menu item: Tools >Language… 

2. In the Mark selected text as: box, select the language. 
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3. Select Default… 

To apply a language directly to selected text 

1. Select the text. 

2. Go to menu item: Tools > Language… 
3. In the Mark selected text as: box, select the language. 

4. Select OK. 
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Technique 3. Provide Alternatives Text for 
Images and Graphical Objects 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 
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information, leave the alternative text blank. 

• If the image contains meaningful text, ensure all 

of the text is replicated. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences. 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below. 

• Test by having others review the document with 

the images replaced by the alternative text. 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 
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the image to a person over the phone. 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Select Image. 

2. (*Right click or Control+click) Select Format Picture… 
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3. In the “Format Picture” window left menu, select Alt Text. 

4. Insert description. 

5. Select OK. 
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Editor’s note: To learn more about adding alternative text 

to images and graphical objects, see the video on how to 

improve accessibility with alt text. 

Technique 4. Avoid “Floating” Elements 

When images and objects are inserted into Word for Mac 

documents, they default to being an “in line with text.” In this case, 

you do not need to change anything. 
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However, if you are editing a document that includes a “floating” 

image or object, use the procedure below: 

To prevent an image or object from “floating” 

1. Under Arrange (top navigation bar). 

2. Select Wrap text. 

3. Select In Line with Text. 
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Editor’s note: For later versions of Word, the instructions 

are simplified slightly, as follows: 

1. Select the image. 

2. Under the Picture Format tab, you’ll see the drop-

down menu for Wrap text. 

Technique 5. Use Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them more straightforward for readers to 

understand. One of the easiest ways to do this is to use “True 

Headings”. True headings are more than just bolded, enlarged, or 

centred text; they are structural elements that order and levels 

provide a meaningful sequence to users of assistive technologies. 

To apply headings 

1. Select text. 

2. In the Styles panel select the heading you wish to apply (in the 

Home bar) 

Note: If the Styles panel is not in view, go to menu item: View > 

Toolbox, Styles. 
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Editor’s note: In later versions of Word for Mac, 

the Styles Pane button is visible on the right side of 

the Home tab. 
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To modify heading styles 

This refers to changing the appearance of all text marked with a 

certain style. 

1. In the Styles dialog box, select the heading you want to 

modify. 

2. Select the drop down menu on the side of the selected 

heading. 

3. Select Modify Style… 

4. In the Modify Style dialog, make the appropriate changes to 

style characteristics. 

5. Select OK. 
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To create a new style 

1. In the Styles dialog box (View > Toolbox, Styles). 
2. Select New Style… 
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3. In the Name box, enter a name for the new style. 

4. Format the characteristics of the new style. 

5. Select OK. 

104  |  Microsoft Word for Mac 2011, 2016, and 2019



Technique 6. Use Named Styles 

Named styles help your readers understand why something was 

formatted in a given way, which is especially helpful when there are 

multiple reasons for the same formatting (e.g., it is common to use 

italics for emphasis, Latin terms and species names). 
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To use default named styles 

Default named styles can be applied the same way as headings (see 

Technique 5). 

Technique 7. Use Built-In Document Structuring 
Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 
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dividing complex data sets into separate smaller 

tables, where possible. Whenever possible, use 

just one row of headings. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• For more complicated tables, consider creating 

a text summary of the essential table contents. 

Any abbreviations used should be explained in the 

summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page. 

Adding a table 

1. Go to Table (top navigation bar). 

2. Under Table Options select New. 

3. In the “New” drop down menu drag the columns and rows 

need. 
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Note: To style the table select the table on the page and choose 

the design available in the Table Styles panel. 

Editor’s note: For later versions of Word for Mac, the 

insert table functions are in found in the Insert tab. 
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Note: Be sure to designate table headers: In the Table 
Design tab, select the checkbox for Header Row, to 

indicate table headings. 

7.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 
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To create an ordered or unordered list 

1. Select Home (top navigation bar). 

2. Under Paragraph select the style (e.g., bullets, number). 

7.3 Columns 

Use Columns feature for placing text in columns. However, because 

columns can be a challenge for users of some assistive technologies, 

you should consider whether a column layout is really necessary. 

7.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 

7.5 Use a Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. 
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To insert a table of contents 

1. Place the cursor in your document where you want to create 

the table of contents. 

2. Document Elements > Table of Contents. 

3. In the Table of Contents select the style you want to use. 

Note: in order for the table of content to automatically set up 

the user must change all the heading to Heading 1. 

Editor’s note: In later versions of Word for Mac, the 

Table of Contents drop-down menu is located under the 

References menu. 
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To update table of contents 

1. Select the table. 

2. Select the drop down menu beside Table of Contents. 

3. Select Update Table… 

Editor’s note: In later versions of Word for Mac, 

the Update Table button is located under the References 
tab. 

7.6 Use Page Numbering 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 
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Insert page numbers 

1. Go to menu item: Insert >Page Numbers… 

2. In the Page Numbers dialog, select the page number 

characteristics (Position, Alignment, Show number on first 

page). 

3. Select OK. 

Editor’s note:  For later versions of Word for Mac, go to 

the Insert tab to find the Page Number button. 

Formatting page numbers 

1. In the Page Numbers dialog, select Format… 
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2. Select the format characteristics in the Page Number Format 

dialog. 

3. Select OK. 

Note: These changes are applied to the predefined page format 

styles. It does not create a new page format style. 

7.7 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change title 

1. Go to menu item: File > Properties. 

2. In the Document Properties dialog, select Summary. 

3. Enter the title in the Title text box. 
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Tip: you can also fill in the subject, author and other 

descriptions if necessary 

Technique 8. Make Charts Accessible 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 

• All basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 

color, rather than color alone, to convey information. 
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◦ When creating line charts, use the formatting options to 

create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colors to differentiate the bars. 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2). 

• Consider providing the data that you used to create the chart 

in tabular form (e.g. as an appendix). 

Technique 9. Make Content Easier to See 

Here are some other things to keep in mind: 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 15 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 
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• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. In order to determine whether the colors in your 

document have sufficient contrast, you can consult an online 

contrast checker, such as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Comparison 

• TPG Contrast Analyser 
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9.3 Avoid Relying on Color or other Sensory 
Characteristics 

Content should not rely solely on sensory characteristics such as 

the colour or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the colour of text 

you have edited and noting the colour. Instead use Word for 

Mac’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.4 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or colour combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 
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• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colours, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings), it should occur 

consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

Technique 11. Check Accessibility 

At this time, Word 2011 for Mac does not offer a mechanism to 

check for potential accessibility errors in your document prior to 

publishing. 

Editor’s note: For later versions of Word for Mac, there is 
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an accessibility checker, located under the Tools menu. For 

detailed instructions, see the following resources: 

• Microsoft: Improve accessibility with the 

Accessibility Checker 

• Microsoft: Make your Word documents accessible 

to people with disabilities 

It is also possible possible to create tagged PDFs using 

later versions of Word for Mac: 

1. Select File: Save As (or press Command+Shift+S) 

2. Enter the file name in the Save As field, then 

choose where you want the file to be saved. 

3. In the Save As dialog, go to the File Format drop 

down box and select PDF. 

4. Select the radio button Best for electronic 
distribution and accessibility (uses Microsoft online 
service). This ensures the PDF is tagged. 
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Note: If you do not see this option, you may need to 

update your version of Word. 

5. Select Save. 

Accessibility Help 

If you are interested in what features are provided to make using 

Word more accessible to users, documentation is provided in the 

Help system: 

1. Go to menu item: File. 
2. Select Help from the list on the left. 

3. Under the Support section, select the Help icon. 

4. Enter “Accessibility” as your search term in the Help dialog 

box. 
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Microsoft Word 2010 

Usage Notes 

  This icon highlights “curb cut” 

opportunities in these techniques. “Curb cuts” are 

situations in which accommodations made for 

accessibility reasons will also result in significantly 

better and more efficient outcomes for everyone. The 

name comes from sidewalk “curb cuts” that were added 

for people in wheelchairs, but are commonly used by 

people with baby strollers, handcarts, wheeled luggage, 

and others. 

At the time of testing (September 30, 2010), Word 2010 provides 

a set of accessibility features that is sufficient to enable the 

production of accessible digital office documents. In addition, Word 

2010 includes an accessibility checking feature. 

This guide is intended to be used for documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 
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• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Word 2010 is Office Open XML (DOCX). 
In addition, Word 2010 offers many other word processor and 

web format saving options. Most of these have not been checked 

for accessibility, but some information and/or instructions are 

available for the following formats in Technique 12 (below). 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or (2) Shift+F10. 
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Disclaimer and Testing Details 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Microsoft Word 2010 

(ver.14.0.4762.1000, Windows XP, Aug. 2010) while creating a 

DOCX document. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. If 

errors are found, please report them to: adod-

comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

WCAG 2.0 Applicability: 

• All success criteria 

All office documents start with a template. These can be as simple as 

a blank standard-sized page or complex nearly-complete document 

with text, graphics and other content (e.g., a “Meeting Minutes” 

template). Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 
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produced when the template is used (see Technique 10. Check 

Accessibility). 

Word 2010’s default template for new documents is a blank page. 

The basic installation also includes blank business card, blank label 

templates, and other blank office-related documents. These are all 

accessible by virtue of being blank. It is possible to create your own 

accessible templates. 

Curb Cuts: Updating templates is also a good 

opportunity to improve document consistency, copy-

editing, and branding. 

To create an accessible template 

1. Create a new document (from the default blank template or 

from one of the prepackaged templates). 

2. Ensure that you follow all of the techniques in this document. 

3. When you are finished, check the accessibility of the document 

(see Technique 10. Check Accessibility) 

4. Go to menu item: File > Save As. 
5. Select Templates. 
6. In the Save as type list, select Word Template. 
7. In the File name box, type a name for the template. Using a 

descriptive File name (e.g. “Accessible Memo Template”) may 

increase the prominence of the accessibility status. As well, 

filling in the text box labeled Tags with the term “accessibility” 

may improve its discoverability as an accessible file. 

8. Select Save. 
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To select an accessible template 

Only use these steps if you have an accessible template available 

(e.g., that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: File > New. 
2. Under Available Templates, select My Templates. 
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3. In the New document dialog, select your accessible template 

from the list. 

4. Select OK. 

5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. 

6. As you add your content (e.g. text, images, etc.), ensure that 
you consult the sections that follow to preserve accessibility. 

Technique 2. Specify Document Language 

WCAG 2.0 Applicability: 

• 3.1.1 Language of Page 

• 3.1.2 Language of Parts 

In order for assistive technologies (e.g. screen readers) to be able 

to present your document accurately, you must indicate the natural 
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(human) language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

 Curb Cuts: The specified document language is 

also used by the spelling and grammar checker. In 

Canada, make sure to choose “English (Canada)” to avoid 

having to override American spellings of words such as 

“colour.” 

To change the default language 

1. Go to menu item: File. 
2. Select Options from the list in the left window pane. 

3. Select Language from the list in the left of the Options dialog. 

4. Under Choose Editing Languages, select the editing language 

you want to useNote: to add an editing language, select the 

language from the drop down list labeled “Add additional 
editing languages.” 

5. Select Set as Default. 
6. Close all Office 2010 programs and open them again for the 

changes to take effect.

Word 2010 has an automatic language detection mechanism, which 

can automatically detect the language of your text. If you type a 

section of text in a different language than the rest of your 
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document, Word 2010 will programmatically mark the language of 

that section of text appropriately. 

To turn on automatic language detection 

1. Go to menu item: Review. 
2. In the Language section, select the Language button. 

3. Select Set Proofing Language. 
4. In the Language dialog, select the Detect language 

automatically check box. 

To apply a language directly to selected text 

1. Select the text. 

2. Go to menu item: Review. 
3. In the Language section, select the Language button. 
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4. Select Set Proofing Language. 
5. In the Mark selected text as box, select the language from the 

list. 

6. Select OK. 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

WCAG 2.0 Applicability: 

• 1.1.1 Non-text Content 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 
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to convey by the image is also conveyed to people who cannot see 

the image. This is done by adding concise alternative text to of each 

image. If an image is too complicated to concisely describe in the 

alternative text alone (e.g. artwork, flowcharts, etc.), provide a short 

text alternative and a longer description as well. 

 Curb Cuts: Sometimes it may not be clear what a 

particular image is meant to convey and alternative text 

can provide that clarity. Also, alternate text has been 

shown to be included in search engines rankings. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?”. 

• If the image does not convey any useful 

information, leave the alternative text blank. 

• If the image contains meaningful text, include 

all of the text in the alternative. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences. 

• If more description is required (e.g. for a chart 

or graph), provide a short description in the 

alternative text (e.g. a summary of the trend) and 

more detail in the long description, see below. 
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• Test by having others review the document with 

the images replaced by the alternative text. 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?”. 

• In some situations, the information being 

conveyed will be how an image looks (e.g. an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone. 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 
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To add alternative text to images and graphical objects 

1. Right-click* the object. 

2. Select Format Picture… 
3. Select the Alt Text option from the list. 

4. Fill in the Description. 

If a Word 2010 document is saved to HTML, the Title and 

Description fields are combined into a single entry within the 

HTML <alt> tag. [Tested: September 30th, 2010] 

When inserting a very small image, or resizing a larger image to be 

much smaller, Word 2010 assumes that the image is intended to be a 

bullet-point for a bulleted list. Once Word 2010 defines the image as 

a bullet, the option to add alternative text disappears. Select Undo, 

to redefine the bullet as an image. When you right-click* the image, 
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select Format Picture… and select the Alt Text tab in the Format 
Picture dialog. Alternative text can be found, or can be entered, into 

the Alternative text box. 

Technique 4. Avoid “Floating” Elements 

WCAG 2.0 Applicability: 

• 1.3.2 Meaningful Sequence 

When certain elements (e.g., images, objects, text boxes) are 

inserted into Word 2010 documents they default to being an “inline 

object”. Inline objects keep their position on the page relative to 

a position in the text. This is beneficial for users of assistive 

technologies (e.g., screen readers), because the screen reader can 

simply read the object (or its alternative text) when it reaches that 

point in the text flow, so the context is clear. 

However, Word 2010 also provides the option to have these 

elements “float” outside of the text order, with text flowing around, 

under or over it. This is a problem for screen reader users because 

their screen reader will often read the text (or alternative text) out 

of context, which can be confusing. These text flow options should 

be avoided. 

Similarly, avoid placing drawing objects such as arrows, lines and 

shapes directly into the document (e.g. as borders, to create a 

diagram). Instead, create borders with page layout tools and insert 

complete graphical objects (e.g., pictures). 
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 Curb Cuts: In-line elements are often easier to 

work with than floating elements, which can end up 

being shifted into strange positions as editing earlier 

parts of a document cause re-pagination. 

To prevent an image or object from “floating” 

1. Select the object. 

2. Go to menu item: Page Layout. 
3. Select Position from the Arrange section. 

4. Select In Line with Text. 

Technique 5. Use Headings 

WCAG 2.0 Applicability: 

• 1.3.1 Info and Relationships 

• 2.4.1 Bypass Blocks 

• 2.4.6 Headings and Labels 

• 2.4.10 Section Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them easier for readers to understand. One of 
the simplest ways to do this is to use “True Headings” to create 

logical divisions between paragraphs. True headings are more than 

just bolded, enlarged, or centered text; they are structural elements 
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that order and levels provide a meaningful sequence to users of 

assistive technologies. 

 Curb Cuts: Using true headings provides several 

important benefits: (1) Headings are used by Word 2010 

to auto-generate a table of contents (see Technique 6.5 

Use a Table of Contents); (2) Headings are used by the 

“Navigation Pane” which is especially helpful for long 

documents (see Word 2010’s “Navigation” Feature); and 

you can update all of the headings of a particular type at 

once, which keeps them consistent. 

Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, etc.) 

• Nest headings properly (e.g. the sub-headings of 

a “Heading 1” are “Heading 2”, etc.) 

To apply headings to selected text 

1. Select text. 

2. Right-click* and select Styles. 
3. Select the heading style from the list. 
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To apply headings using the Styles toolbar 

1. Select text. 

2. Go to menu item: Home. 
3. In the Styles section, select the heading you wish to applyNote: 

You can scroll through the multiple heading styles using the 

arrows on the right side of the Styles section. You can also 

change the Style design by selecting the Change Styles button 

on the right. 

To modify heading styles 

1. Go to menu item: Home. 
2. In the Styles section, right-click* the style you wish to use 

from the Styles Gallery. 
3. Select Modify. 
4. In the Modify Style dialog, make the appropriate changes to 

style characteristics. 

5. Select OK. 

To return to the default heading styles: 

1. Go to menu item: Home. 
2. In the Styles section, select Change Styles. 
3. Select Style Set. 
4. Select Word 2010 from the list. 
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Technique 6. Use Built-In Document Structuring 
Features 

WCAG 2.0 Applicability: 

• 1.3.1 Info and Relationships 

• 1.3.2 Meaningful Sequence 

• 2.4.2 Page Titled 

 Curb Cuts: Using built-in structural features is 

much more reliable that trying to use typography for 

formatting (e.g. tabs to separate table cells, repeated 

new lines for a page break). 

6.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g. 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

140  |  Microsoft Word 2010



Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g. “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 
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(see Technique 4. Avoid “Floating” Elements). 

To add a table with headings 

1. Go to menu item: Insert. 
2. In the Tables section, select the Tables icon. 

3. Select the number of rows and columns you would like your 

table to have. 

4. Select the table and a Table Tools menu item should appear. 

5. Go to menu item: Table Tools > Design. 
6. In the Table Style Options section, select the Header Row 

check boxNote: Whenever possible, keep tables simple with 

just one row of headings. 

6.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Go to menu item: Home. 
2. In the Paragraph section, select the Bullets icon for unordered 

lists or select the Numbering icon for ordered lists. 
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3. To choose a different list format, select the arrow beside the 

icon. 

4. Select a format from the format Library that appears in the 

drop-down menu. 

To modify list styles 

1. Go to menu item: Home. 
2. In the Paragraph section, select the arrow beside the Bullets 

icon for unordered lists or select the arrow beside the 

Numbering icon for ordered lists. 

3. Select Define New Bullet… to create a new unordered list 

format. 

4. Select Define New Number Format… to create a new ordered 

list format. 

5. In the New Bullet dialog or the New Number Format dialog, 

select the list characteristics. 

6. Select OK. 

6.3 Columns 

Use the Columns feature for placing text in columns. 

Note: Because columns can be a challenge for some users with 

disabilities (e.g., people using magnifiers), consider whether a 

column layout is really necessary. 

6.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 
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To add a page break 

1. Go to menu item: Page Layout. 
2. In the Page Setup section, select the arrow beside the Breaks 

icon. 

3. Select the type of break to add. Page break is used to start a 

new page with the same page layout (page orientation, 

headers, page numbering, etc.). Section break is used if you 

want to start a new section of the document with a differing 

page layout. 

6.5 Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To insert a table of contents 

1. Place the cursor in your document where you want to create 

the table of contents. 

2. Go to menu item: References. 
3. In the Table of Contents section, select Table of Contents. 
4. Select the style that you want to use. 
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To update a table of contents 

1. Select the table. 

2. Go to menu item: References. 
3. In the Table of Contents section, select the Update Table 

button. 

6.6 Page Numbering 

Numbering the pages of you document helps those reading and 

editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 

To insert page numbers 

1. Go to menu item: Insert. 
2. In the Header & Footer section, select Page Number. 
3. Select where you would like to insert your page numbers. 

4. Select the style of page number you would like to use. 

To format page numbers 

1. Go to menu item: Insert. 
2. In the Header & Footer section, select Page Number. 

3. Select Format Page Numbers… 
4. In the Page Number Format dialog, select the page format 

characteristics you would like to use 

Note: These changes are applied to the predefined page format 

styles. It does not create a new page format style. 
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6.7 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File. 
2. Select Info from the list in the left window pane. 

3. In the right window pane, select on the Title text box. 

4. Enter the TitleNote: The Title defined in the properties is 

different than the file name. It is also unrelated to the template 

name, discussed above. 

Technique 7. Create Accessible Charts 

WCAG 2.0 Applicability: 

• 1.1.1 Non-text Content 

• 1.3.1 Info and Relationships 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 

• All basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 
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color, rather than color alone, to convey information. 

◦ When creating line charts, use the formatting options to 

create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colors to differentiate the bars 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 8.2 Use Sufficient Contrast) 

• Consider providing the data that you used to create the chart 

in tabular form (e.g., as an appendix). 

 Curb Cuts: If the chart data is also provided in an 

appendix, it will be easier for all users to make use of the 

data. 

Technique 8. Make Content Easier to See 

WCAG 2.0 Applicability: 

• 1.3.3 Sensory Characteristics 

• 1.4.1 Use of Color 

• 1.4.3 Contrast (Minimum) 
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• 1.4.5 Images of Text 

• 2.2.2 Pause, Stop, Hide 

 Curb Cuts: All users will benefit from content 

that is easier to see. 

8.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) are typically easier to read than serif fonts (e.g., Times 

New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 
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printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such as the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

To change the text size for a default named style 

1. Go to menu item: Home. 
2. In the Styles section, right-click* the Style you wish to modify. 

3. Select Modify Style. 
4. Under Formatting in the Modify dialog box, select the 

appropriate font size. 

5. Exit with OK. 
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8.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as the TPG Contrast Analyser or the WebAIM: Contrast Checker. 

8.3 Avoid Relying on Color or Sensory 
Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Word 2010’s 

“Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 
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8.4 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g. 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 9. Make Content Easier to Understand 

WCAG 2.0 Applicability: 

• 2.4.4 Link Purpose (In Context) 

• 3.1.4 Abbreviations 

• 3.1.5 Reading Level 

• 3.2.3 Consistent Navigation 

• 3.2.4 Consistent Identification 

9.1 Write Clearly 

 Curb Cuts: By taking the time to design your 

content in a consistent way, it will be easier to access, 

navigate and interpret for all users. 
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• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g. headings, footings, etc.), it 

should occur consistently each time it is repeated. 

9.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Type (or paste in) a web address and press spacebar or “Enter” 

to convert into a hyperlink. 

2. Select the link and right-click*. 

3. Select Edit Hyperlink (Ctrl + K). 

4. Edit the text in the Text to display box. 
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Technique 10. Check Accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1. Use Accessible Templates), Word 2010 offers an 

“Accessibility Checker” to review your document against a set of 

possible issues that users with disabilities may experience in your 

file. 

Important Note: No checker can detect all types of accessibility 

issues. For example it can tell if alternative text is missing, but it 

cannot tell if alternative text is actually correct. It also doesn’t test 

for some issues, including colour contrast. 

The Office website provides more information about the 

Accessibility Checker, including the rules it uses to identify and 

classify accessibility issues. 

The “Accessibility Checker” classifies issues as 

• Error – content that makes a file very difficult or impossible 

for people with disabilities to understand 

• Warning – content that in most, but not all, cases makes a file 

difficult for people with disabilities to understand 

• Tip – content that people with disabilities can understand, but 

that might be better organized or presented in a way that 

would maximize their experience 

To use the “Accessibility Checker” 

1. Make sure the file is saved as a DOCX (Older DOC files are not 

compatible with the checker). 

2. Go to menu item: File. 
3. Select Info in the left window pane. 

4. Under Prepare for Sharing, an alert will appear if a potential 

accessibility issue has been detected.
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5. To view and repair the issues, select Check for Issues and then 

Check Accessibility. 

6. An Accessibility Checker task pane will open, showing the 

inspection results. 

154  |  Microsoft Word 2010



7. Select a specific issue to see Additional Information. 
8. Follow the steps provided to fix or revise the content. 

Microsoft Word 2010  |  155



156  |  Microsoft Word 2010



Technique 11. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Saving to PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

10. Check Accessibility. 

1. Go to menu item: File. 
2. Select Save As. 
3. In the File name box, type a name for the file. 

4. In the Save as type list, select PDF or XPS Document. 
5. Select the Options button. 

6. Under Include non-printing information in the Options 
dialog, ensure that the Document structure tags for 
accessibility check box is selected. 

7. Select OK and Save. 
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Saving to HTML 

1. Go to menu item: File. 
2. Select Save As. 
3. In the File name box, type a name for the file. 

4. In the Save as type box, select Web Page. 
5. Select Save. 
6. Check the HTML file for accessibility (see Technique 10. Check 

Accessibility). 
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To clean up your HTML file 

1. Remove unnecessary styles, line breaks, etc. 

2. Remove unnecessary id, class, and attributes. 

3. Remove font tags. 

4. Remove styles in the <head> tag. 

5. Ensure the <th> tags have a scope attribute. 

6. Remove <p> tags nested inside <th> and <td> tags. 

7. Check for accessibility (see Technique 11, above). 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 12. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Microsoft Accessibility Page 

• Office 2010 Accessibility Tutorials 

• Keyboard shortcuts for Word 2010 

• Customize keyboard shortcuts for Word 2010 

• Accessibility features in Word 2010 

Other Application Features 
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Word 2010’s “Navigation” Feature 

After you have populated your document with content and true 

headings have been applied, you may wish to rearrange the content. 

In order to maintain the integrity and accessibility of the altered 

sequence, you will need to ensure that structural information (e.g., 

heading levels) is adjusted accordingly. 

Word 2010 provides a “Navigation” mechanism which displays all 

parts of the document, such as headings, paragraphs, objects, etc. in 

sequential order. It helps you navigate, access, and manipulate the 

content. You can move headings or subordinate text up or down, 

rearranging their sequence in a way that can be programmatically 

determined and therefore accessible to assistive technologies. 

To use the “Navigation” feature 

1. Go to menu item: View. 
2. In the Show section, select the Navigation Pane check box. 

3. The Navigation pane will open to the left of your document. 

To jump to a location in a document: 

1. Select one of three navigation options: 

1. Select the Browse headings icon 

Note: select the heading to view hierarchical headings and 

content below it. 

2. Select the Browse pages icon 

3. Select the Search text 
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2. Scroll through the sequential list and double-click* on the 

location you would like to jump to 

To move content up or down in a document: 

• Select and drag the content to a new location in the list 

Accessibility Help 

If you are interested in what features are provided to make using 

Word 2010 more accessible to users, documentation is provided in 

the Help system: 

1. Go to menu item: File. 
2. Select Help from the list on the left. 

3. Under the Support section, select the Help icon. 

4. Enter “Accessibility” as your search term in the Help dialog 

box. 
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Microsoft Word 2008 for Mac 

Usage Notes 

At the time of testing (January 26, 2011), Word 2008 for Mac lacks 

several features that enable accessible office document authoring, 

most notably: the ability to add alternative text to image and 

objects. As a result, some of the other features that might otherwise 

support accessibility, such as its extensive templates are not as 

effective. In addition, Word 2008 for Mac does not include an 

accessibility checking feature. 

This guide is intended to be used for documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

Microsoft Word 2008 for Mac  |  163

http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php


File Formats 

The default file format for Word for Mac is Office Open XML 
(DOCX). 

In addition, Word 2008 for Mac offers many other word processor 

and web format saving options. Most of these have not been 

checked for accessibility, but some information and/or instructions 

are available for the following formats in Technique 11 (below): 

• DOC (MS Word 97–2004) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 
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recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using Microsoft Word 2008 for Mac (ver.12.0.0 (071130), 

Mac OS X, Jan. 2011) while creating a DOCX document. Files are 

also easily saved as other file formats, which is useful for checking 

accessibility (see Technique 12, below). 

This document is provided for information purposes only and is 

neither a recommendation nor a guarantee of results. If errors are 

found, please report them to: adod-comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used. 

Word for Mac’s default template for new documents is a blank 

page. The basic installation also includes blank business card, blank 

label templates, and other blank office-related documents. These 

are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Word for Mac. As well, you can edit and modify the 

existing prepackaged templates, ensuring their accessibility as you 

do so and saving them as a new template. 
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To create an accessible template 

1. Create a new document (from the default blank template or 

from one of the prepackaged templates). 

2. Ensure that you follow the techniques in this document. 

3. When you are finished you should also check the accessibility 

of the document (see Technique 10, below). 

4. Go to menu item: File > Save As. 
5. In the Save As box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Memo Template”) may 

increase the prominence of the accessibility status. 

6. In the Format box, select Word Template. 
7. Select Save. 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g., that you previously saved). Otherwise, simply open a 

new (blank) document. 
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1. Go to menu item: File > Project Gallery… 
2. Under Category, select My Templates (or select the location 

you saved your accessible template). 

3. Select the template from the scrolling gallery. 

4. Select Open. 
5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2. Specify Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 
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To change the default language 

1. Go to menu item: Tools > Language… 
2. In the Language dialog, select the language. 

3. Select Default… 

To apply a language directly to selected text 

1. Select the text. 

2. Go to menu item: Tools > Language… 
3. In the Mark selected text as box, select the language from the 

list. 

4. Select OK. 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

At this time, Word 2008 for Mac does not offer a mechanism which 

enables the user to add alternative text descriptions to images or 

objects. [Tested: January 26, 2011] 
When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

Technique 4. Avoid “Floating” Elements 

When images and objects are inserted into Word 2008 for Mac 

documents they default to being an “inline object”. Inline objects 

keep their position on the page relative to a portion of the text. 

A “floating” object keeps its position relative to the page, while 

text flows around it. As content moves up or down on the page, the 

object stays where it was placed. To ensure that images and objects 

remain with the text that references it, always position it as an inline 

object. 

Similarly, avoid placing drawing objects directly into the 
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document (e.g., as borders, to create a diagram). Instead, create 

borders with page layout tools and insert complete graphical 

objects. 

To prevent an image or object from “floating” 

1. Select the object. 

2. Go to menu item: Format > Picture… 
3. Select Layout. 
4. Under Wrapping style, select In Line with Text 
5. Select OK. 

Technique 5. Use Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them more straightforward for readers to 

understand. One of the easiest ways to do this is to use “True 
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Headings” to create logical divisions between paragraphs. True 

headings are more than just bolded, enlarged, or centered text; they 

are structural elements that order and levels provide a meaningful 

sequence to users of assistive technologies. 

Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, etc.) 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.) 

• Do not skip heading levels 

To apply headings 

1. Select text. 

2. If the Formatting Palette is not in view, go to menu item: View 
> Toolbox, Formatting Palette. 

3. In the Formatting Palette, if the Styles section is not open, 

select Styles. 
4. Headings can be found under Pick style to apply. 
5. Select the heading you wish to apply. 
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To modify heading styles 

1. If the Formatting Palette is not in view, go to menu item: View 
> Toolbox, Formatting Palette. 

2. In the Formatting Palette, if the Styles section is not open, 

select Styles. 
3. Headings can be found under Pick style to apply. 
4. Select the menu icon beside the heading you want to modify. 

5. Select Modify Style… 
6. In the Modify Style dialog, make the appropriate changes to 

style characteristics. 

7. Select OK. 

To create a new style 

1. If the Formatting Palette is not in view, go to menu item: View 
> Toolbox, Formatting Palette. 

2. In the Formatting Palette, if the Styles section is not open, 

select Styles. 
3. Headings can be found under Pick style to apply. 
4. Select New Style… 
5. In the Name box, enter a name for the new style. 

6. Format the characteristics of the new style. 

7. Select OK and the new style will be added to the Pick style to 
apply scrolling list. 
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Technique 6. Use Named Styles 

As with “True Headings” (see Technique 5), you should attempt to 

make use of the named styles that are included with the office 

application (e.g., “emphasis”, “caption”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). 

For more information on formatting using named styles, see 

Technique 9. 

Note: While office application suites support headings in much the 

same way, the named styles often differ. 

To use default named styles 

• Default named styles can be applied the same way as headings 

(see Technique 5). 

Technique 7. Use Built-In Document Structuring 
Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 
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screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. Whenever possible, use 

just one row of headings. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 
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other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

To add a table with headings 

1. Go to menu item: Table > Insert > Table… 
2. Select the characteristics of the table and select OK. 
3. Go to menu item: Table > Table Properties… 
4. In the Table Properties dialog, select Row. 
5. Under Options, select the Repeat as header row at the top of 

each page check box 

6. Select OK. 
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7.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Select the text. 

2. If the Formatting Palette is not in view, go to menu item: View 
> Toolbox, Formatting Palette. 
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3. In the Formatting Palette, select Bullets and Numbering if it is 

not already open. 

4. In the Bullets and Numbering dialog, select Type, Bullets for 

bulleted lists or Type, Numbering for numbered lists. 

5. To change the style, select a list style from the Style drop-

down list. 

At this time, it is not possible to modify pre-formatted list styles or 

to create your own list styles. [Tested: January 26, 2011] 

7.3 Columns 

Use Columns feature for placing text in columns. However, because 
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columns can be a challenge for users of some assistive technologies, 

you should consider whether a column layout is really necessary. 

7.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 

7.5 Use a Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To insert a table of contents 

1. Place the cursor in your document where you want to create 

the table of contents. 

2. Go to menu item: Insert > Document Elements > Table of 
Contents. 

3. In the Table of Contents section that opens above the 

document pane, select the style you want to use. 
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To update a table of contents 

1. Select the table, 

2. Select the icon beside Table of Contents, 
3. Select Update Table… 
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7.6 Use Page Numbering 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 

To insert page numbers 

1. Go to menu item: Insert > Page Numbers… 
2. In the Page Numbers dialog, select the page number 

characteristics (Position, Alignment, Show number on first 
page), 

3. Select OK. 
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To format page numbers 

1. In the Page Numbers dialog, select Format… 
2. Select the format characteristics in the Page Number Format 

dialog. 

3. Select OK 
4. Note: These changes are applied to the predefined page format 

styles. It does not create a new page format style. 
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7.7 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File > Properties. 
2. In the Document Properties dialog, select Summary. 
3. Enter the title in the Title text box. 

Note: The title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 
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Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 

• All basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 

color, rather than color alone, to convey information. 

◦ When creating line charts, use the formatting options to 
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create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colors to differentiate the bars 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2). 

• Consider providing the data that you used to create the chart 

in tabular form (e.g. as an appendix). 

Technique 9. Make Content Easier to See 

Here are some other things to keep in mind: 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 
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• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

To change the text size for a default named style 

1. Go to menu item: View > Formatting Palette. 
2. If the Styles section is not open, select Styles. 

3. Under Pick Style to the Style you wish to modify. 

4. Select Modify… 
5. Under Formatting in the Modify dialog box, select the 

appropriate font size. 

6. Exit with OK. 
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9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 
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• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 
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However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Word 2008 for 

Mac’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
Understand 
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10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 
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To add hyperlinks with meaningful text 

1. Type (or paste in) a web address and press spacebar or “Enter” 

to convert into a hyperlink. 

2. Highlight the link. 

3. Go to menu item: Insert > Hyperlink… 
4. Edit the text in the Display box 

5. Select OK. 

Technique 11. Check Accessibility 

At this time, Word 2008 for Mac does not offer a mechanism to 

check for potential accessibility errors in your document prior to 

publishing. [Tested: January 26th, 2011] 
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Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Note: Before saving in other formats, you may want to run the 

Compatibility Report feature by selecting Compatibility Report… 
from the Save As dialog. This checks the compatibility of your 

existing document with the format you have selected save your 

document as. The results of this check are revealed in the 

Compatibility Report dialog, where you have explanations of errors 

and options to fix them. To run this check at any time, go to menu 

item: View > Toolbox, Compatibility Report. 

DOC 

1. Go to menu item: File > Save As… 
2. In the Save As box, type a name for the file. 

3. In the Format box, select Word 97-2004 Document (.doc). 
4. Select Save. 

PDF 

While Word 2008 for Mac allows you to save documents in the PDF 

format. However, at this time, it does not offer an explicit option 

to save your document in the tagged PDF format. [Tested: January 
26th, 2011] 
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To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

Editor’s note:For detailed instructions, see our section on 

how to check accessibility using Adobe Acrobat 

Professional. 

HTML 

1. Go to menu item: File > Save as Web Page… 
2. In the Save As box, type a name for the file. 

3. Select Save. 
4. Check the HTML file for accessibility (see below). 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes. 

• Remove font tags. 

• Remove styles in the <head> tag. 
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• Ensure the <th> tags have a scope attribute. 

• Remove <p> tags nested inside <th> and <td> tags. 

• Check for accessibility. 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

To evaluate HTML accessibility 

Use one of the web accessibility checkers available online, such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results by 

the IDRC. 

• Coming soon… 

Accessibility Help 

If you are interested in what features are provided to make using 

Word 2008 for Mac more accessible to users, documentation is 

provided in the Help system: 

1. Go to menu item: Help 
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2. Enter “Accessibility” as your search term in the Search box 
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Microsoft Word 2007 

Usage Notes 

At the time of testing (January 10, 2011), Word 2007 provides a set of 

accessibility features that is sufficient to enable the production of 

accessible digital office documents. However, Word 2007 does not 

include an accessibility checking feature. 

This guide is intended to be used for documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 
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File Formats 

The default file format for Word 2007 is Office Open XML (DOCX). 
In addition, Word 2007 offers many other word processor and 

web format saving options. Most of these have not been checked for 

accessibility. 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Microsoft Word 2007 

(ver.12.0.6545.5000, Windows 7, Jan. 2011) while creating a 
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DOCX document. Files are also easily saved as other file 

formats (see Technique 11). 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. If 

errors are found, please report them to: adod-

comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Accessibility Checking, 

below). 

Word 2007’s default template for new documents is a blank page. 

The basic installation also includes blank business card, blank label 

templates, and other blank office-related documents. These are all 

accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Word 2007. As well, you can edit and modify the existing 

prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 

To create an accessible template 

1. Create a new document (from the default blank template or 
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from one of the prepackaged templates) 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (See Technique 10, below) 

4. Go to menu item: Office > Save As > Word Template 
5. Save the template in the Microsoft > Templates folder 

6. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Memo Template”) may 

increase the prominence of the accessibility status. As well, 

filling in the text box labeled Tags with the term “accessibility” 

may improve its searchability as an accessible file. 

7. Select Save 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 
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1. Go to menu item: Office > New 
2. Under Templates, select My templates… 

3. In the New document dialog, select your accessible template 

from the list in the My Templates tab 

4. Select OK 
5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 
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Technique 2. Specify Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To change the default language 

1. In the operating system, activate the keyboard layout for the 

language in which you want to create and edit text 

2. Right-click* the status bar at the bottom of the window, 

ensure that Language is selected, this displays a reminder of 

the active keyboard layout in the status bar 

Word 2007 has an automatic language detection mechanism, which 

can automatically detect the language of your text. If you type a 

section of text in a different language than the rest of your 

document, Word 2007 will programmatically mark the language of 

that section of text appropriately. 
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To turn on automatic language detection 

1. Go to menu item: Review 
2. In the Proofing section, select the Set Language button 

3. In the Language dialog, select the Detect language 
automatically check box 

To apply a language directly to selected text 

1. Select the text 

2. Go to menu item: Review 
3. In the Proofing section, select the Set Language button 

4. In the Mark selected text as box, select the language from the 

list 

5. Select OK 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 

206  |  Microsoft Word 2007



Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information conveyed by the 

image within the body of the document, providing the images as 

an alternate to the text. In that case, you do not have to provide 

alternate text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* the object 

2. Select Size… 
3. Select the Alt Text tab in the Size dialog 

4. Fill in the Alternative Text 
5. Select Close 
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When inserting a very small image, or resizing a larger image to be 

much smaller, Word 2007 assumes that the image is intended to be a 

bullet-point for a bulleted list. Once Word 2007 defines the image as 

a bullet, the option to add alternative text disappears. Select Undo, 

to redefine the bullet as an image. When you right-click* the image, 

select Format Picture… and select the Alt Text tab in the Format 
Picture dialog. Alternative text can be found, or can be entered, into 

the Alternative text box. 
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Technique 4. Avoid 'Floating' Elements 

When images and objects are inserted into Word 2007 documents 

they default to being an “inline object”. Inline objects keep their 

position on the page relative to a portion of the text. A “floating” 

object keeps its position relative to the page, while text flows 

around it. As content moves up or down on the page, the object 

stays where it was placed. To ensure that images and objects remain 

with the text that references it, always position it as an inline object. 

Similarly, avoid placing drawing objects directly into the 

document (e.g., as borders, to create a diagram). Instead, create 

borders with page layout tools and insert complete graphical 

objects. 

To prevent an image or object from “floating” 

1. Select the object 

2. Go to menu item: Page Layout 
3. Select Position from the Arrange section 

4. Select In Line with Text 

Technique 5. Use Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them more straightforward for readers to 

understand. One of the easiest ways to do this is to use “True 
Headings” to create logical divisions between paragraphs. True 

headings are more than just bolded, enlarged, or centered text; they 

are structural elements that order and levels provide a meaningful 

sequence to users of assistive technologies. 
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Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, etc.) 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.) 

• Do not skip heading levels 

To apply headings using the Styles toolbar 

1. Select text 

2. Go to menu item: Home 
3. In the Styles section, select the heading you wish to apply 

Note: You can scroll through the multiple heading styles using 

the arrows on the right side of the Styles section. You can also 

change the Style design by selecting the Change Styles button 

on the right. 

To modify heading styles 

1. Go to menu item: Home 
2. In the Styles section, right-click* the style you wish to use 

from the Styles Gallery 
3. Select Modify 
4. In the Modify Style dialog, make the appropriate changes to 

style characteristics 
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5. Select OK 

To return to the default heading styles 

1. Go to menu item: Home 
2. In the Styles section, select Change Styles 
3. Select Style Set 
4. Select Word 2007 from the list 

Technique 6. Use Built-In Document Structuring 
Features 

6.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 
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• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. Whenever possible, use 

just one row of headings. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 
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To add a table with headings 

1. Go to menu item: Insert 
2. In the Tables section, select the Tables icon 

3. Select the number of rows and columns you would like your 

table to have 

4. Select the table and a Table Tools menu item should appear 

5. Go to menu item: Table Tools > Design 
6. In the Table Style Options section, select the Header Row 

check box 

6.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Go to menu item: Home 
2. In the Paragraph section, select the Bullets icon for unordered 

lists or select the Numbering icon for ordered lists 

3. To choose a different list format, select the arrow beside the 

icon 

4. Select a format from the format Library that appears in the 

drop-down menu 
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To modify list styles 

1. Go to menu item: Home 
2. In the Paragraph section, select the arrow beside the Bullets 

icon for unordered lists or select the arrow beside the 

Numbering icon for ordered lists 

3. Select Define New Bullet… to create a new unordered list 

format 

4. Select Define New Number Format… to create a new ordered 

list format 

5. In the New Bullet dialog or the New Number Format dialog, 

select the list characteristics 

6. Select OK 

6.3 Columns 

Use Columns feature for placing text in columns. However, because 

columns can be a challenge for users of some assistive technologies, 

you should consider whether a column layout is really necessary. 

6.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 

6.5 Use a Table of Contents 

Creating an index or table of contents to outline office document 
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content can provide a means of navigating the meaningful sequence 

of content. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To insert a table of contents 

1. Place the cursor in your document where you want to create 

the table of contents 

2. Go to menu item: References 
3. In the Table of Contents section, select Table of Contents 
4. Select the style that you want to use 

To update a table of contents 

1. Select the table 

2. Go to menu item: References 
3. In the Table of Contents section, select the Update Table 

button 

6.6 Use Page Numbering 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 
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To insert page numbers 

1. Go to menu item: Insert 
2. In the Header & Footer section, select Page Number 
3. Select where you would like to insert your page numbers 

4. Select the style of page number you would like to use 

To format page numbers 

1. Go to menu item: Insert 
2. In the Header & Footer section, select Page Number 
3. Select Format Page Numbers… 
4. In the Page Number Format dialog, select the page format 

characteristics you would like to use 

Note: These changes are applied to the predefined page format 

styles. It does not create a new page format style. 

6.7 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: Office > Prepare > Properties 
2. In the Document Properties section that appears, select the 

Title text box 

3. Enter the Title 
Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 
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above. 

Technique 7. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 

• All basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 

color, rather than color alone, to convey information. 

◦ When creating line charts, use the formatting options to 

create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colors to differentiate the bars 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2) 

• Consider providing the data that you used to create the chart 

in tabular form (e.g. as an appendix). 

Technique 8. Make Content Easier to See 

Here are some other things to keep in mind: 
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8.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

To change the text size for a default named style 

1. Go to menu item: Home 
2. In the Styles section, right-click* the Style you wish to modify 

3. Select Modify Style 
4. Under Formatting in the Modify dialog box, select the 

appropriate font size 
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5. Exit with OK 

8.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 
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Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

8.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 
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8.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Word 2007’s 

“Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

8.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 9. Make Content Easier to Understand 

9.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 
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• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

9.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To add hyperlinks with meaningful text 

1. Type (or paste in) a web address and press spacebar or “Enter” 

to convert into a hyperlink 

2. Select the link and right-click* 

3. Select Edit Hyperlink (Ctrl + K) 

4. Edit the text in the Text to display box 
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Technique 10. Check Accessibility 

At this time, Word 2007 does not offer a mechanism to check for 

potential accessibility errors in your document prior to publishing. 

[Tested: January 10th, 2011] 
In order to get some indication of the accessibility of your 

document or template, then you may consider saving the file into 

HTML or PDF in order to perform an accessibility check in one of 

those formats, as described below. 

To evaluate HTML accessibility 

Save the document into HTML format and use one of the web 

accessibility checkers available online, such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option. 

3. Select the Start Checking button. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 11. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see below. 

1. Make sure the file is saved as a DOCX (Older DOC files are not 

compatible with the checker). 

2. Go to menu item: Office > Save As > PDF or XPS 
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3. In the File name box, type a name for the file 

4. Select the Options button 

5. Under Include non-printing information, ensure that the 

Document structure tags for accessibility check box is 

selected 

6. Under PDF options, ensure that Bitmap text when fonts may 
not be embedded check box is de-selected 

7. Select OK and Save 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

HTML 

1. Go to menu item: Office > Save As > Other Formats 
2. In the File name box, type a name for the file 

3. In the Save as type box, select Web Page 
4. Select Save 
5. Check the HTML file for accessibility (see Technique 10, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 10, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 
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To evaluate HTML accessibility 

Save the document into HTML format and use one of the web 

accessibility checkers available online, such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

Technique 12. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Office 2007 Accessibility Tutorials 

• Save as DAISY 

Accessibility Help 

If you are interested in what features are provided to make using 

Word 2007 more accessible to users, documentation is provided in 

the Help system: 

1. Select the Help icon from the right corner of the Toolbar or 

select F1 
2. Enter “Accessibility” as your search term in the Help dialog box 
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Pages for Mac 

Usage Notes 

At the time of testing (September 30, 2010), Pages ’09 lacks several 

features that enable accessible office document authoring, most 

notably: the ability to add alternative text to image and objects. As 

a result, some of the other features that might otherwise support 

accessibility, such as its extensive templates are not as effective. 

Editor’s note: In later versions of Pages, users have the 

ability to add alt text to images and graphical objects. Apple 

has added significant accessibility improvements to its 

iWork applications, but an accessibility checker is not a 

feature yet. 

In addition, Pages does not include an accessibility checking 

feature. 

What’s an “Office Document”? 

You should use these techniques when you are using Pages to create 

documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 
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include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Pages is the native iWork format. 

In addition, Pages offers many other word processor and web 

format saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12: 

• MS Word 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 
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is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using iWork Pages ’09 (ver.4.0.3 (766), Mac OS X, Sept. 

2010) and Pages (version 8.1) while producing a document in the 

native iWork file format. Files are also easily saved as other file 

formats (see Technique 12). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 
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template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

The default template for new documents in Pages is a blank page. 

The basic installation also includes blank letter templates and blank 

business reports. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Pages. As well, you can edit and modify the existing 

prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 

To create an accessible template 

1. Go to menu item: File > New or File > New from Template 
Chooser… (Shift+Apple+N). 

2. In the Template Chooser dialog, select the Blank template or 

select one of the other existing template designs. 

3. A new document in your selected template style will open. 

4. Ensure that you follow the techniques in this document. 

5. When you are finished you should also check the accessibility 

of the document (See Accessibility Checking, below). 

6. Go to menu item: File > Save as Template… 
7. In the Export As box, type a name for the template. Using a 

descriptive template name (e.g., “Accessible Memo Template”) 

will increase the prominence of the accessibility status. 

8. Specify a folder in which to save your template. To save the 

template in a different location than the default, create a new 

folder in the Templates folder. The folder name is then used as 

a template category in the Template Chooser. 

Note: By default, it will be saved in your home folder in 

Library/Application Support/iWork/Pages/Templates/My 

Templates pane of the Template Chooser. 

Pages for Mac  |  233



9. Click Save. 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g., that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > New from Template Chooser…
(Shift+Apple+N). 

2. In the Template Chooser dialog, select My Templates from the 

left pane. 
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3. Select your accessible template and click Choose. 

Technique 2. Specify Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To apply a language directly to selected text 

1. Highlight the text 

Note: To change the language of the entire document, do a 

select all to select all the text in the document. 

2. Go to menu item: View > Show Inspector. 

3. In the Inspector dialog, select the Text button. 
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4. In the Text section, click the More tab. 

5. In the Language section, select the language from the drop-

down list. 

Editor’s note: In later versions of Pages, instructions for 

applying language to specific text is not specified. Users 

can, however, change a document’s formatting and 

language. 

For detailed instructions, see how to format a document 

for another language in the Pages User Guide for Mac. 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

At this time, Pages ’09 does not offer a mechanism which enables 

the user to add alternative text descriptions to images or objects. 

[Tested: September 28, 2010] 

Editor’s note: In later versions of Pages, users can add 

alternative text descriptions for images and objects: 

1. Click the image to select it, then, in the Format 
sidebar, click the Image tab. 

2. Click the Description text box, then enter your 

text. 

For more details, see the section on how to add an image 

description in the Pages User Guide for Mac. 

When  using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

Technique 4. Avoid “Floating” Elements 

Pages will default the position of an inserted image or object 

depending on the method that is used to insert it. If you use a 

method that requires you to simply drag-and-drop the image or 

object onto the document, it will automatically be positioned as 

“floating”. 

A “floating” object keeps its position relative to the page, while 

text flows around it. As content moves up or down on the page, the 

object stays where it was placed. To ensure that images and objects 
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remain with the text that references it, press the Command key and 

then drag the image onto the document or follow the steps below. 

To import image as an inline object 

1. Place the insertion point wherever you want the image to 

appear. 

2. Go to menu item: Insert > Choose. 
3. Select the image file. 

4. Click Insert. 
Note: You can always ensure your image or object is positioned 

with the text that references it. Select the image or object, 

then go to the Format bar and ensure that Inline button is 

selected. 

Editor’s note: For later versions of Pages, the instructions 

for adding an image inline is slightly different: 

1. Click the Media button in the toolbar. 

2. Choose Photos, then drag an image from a photo 

library to the page or to a media placeholder. 

For more details, see how to place objects inline with text 

in the Pages User Guide for Mac. 

Technique 5. Use Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them more straightforward for readers to 
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understand. One of the easiest ways to do this is to use “true 
headings” to create logical divisions between paragraphs. True 

headings are more than just bolded, enlarged, or centered text; they 

are structural elements that order and levels provide a meaningful 

sequence to users of assistive technologies. 

Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, etc.) 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.) 

• Do not skip heading levels 

To apply headings to selected text 

1. Highlight selected text. 

2. Go to the Format Bar and select the Choose a paragraph style 
button. 

3. Select the style you would like to apply from the drop-down 

menu. 
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To create new heading styles 

1. Highlight text and format with the characteristics you would 

like to apply to a new heading. 

2. Go to menu item: Format > Create New Paragraph Style from 
Selection… 

3. In the New paragraph style dialog, enter a heading style name 

in the Name text box. 

4. Select OK. 

Editor’s note: For later versions of Pages, after selecting 

text, follow these steps to create new heading styles: 
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1. From the Format sidebar, click the paragraph style 

name at the top of the sidebar. 

2. Click the New Style button at the top of the 

Paragraph Styles menu. A new style with a 

placeholder name appears in the menu. 

3. The Paragraph Styles menu with a callout to the 

New Style button. 

4. Type a name for the new style, then click outside 

the menu to close it. 

For more details, see how to create a paragraph style in 

the Pages User Guide for Mac. 

Technique 6. Use Named Styles 

As with “True Headings” (see Technique 5), you should attempt to 

make use of the named styles that are included with the office 

application (e.g., “emphasis”, “caption”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

To use default named styles 

• Default named styles can be applied the same way as headings 

Pages for Mac  |  243

https://support.apple.com/en-ca/guide/pages/tanc48ac66bd/8.2/mac/1.0


(see Technique 5). 

Technique 7. Use Built-In Document Structuring 
Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 
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break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

To add a table with headings 

1. Position the cursor at the location in the document you would 

like to add the table. 

2. Go to menu item: Insert > Table. 
3. Go to menu item: View > Show Inspector. 
4. In the Inspector dialog, select Table inspector. 
5. Select the Table tab. 

6. In the Headers & Footer section, click the Choose the number 
of header columns button or the Choose the number of 
header rows button. 
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7. Select the number of header rows or columns you would like 

your table to have. 

7.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Place the cursor where you would like to insert the list or 

highlight the text of a list you already entered into your 

document. 

2. In the Toolbar, click the Inspector button to show the 

inspector window. 

3. In the Inspector dialog, click the Text inspector button. 

4. Select the List tab. 

5. In the Bullets & Numbering section, format your list style 

using the drop-down menus. 
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Editor’s note: In later versions of Pages, follow these 

instructions to create an ordered or unordered list: 

1. Select the text you want to format. 

2. In the Format sidebar, click the Style button near 

the top. 

Note: If the text is in a text box, table, or shape, first 

click the Text tab at the top of the sidebar, then click 

the Style button. 

3. Click the pop-up menu next to Bullets & Lists, then 

choose a list style. 

For more details, see how to format a list in the Pages 

User Guide for Mac. 

7.3 Columns 

Use Columns feature for placing text in columns. 

Note: Because columns can be a challenge for users of some assistive 

technologies, consider whether a column layout is really necessary. 

7.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 
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7.5 Use a Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To generate a Table of Contents 

1. In the Toolbar, click Inspector. 
2. In the Inspector dialog, click the Document button. 

3. Select the TOC tab. 

4. Select the checkboxes next to the paragraph styles whose text 

you want to appear in the table of contents. 

5. In the #’s column, select those paragraph styles for which you 

want page numbers to appear. 
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6. Place the insertion point at the beginning of the line where you 

want the table of contents to appear 

Note: Table of contents created in Pages list only the content 

that follows it, up until the next table of contents. To create a 

master table of all the contents in your document, it must be 

the only table of contents and must be placed at the beginning 

of the document. 

7. Go to menu item: Insert > Table of Contents. 

Editor’s note: In later versions of Pages, follow these 

instructions to generate a table: 

1. If you haven’t already done so, apply paragraph 

styles to the text you want to appear in the table of 

contents. 

2. Click the View menu button in the toolbar, then 
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choose Table of Contents. 

3. Click Edit at the top of the sidebar, then select the 

paragraph styles you want to include. 

4. Place the insertion point where you want the table 

of contents to appear, then do one of the following: 

◦ Add a TOC for the whole document: Click the 

Insert Table of Contents button at the bottom 

of the Table of Contents sidebar. Entries are 

gathered from the entire document. 

◦ Add a TOC for this section: Choose Insert > 

Table of Contents > Section. Entries are 

gathered from only the section where you’re 

inserting the table of contents. 

◦ Add a TOC for content up to the next TOC: 

Choose Insert > Table of Contents > To Next 
Occurrence. Entries are gathered between this 

table of contents and the next table of contents. 

5. To format the text and add leader lines, click the 

table of contents to select it. When the table of 

contents is selected, a blue line appears around it and 

its text is highlighted in blue. 

For more details, see how to insert a table of contents 

into a word-processing document in the Pages User Guide 

for Mac. 

To update a Table of Contents 

1. In the Toolbar, click Inspector. 
2. In the Inspector dialog, click the Document button. 
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3. Select the TOC tab. 

4. Click Update Now at the bottom of the dialog. 

Note: You can also automatically update by clicking any entry 

in the table of contents. 

7.6 Use Page Numbering 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 

content. 

To Insert Page Numbers 

1. Go to menu item: Insert > Auto Page Numbers… 
2. In the Insert Page Numbers dialog, format the page number 

using the available options. 

3. Select Insert. 

7.7 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. In the Toolbar, select Inspector. 
2. In the Inspector dialog, select the Document inspector 

button. 
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3. Click the Info tab. 

4. In the Title box, type a descriptive name for the document. 

Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 
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To create a chart 

1. Go to menu item: Insert > Chart. 
2. Select a chart type from the list. 

3. Update the Chart Data Editor with the data you would like to 

display in the chart. 

4. Close the Chart Data Editor. 

To add titles and labels 

1. Select the chart. 

2. Go to menu item: View > Show Inspector. 
3. In the Chart Inspector, select Chart. 
4. Ensure the Show Title and Show Legend check boxes are 

selected. 

5. Select Axis. 
6. Under Value Axis (Y) and Category Axis (X), select Show Title 

and Show Value Labels from their respective drop-down 

menus. 

To change to a different predefined Chart Type 

1. Select the chart. 

2. Go to menu item: View > Show Inspector. 
3. Select a chart type from the Choose a chart type drop-down 

menu. 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 
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different types of dotted lines to facilitate legibility for users 

who are color blind. 

• When creating bar charts, it is helpful to apply texture instead 

of color to differentiate the bars. 

• Change the default colors to a color safe or gray-scale palette. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2). 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 
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printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 
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information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Pages’ “Change 

Tracking” functionality to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Images of Text 

Before you use an image to control the presentation of text (e.g., 

256  |  Pages for Mac

https://www.google.com/search?q=convert+image+to+grayscale+online
https://www.google.com/search?q=convert+image+to+grayscale+online


to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the steps noted in Technique 

3. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 
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list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To add hyperlinks with meaningful text 

1. In the Toolbar, click Inspector. 

2. Click the Link inspector button. 

3. Select the Hyperlink tab. 

4. Select the Make all hyperlinks inactive checkbox. 

5. Edit the hyperlink text 

Note: While editing the hyperlink text, you have deactivated all 

hyperlinks in the document. To reactive the hyperlinks, 

deselect the Make all hyperlinks inactive checkbox. 
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Editor’s note: For more details on this topic, see how to 

link to a webpage, email, or page in the Pages User Guide 

for Mac. 

Technique 11. Check Accessibility 

At this time (December 2019), Pages does not offer a mechanism 

to check for potential accessibility errors in your document prior 

to publishing. As well, it is not currently possible to export Pages 

documents as HTML. 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

Editor’s note: For detailed instructions, see how to 

export to Word, PDF, or another file format in the Pages 

User Guide for Mac. 

To evaluate HTML accessibility 

Save the document into HTML format and use one of the web 

accessibility checkers available online, such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 
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To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option. 

3. Select the Start Checking button. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when exporting to formats 

other than the default. 
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At this time (December 2019), it is not possible to export Pages 

documents as HTML files. 

PDF, Word, RTF, or plain text 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 

1. Go to menu item: File > Export. 
2. Select the type of format you would like to export, click Next. 
3. In the Save As box, type a name for the document. 

4. Choose where you want to save the document. 

5. Click Export. 
Note: Exporting a plain text file removes all formatting. Pages 

documents may not export identically in Word, due to text 

layout differences. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Apple Pages Support 

• Apple: Create accessible documents with Pages 
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Accessibility Help 

If you are interested in what features are provided to make using 

Pages more accessible to users, documentation is provided in the 

Help system: 

1. Go to menu item: Help 
2. Enter a search term into the Search box 
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OpenOffice Writer and 
LibreOffice Writer 

Usage Notes 

The techniques described in this document apply both to 

OpenOffice Writer 3.4.0 and LibreOffice 4.0.4.2. There are 

sometimes minor differences in the toolbars and dialogs between 

the two office suites, but these differences do not require different 

instructions. 

At the time of testing (July 2013), Writer provides a set of 

accessibility features that is sufficient to enable the production 

of accessible digital office documents. An accessibility checking 

feature is available by installing the AccessODF extension. 

Editor’s note: For later versions of OpenOffice Writer and 

LibreOffice, the accessibility checking features made 

available through AccessODF is no longer stable (tested on 

OpenOffice 4.1.7 and LibreOffice 6.3.1.2). 

We recommended using other applications, such as 

current versions of Microsoft Word, which has a robust 

suite of tools available for creating accessible documents. 

This guide is intended to be used for documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 
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• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Writer is Open Document Text (ODT). In 

addition, Writer offers many other word processor and web format 

saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12. 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 
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• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Several techniques refer to the Styles and Formatting dialog. By 

default, this is a floating dialog but it can also be docked, so it 

becomes a panel. When the dialog or panel is open, keyboard users 

can navigate to it using the key F6. The same applies to the 

Navigator, which can either float over the editing area or be docked 

next to it. 

Disclaimer and Testing Details: 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Writer (ver. 3.4.0, Windows 7, 32 

bits, July 2013) while creating an ODT document. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. If 

errors are found, please report them to: adod-

comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 
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as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

Writer’s default template for new documents is a blank page. 

The basic installation also includes blank business card and blank 

label templates. These are all fairly accessible by virtue of being 

blank. However, you should make the default language of a template 

unambiguous (see Technique 2). 

It is possible to create your own accessible templates from 

scratch in Writer. As well, you can edit and modify the existing 

prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 

To create an accessible template 

1. Create a new document (either blank or from an existing 

template). 

2. Ensure that you follow the techniques in this document. 

3. When you are finished you should also check the accessibility 

of the document (See Accessibility Checking, below). 

4. Go to menu item: File > Properties. 
5. Use the Title and/or Comments to indicate the accessibility 

status of the template. Using Title (e.g., “Accessible Memo 

Template”) will increase the prominence of the accessibility 

status because this is used in place of the template’s file name. 

Comments can be used to add more information if necessary 

(e.g., “This memo template has been checked for accessibility.”). 
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6. Close the dialog with OK. 
7. Go to menu item: File > Templates > Save. 
8. In the New Template box, type a name for the template. 

9. Select the category you would like to save it in, under 

Categories. 
Note: the category is simply the folder into which you are 

saving the template. 

10. Close the dialog with OK. 
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To select an accessible template 

Only use these steps if you have an accessible template available 

(e.g. that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: File > New > Templates and Documents. 
2. Select the Templates icon. 

3. Select a template document from the list. 

Note: A properties pane appears on the right side of the 

window, where you can read the document properties (Title, 

By, Date, Modified by, Modified on, Description, and Size). If 

you placed information about the accessibility of the template 

in the Title and/or Comments when you created the template 

(see above), this will be displayed in the Title and/or 

Description, respectively. 

4. Select Open. 
5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
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to preserve accessibility. 

Technique 2. Specify Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To select a language for the whole document 

1. Go to menu item: Tools > Options. 
2. Select Language Settings > Languages. 
3. Under Default languages for documents, select the document 

language for all newly created documents. 

Note: Writer uses three categories of languages: “Western 

languages”, “Asian languages” and CTL languages (complex text 

layout). For monolingual documents in a Western language, 

you should change the values for Asian languages and CTL 

languages from their defaults to “None”. Under default 

languages for documents, enable “Show UI elements for UI 

elements for East Asian languages” and “Show UI elements for 

Bi-Directional writing”. Then set the values for Asian and CTL 

to “None”. You can then again disable the UI elements for these 

languages again. 

Tip: Do this for all your templates. 

4. Close the dialog with OK. 
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To select a language for a paragraph style 

1. Place the cursor in the paragraph using the paragraph style 

you want to edit. 

2. Right-click* and go to menu item: Edit Paragraph Style. 
3. Select the Font tab. 

4. Select the Language and select OK. 
Note: All paragraphs formatted with the current paragraph 

style will have the selected language. 
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To select a language for hyperlinks 

The default language of hyperlinks in Writer is “None”. If all or most 

hyperlinks in a document are in the same language, you should 

modify the style for hyperlinks. 

1. Go to menu item: Format > Styles and Formatting. 
2. In the Styles and Formatting dialog, select the Character 

Styles icon. 

3. Right-click* on the style Internet Link. 
4. Select Modify… 
5. Select the Font tab. 

6. Set the language to English (or the Western language that you 

use most). If the UI for non-Western languages is enabled, set 

the non-Western languages to “None”. 

Tip: Set the language for the style Internet Link in all your 

templates. 
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To apply a language directly to selected text 

1. Select the text to which you want to apply a language. 

2. Go to menu item: Format > Character. 
3. Select the Font tab. 

4. Select the Language. 
5. If the UI for non-Western languages is enabled, set the non-

Western languages to “None”. 

6. Select OK. 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

Some issues have been observed with Writer involving the loss of 

alternative text and longer descriptions (e.g., when images anchored 

to a paragraph are changed to anchor as characters, when a caption 

is added). We suggest that you guard against this data loss by 

keeping backups and by setting image anchoring and captions 

before adding the alternative text. 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank. 

• If the image contains meaningful text, ensure all 

of the text is replicated. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences. 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below. 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone. 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

Alternatively, you can include the same information conveyed by the 

image within the body of the document, providing the images as 

an alternate to the text. In that case, you do not have to provide 

alternate text within the image. 

Note: When inserting a new image or object in place of an existing 

image or object, the alternative text and description will remain the 

same. This is helpful if you are inserting an updated version of an 

image, whose meaning and context has not change. However, when 

inserting an entirely new image or object, you will be required to 

change the title and description fields accordingly. 

Note: When inserting a picture or object that is too large for the 

height or width of the page, it is best to reduce the size before 

inserting it into the document. This results in a smaller file size and 

usually better image quality. 

To add alternative text to images and graphical objects 

1. Right-click* the object. 
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2. Go to menu item: Picture. 
3. Select the Options tab in Picture dialog. 

4. Fill in Alternative Text box. 

Note: the Alternative Text is also the Title of the object. 

To add long descriptions to images 

1. Right-click* on object. 

2. Select Description… option. 

3. Enter description in Description box. 
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Technique 4. Avoid “Floating” Elements 

When images and objects are inserted into Writer documents they 

default to “floating” with an anchor “To Paragraph”. This makes 

them difficult to select with the keyboard, so “floating” should be 

prevented by anchoring them “As Character”. 

A “floating” object keeps its position relative to the page, while 

text flows around it. As content moves up or down on the page, 

the object stays where it was placed. To ensure that images and 

objects remain with the text that references it, always position it has 

attached to a character at the end of the in-text reference. 

Similarly, avoid placing drawing objects directly into the 

document (e.g., as borders, to create a diagram). Instead, create 

borders with page layout tools and insert complete graphical 

objects. 

To prevent an image or object from “floating” 

1. Right-click* the object. 
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2. Select Anchor > As Character option. 

Technique 5. Use Headings 

Any documents that are longer than a few paragraphs require 

structuring to make them more straightforward for readers to 

understand. One of the easiest ways to do this is to use “True 
Headings” to create logical divisions between paragraphs. True 

headings are more than just bolded, enlarged, or centered text; they 

are structural elements that order and levels provide a meaningful 

sequence to users of assistive technologies. 

Tips for headings 

• Use the default headings styles provided 

(“Heading “, “Heading 2”, etc.). 

• Nest headings properly (e.g., the sub-headings 

of a “Heading 1” are “Heading 2”, etc.). 

• Do not skip heading levels. 

To apply headings from the Formatting Toolbar 

1. Highlight the text that you want to make into a navigational 

heading. 

2. Select the desired heading from the dropdown list in the 

Formatting Toolbar. 
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To apply headings using the Styles and Formatting panel 

1. Highlight the text that you want to make into a navigational 

heading. 

2. Go to menu item: Format > Styles and Formatting. 
3. Double-click* the desired heading style. 

Note: If a heading style is modified in the Styles and 
Formatting panel, the modification will apply to every heading 

of that style. 

To apply headings using keyboard shortcuts (up to Heading 5) 

1. Highlight the text that you want to make into a navigational 

heading. 

2. Select Ctrl+1 (for Heading 1), Ctrl+2 (for Heading 2), … Ctrl+5 

(for Heading 5). 
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To modify heading styles 

1. Go to menu item: Format > Styles and Formatting (F11). 

2. Select the style to modify from the list. 

3. Right-click* and select: Modify… 
4. In the Paragraph Style dialog, select the Organizer tab. 

5. In the Name box, enter a unique style name. 

6. Format the heading style using the available formatting options 

in the various tabs. Make sure your selections align with the 

techniques in this document. 

7. Select OK. 

Technique 6. Use Named Styles 

As with “True Headings” (see Technique 5), you should attempt to 

make use of the named styles that are included with the office 

application (e.g., “emphasis”, “caption”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Writer provides named “paragraph styles” for “caption”, “endnote”, 

etc. Styles for strong emphasis, emphasis, source code and 

quotations are not paragraph styles but “character styles”. You can 

access character styles by selecting the Character Styles icon in the 

Styles and Formatting dialog. 
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To use default named styles 

• Default named styles can be applied the same way as headings 

(see Technique 5). 

Technique 7. Use Built-In Document Structuring 
Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 
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dividing complex data sets into separate smaller 

tables, where possible. 

• Always set the header to show at the top of each 

page. Also set the table to break between rows 

instead of in the middle of rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cell labels should be concise and 

clear. 

To add a table with headings 

1. Go to menu item: Insert > Table (Ctrl+F12). 

2. Enter a name for the table. 

3. Specify the number of columns and rows in the table. 

4. Select the Heading check box. 

5. Select the Repeat heading check box. 

6. Indicate the number of rows you want to use for the heading in 

The first…rows spinner box. 

Note: Whenever possible, keep tables simple with just 1 row of 
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headings. 

To add table headings manually 

1. Highlight the table cells that should be headers. 

2. Go to menu item: Format >Styles and Formatting (F11). 

3. Select the Heading check box and make sure that Repeat 
heading is checked. 

To make tables break between rows instead of in the middle of 
rows 

1. Place the cursor inside the table. 

2. Go to menu item: Table > Table Properties. 
3. Select the Text Flow tab. 

4. Unselect the check box Allow row to break across pages and 
columns. 

5. Select OK. 
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7.2. Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

This applies a paragraph style for lists that makes sure that assistive 

technology and other software can recognize the content as a list. 

1. Select text. 

2. Go to menu item: Format > Styles and Formatting. 
3. In the Styles and Formatting dialog, select a list style such as 

List 1 or Numbering 1. 

Note: Do not select the style “List”: this style is reserved for 

modifying all list styles or numbering styles at once. 

There are two methods for adding visual list formatting to this list: 

the first one modifies the applied paragraph style: 

1. Go to menu item: Format > Styles and Formatting. 
2. Right-click* the paragraph style you applied to the content 

(e.g., List 1 or Numbering 1). 

3. Select Modify… 
4. In the Paragraph Style dialog, select the Outline & Numbering 

tab. 

5. Select a Numbering Style (this drop-down list also contains 

styles for unordered lists). 

6. Select the Indents and Spacing tab. 

7. Set the indent values you would like to use for this list type. 

8. Select OK. 
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The second method changes the visual formatting of a list without 

changing all lists based on the same style: 

1. Select the list 

2. Go to menu item: Format > Bullets and Numbering. 
3. In the Bullets and Numbering dialog, select the Bullets tab for 

unordered lists or the Numbering type tab for ordered lists. 

4. Select a list style from the Selection gallery. 

5. Select OK. 

To create sublists 

This is the only way to create a true sublist (i.e. a list that is 

(internally) a child list of the list item above it) instead of a list that is 

merely indented more from the margin. 

1. Select the list items that should become a sublist. 

2. On the Bullets and Numbering toolbar, select the button 

Demote One Level or the button Demote One Level with 
Subpoints. 

To create new list styles 

1. Go to menu item: Format > Styles and Formatting. 
2. In the Styles and Formatting dialog, select the List Styles icon. 

3. Right-click* a style from the list. 

4. Select New… 
5. In the Numbering Style dialog, enter a name for the list style 

in the Name box. 

6. Format the list using the available formatting options in the 
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various tabs. 

7. Select OK. 

Note: This does not create new paragraph styles but new formatting 

styles that you can apply to paragraph styles for lists. Even though 

the names for the formatting styles (List 1, Numbering 1 etc.) that 

appear when you select the List Styles icon are the same as some 

of the paragraph styles that appear when you select the Paragraph 

Styles icon, their purpose is different: the Paragraph Styles are for 

document structure and other paragraph features (e.g. indent), the 

List Styles are for the numbering or bullet style. 

7.3 Columns 

Use the Columns feature for placing text in columns. 

Note: Because columns can be a challenge for users of some 

assistive technologies, consider whether a column layout is really 

necessary. 

7.4 Page Breaks 

Start a new page by inserting a page break instead of repeated hard 

returns. 

To insert a page break, use the shortcut Ctrl + Enter or go to 

the menu item Format > Manual Break and select Page Break (the 

default option). 
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7.5. Use a Table of Contents 

Creating an index or table of contents to outline office document 

content can provide a means of navigating the meaningful sequence 

of content. 

The best way to generate a table of contents is after applying the 

predefined heading styles, such as “Heading 1” as described above, 

to the headings that you want to include in your table of contents. 

After you apply these styles, you can then create a table of contents. 

To insert a Table of Contents 

1. Select in your document where you want to create the table of 

contents. 

2. Go to menu item: Insert > Indexes and Tables > Indexes and 
Tables. 

3. Select the Index/Table tab. 

4. Select Table of Contents in the Type dropdown. 

5. Select OK. 

To use a different paragraph style as a Table of Contents entry 

1. Select in your document where you want to create the table of 

contents. 

2. Go to menu item: Insert > Indexes and Tables > Indexes and 
Tables. 

3. Select the Index/Table tab. 

4. Select Table of Contents in the Type box. 

5. In the Create from area, select the Additional Styles check 

box. 

6. Select the (…) button next to the check box. 
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7. In the Assign Styles dialog, select the style in the list. 

8. Select the >> or the << button to define the outline level for the 

paragraph style. 

To update a Table of Contents 

1. Select Tools > Update > All Indexes and Tables. 

7.6 Use Page Numbering 

Numbering the pages of your document helps those reading and 

editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 

To Insert Page Numbers 

1. Go to menu item: Insert > Footer. 
2. Select the page style that you want to add the footer to. If you 

have not created or applied any special page styles, “Default” 

will be the only option. 

3. Go to menu item: Insert > Fields > Page Number. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. 
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• All basic accessibility considerations that are applied to the 

rest of your document must also be applied to your charts and 

the elements within your charts. For example, use shape and 

color, rather than color alone, to convey information. 

◦ When creating line charts, use the formatting options to 

create different types of dotted lines to facilitate legibility 

for users who are color blind. 

◦ When creating bar charts, it is helpful to apply textures 

rather than colors to differentiate the bars. 

• Ensure that the contents are your chart are appropriate 

labeled to give users reference points that will help them to 

correctly interpret the information. 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2). 

• Consider providing the data that you used to create the chart 

in tabular form (e.g., as an appendix). 

To create a chart 

1. Go to menu item: Insert > Object > Chart… 
2. Right-click* the chart and select Chart Data Table… 
3. Update the data table with the data you would like to display. 

4. Close the data table. 

To add titles and labels 

1. Select the chart. 

2. Go to menu item: Insert > Titles. 
3. Update the relevant fields and select OK. 
4. Go to menu item: Insert > Data Labels. 
5. Configure your data label selections and select OK. 
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To apply textures to bar charts 

1. In the chart’s legend, right-click* on the Legend Key for one of 

the bars. 

2. Select Format Data Series… 
3. In the Fill area, select Hatching and choose one of the 

textures. 

4. Optionally, select the Background Color check box and choose 

a color. 

5. Select OK. 

Repeat these steps for each legend key. 

To change the line style in line charts 

1. In the line chart’s legend, right-click* on the Legend Key. 
2. Select Format Data Series… 
3. Select the Line tab. 

4. Choose a line style that will help distinguish the data series 

from the other lines in the chart. 

5. Select OK. 

Repeat these steps for each legend key. 

Technique 9. Make Content Easier to See 

Here are some other things to keep in mind: 
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9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., 

Verdana, Helvetica, Arial) may sometimes be easier to read 

than serif fonts (e.g., Times New Roman, Garamond). 

Note: Some fonts were specifically designed for easier reading 

on screens (e.g. the sans-serif fonts Verdana, Trebuchet MS 

and Calibri, and the serif fonts Georgia, Cambria and 

Constantia). Unfortunately, many of these fonts are not 

available across operating systems. 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated (e.g., blinking) text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 
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To change the text size for a default named style 

1. Go to menu item: Format > Styles and Formatting (F11). 

2. Select the style to modify from the list. 

3. Right-click* and select: Modify… 
4. Select the Font tab. 

5. Select a font size under Size. 
6. Select OK. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 
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• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• TPG Contrast Analyser 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Relying on Color or Sensory 
Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead, use Writer’s 

“Changes” feature to track changes. You can find this feature in 

the Edit menu. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 
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9.4 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted in 

Technique 3, above. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 
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out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Position the cursor where you would like to enter the link. 

2. Go to menu item: Insert > Hyperlinks. 
3. In the Hyperlink dialog, enter the link address in the Target

box. 

4. In the Further settings section, enter the text to display in the 

Text box. 

5. Select Apply. 
6. Select Close. 

Technique 11. Check Accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), download the AccessODF extension and install it 

using Writer’s Extension Manager (Tools > Extension Manager…). 

This extension offers an “Accessibility Evaluation” function to review 

your document against a set of possible issues that users with 

disabilities may experience in your file. 

AccessODF classifies issues as either: 

• Error: Content that makes a file very difficult or impossible for 

people with disabilities to understand. 
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• Warning: Content that in most, but not all, cases makes a file 

difficult for people with disabilities to understand. 

To Use AccessODF 

1. Go to menu item: Tools > Accessibility Evaluation… 
2. An Accessibility Evaluation task panel will open. 

3. Select Check to start the evaluation. 
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4. Select a specific issue to see its description and repair 

suggestions. If the Repair button becomes active, selecting this 

button will either repair the issue automatically or open the 

dialog where you can repair the issue. (For example, adding a 

text alternative to an image cannot be done automatically, so 

AccessODF opens the dialog for text alternatives.) If the issue 

is a false alarm, select the Ignore button. 

5. When you have repaired all the issues, select the Check button 

again to find issues that may have gone undetected so far. 

More complete instructions are available in the AccessODF User 

Guide. 

Note: Currently, AccessODF 0.1.0 is not compatible with 

OpenOffice 4.0 (with the new 

sidebar) and LibreOffice 4.1 (with or without the sidebar). 

Editor’s note: AccessODF has not been updated recently, 

and it does not work with later versions of OpenOffice or 

LibreOffice. 

Using HTML and PDF to Evaluate Accessibility 

Since the AccessODF plugin may not work with current versions 

of OpenOffice or LibreOffice, consider saving the document as an 

HTML or PDF file and check those formats for accessibility. This 

will allow you to get some indication of the accessibility of your 

document or template. 

298  |  OpenOffice Writer and LibreOffice Writer

http://sourceforge.net/p/accessodf/wiki/UserGuide/
http://sourceforge.net/p/accessodf/wiki/UserGuide/


To evaluate HTML accessibility 

Save the document into HTML format and use one of the web 

accessibility checkers available online, such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option. 

3. Select the Start Checking button. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 
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Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 

1. Go to menu item: File > Export as PDF. 
Note: This option is different than the Adobe PDF option in the 

Print dialog. 

2. The PDF Options dialog window opens. 

3. Select the General tab. 

4. Select the check box labeled Tagged PDF 
Note: You must ensure this option is selected in the PDF 

Options window dialog box before using PDF icon on menu 

bar. This option is not checked by default, but will remain 

checked once you have selected it. 

5. Select the check box labeled Export bookmarks. 
Note: This creates a hierarchical list of bookmarks that link to 

the document’s headings. This list is displayed in the 

bookmarks panel of Adobe Acrobat and Adobe Reader and 

facilitates navigation (for sighted users) in large documents. 

6. Optionally, select the Initial View tab; in the Panes area, select 

the radio button Bookmarks and page. 
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7. Select Export. 
8. Enter name and save location. 

9. Select Save. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

HTML (Single HTML File) 

1. Go to menu item: File > Save As… 
2. Enter a path and a name for the HTML document. 

3. In the Save as type box, select “HTML Document 

(OpenOffice.org Writer)” (in OpenOffice.org) or “HTML 

Document (Writer)” (in LibreOffice). 

4. Select Save. 
5. A dialog asking which format to choose will appear. 

6. Select Keep Current Format (in OpenOffice.org) or Use HTML 
Document (Writer) Format (in LibreOffice). 

7. Check the HTML files for accessibility (see Technique 11). 

HTML (Multiple HTML Files) 

1. Apply one of the default heading paragraph styles to the 

paragraphs where you want to generate an HTML page. 

2. Go to menu item: File > Send > Create HTML Document. 
3. Enter a path and a name for the HTML document. 

4. Select Save. 
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5. Check the HTML file for accessibility (see Technique 11). 

To clean up your HTML file 

You may wish to use HTML editors or utilities to help with this 

process. 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes. 

• Remove font tags. 

• Remove styles in the <head> tag. 

• Ensure the <th> tags have a scope attribute. 

• Remove <p> tags nested inside <th> and <td> tags. 

• Check for accessibility (see Technique 11). 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• odt2daisy – an export as DAISY add-in for OpenOffice.org. 

• odt2braille – a Braille extension to OpenOffice.org Writer that 

enables the printing of documents to a Braille embosser and 

the export of documents as Braille files. 

• OOo2GD – an extension that allows you to export, update and 

import documents, spreadsheets and presentations between 

OpenOffice.org applications and Google docs. 
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Editor’s note: The plugins above have not been updated 

recently and may no longer work with current versions of 

OpenOffice and LibreOffice. 

Other Application Features 

Writer’s “Navigator” Feature 

After you have populated your document with content and true 

headings have been applied, you may wish to rearrange the content. 

In order to maintain the integrity and accessibility of the altered 

sequence, you will need to ensure that structural information (e.g., 

heading levels) is adjusted accordingly. 

Writer provides a “Navigator” mechanism which displays all parts 

of the document, such as headings, tables, frames, objects or 

hyperlinks. These elements are referred to as “categories”. If a plus 

sign appears next to any one of the categories, it means there is 

more than one object of its kind within the document. 

The “Navigator” feature helps you navigate document content, as 

well as access and manipulate the content. This enables you to move 

headings or subordinate text up or down in a document, as well 

as promote or demote heading levels. Arranging objects and other 

elements of the document is possible as well, following the same 

principle as arranging headings and text. This allows you to apply a 

meaningful sequence that can be programmatically determined and 

therefore accessible to assistive technologies. 
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To open the “Navigator” 

1. Select the View tab from the menu bar (F5). 

2. Select the Navigator option. 

To jump to a location in a document 

1. Double-click* an item listed in the Navigator window, or enter 

the respective page number in the spin box. 

To open a category 

1. Select the plus sign beside the category. 
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To view only the entries in a certain category 

1. Select the category and select the Content View icon. 

Note: Until you select the icon again, only the objects of this 

category will be displayed. 
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To move heading up or down in a document 

1. On the Standard Bar, select the Navigator icon to open the 

Navigator. 

2. On the Navigator, select the Content View icon. 

3. Do one of the following: 

1. Drag a heading to a new location in the Navigator list. 

2. Select a heading in the Navigator list, and then select the 

Promote Chapter or Demote Chapter icon. 

3. To move the heading without the subordinate text, hold 

down Ctrl while you drag or select the Promote Chapter 
or Demote Chapter icons. 

To Promote or Demote the Level of a Heading 

1. Select the heading in the Navigator list 

2. Select the Promote Level or Demote Level icon 

Accessibility Help 

If you are interested in what features are provided to make Writer 

more accessible to users, consult one of the the following: 

For OpenOffice Writer: 

1. Go to menu item: Help > OpenOffice.org Help (F1). 

2. Enter “accessibility” as the Search Term. 

For LibreOffice Writer: 

• Accessibility in LibreOffice 
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Authoring Techniques for Accessible
Office Documents: Spreadsheet





Google Sheets 

Usage Notes 

At the time of testing (December 2019), Google Sheets lacks some 

features that enable accessible office document authoring, most 

notably: the ability to indicate changes in natural language, 

programmatically determined named styles, and a separate 

document title field. 

No accessibility checking feature is built into Google Sheets; 

however, you can install a third-party add-on called Grackle Sheets. 

Grackle is a third-party plug-in that includes an accessibility 

checker along with other features that enhance accessibility (see 

Technique 11). Due to the nature of Google Sheets, some 

accessibility features, such as tables, are only fully accessible when 

exporting the document to another format, like an HTML file. 

What’s an “Office Document”? 

You should use these techniques when you are using Google Sheets 

to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 
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• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

Google Sheets does not have a default file format, as it is a web-

based authoring tool. 

Google Sheets offers various spreadsheet processor and web 

format saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12: 

• Microsoft Excel (.xlsx) 

• OpenDocument Format (.ods) 

• PDF Document (.pdf) 

• HTML (.html, zipped) 

• Comma-separated values (.csv, current sheet) 

• Tab-separated values (.tsv, current sheet) 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 
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is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups . In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. Files are also easily 

saved as other file formats (see Technique 12). 

Editor’s note: Since the content of this page has been 

heavily updated from the original article (Authoring 

Techniques for Accessible Office Documents: Google docs: 

Spreadsheets), the usual editor’s notes that flag new 

content will be omitted. The application-specific steps and 

screenshots were updated in December 2019. 

Technique 1. Use Accessible Templates 

Google Sheets lacks support for some accessibility features, such 

as table headers that repeat. With this in mind, be cautious of 
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templates available in the Google Sheets template gallery and be 

sure that they comply the techniques discussed here. 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

Google Sheets’s default template for new documents is a blank 

spreadsheet. The basic installation also includes a wide variety of 

templates ranging from blank service invoices to blank project 

management schedules. These are all accessible by virtue of being 

blank. 

It is possible to create your own templates from scratch in Google 

Sheets. As well, you can edit and modify the existing templates, 

ensuring their accessibility as you do so and saving them as a new 

template. 

To select a template 

1.  Go to Google Sheets. 

2. At the top right, click on Template Gallery. 

3. Select a template. 

4. A copy of the template will open. 
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To create an accessible template 

1. Create a new spreadsheet (from the default template or from 

an existing template). 

Note: If creating a template from an existing document, go 

to File > Make a copy. Type a name and choose where to save 

it, then, click Ok. 

2. Rename your document. Be sure to indicate that the document 

is an accessible template by using terms such as “accessible” 

(e.g., “Accessible Memo Template”). This will improve its 

searchability and promote its use as an accessible template. 

3. Ensure that you follow techniques in this document. You may 

also check the accessibility (see Technique 11). 

To share your accessible template as a new document 

You can share your accessible template, but it may be more useful 

to share the file as copy that other users can add to their Google 

Drive. 

1. Go to the address bar change the end of the URL before 

sending it. 

2. Replace “edit” at the end of the URL with “copy”. 

For example: 

Before: http://docs.google.com/spreadsheet/d/12345678/edit 
After: http://docs.google.com/spreadsheet/d/12345678/copy 

3. Send the modified copy link. 

4. When the recipient follows the modified copy link, they’re 

instructed to click on Make a copy. 
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5. They can then work on a copy of the accessible template. 

For more information, see the resources below: 

• Google: Create document templates 

• Google: Share “Make a copy” links to your files 

Technique 2. Set Document Language 

At this time (December 2019), Google Sheets does not offer an 

explicit language selection mechanism to indicate the natural 

language of your spreadsheet or changes in natural language at 

any point within the content (e.g., a few cells containing text in a 

different language than the rest of the spreadsheet). Google Sheets 

defaults the natural language to the language selected for your 

Google Account (see Google: Change Your Typing Language). 

When exporting to other document formats, there is no 

guarantee that the natural language of your Google Account will be 

indicated as the natural language of your document. In order for 

assistive technologies (e.g., screen readers) to be able to present 

your document accurately, it is important to indicate the natural 

language of the document. If a different natural language is used for 

a paragraph or selected text, this also needs to be clearly indicated. 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

Google Sheets offers a mechanism for adding alternative text or 

longer descriptions to images and objects where it can be readily 

accessed by screen reader users. While you can add alt text, you 

will need to ensure that you provide longer descriptions in the body 

of the document, near the images and objects. While this solution 

is not optimal for screen reader users and will complicate your 

own accessibility testing, it is necessary until long descriptions are 

supported. 
When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 
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sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 
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Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

For images in a cell 

1. Right-click* on the image. 

2. Select Alt Text from the contextual menu. 

3. Add your alt text to the Description field. 
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For images placed over cells 

1. In the top right corner of the image, click on the three dots. 
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2. From the drop-down menu, select Alt text. 
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3. In the Description field type or paste appropriate alt text. 

Note: The image used in the alt text screenshots above are by John 

322  |  Google Sheets



Tenniel from Alice’s Adventures in Wonderland from the original 1865 

edition of the book. 

Technique 4. Format Your Cells 

As you begin adding content, your spreadsheet will require 

structuring to bring meaning to the data, make it easier to navigate, 

and help assistive technologies read it accurately. One of the easiest 

ways to do this is to ensure that you properly format the cells. 

4.1 Named Styles 

At this time (December 2019), Google Sheets does not offer named 

styles functionality. 

You should make use of the named styles that are included with 

the office application (e.g., “Heading”, “Result”, etc.) before creating 

your own styles or using the character formatting tools directly. 

Named styles help your readers understand why something was 

formatted in a given way, which is especially helpful when there are 

multiple reasons for the same formatting (e.g., it is common to use 

italics for emphasis, Latin terms and species names). 

For more information on formatting using named styles, see 

Technique 6. 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Formatting header and result cells brings order to the 

spreadsheet and makes it easier for users to navigate effectively. For 

example, you can format header rows and columns using “Heading” 

styles to apply bolded, enlarged, and italicized text (among other 

characteristics). You may also want to format cells containing 
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results of calculations to appear bold and underlined to help 

distinguish them from the rest of your data. 

4.2 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 

To format cell characteristics 

1. Highlight the cells that you want to format 

Note: to format a row or column, select the row or column 

indicator and follow the next steps 

2. Go to the menu icon bar 

3. Select the icon or drop-down list for the format you would like 

to apply (e.g., Format as currency, Format as percent, More 
formats) 

Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 
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For more details, see the following articles from the Google Help 

Center: 

• How to edit and format a spreadsheet (includes how to format 

your entire spreadsheet with themes) 

• How to format numbers in a spreadsheet 
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Technique 5. Use Cell Addressing 

5.1 Define Names 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. By associating a meaningful name to a data range, you 

will be enhancing the readability of your document. These named 

ranges can be referenced in multiple locations of your document 

and within calculations and equations. 

To define a name 

1. Select the cells you would like to name 

2. Go to menu item: Data > Named ranges. A menu will open on 

the right. 
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3. Type the range name you want (see Range Names, below). 

4. To change the range, click the Spreadsheet Grid icon. 
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5. Select a range in the spreadsheet or type the new range into 

the text box, then click Ok. 

6. Click Done. 

Range names: 

• Can contain only letters, numbers, and 

underscores. 

• Can’t start with a number, or the words “true” or 

“false.” 

• Can’t contain any spaces or punctuation. 

• Must be 1–250 characters. 

• Can’t be in either A1 or R1C1 syntax. For 

example, you might get an error if you give your 

range a name like “A1:B2” or “R1C1:R2C2.” 
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Edit or delete a named range 

1. Select Data, then Named ranges. 

2. On the named range you want to edit or delete, click Edit. 

◦ To edit the range: Enter a new name or range, then click 

Done. 

◦ To delete the named range: Next to the name, click Delete 
range. On the menu that opens, click Remove. 

◦ Note: When you delete a named range, any formulas that 

reference it will no longer work. Protected ranges that 

reference a named range will use the cell values and 

continue to work. 

Technique 6. Create Accessible Charts 

Spreadsheet applications support various types of charts, which 

can be used to display your spreadsheet data in meaningful ways 

for your audience. It is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help to 

correctly interpret the information. 

To create an accessible chart 

1. Go to menu item: Insert > Chart 
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2. In the Chart Editor , a data range has been pre-selected and 

will appear in the box labeled Data. (Note: If this range is 

incorrect, enter a new range in the box labeled Data . To 

update the data range by manually highlighting the cells, select 

the Select range… link. This opens the What data? dialog, 

which allows you to highlight the data range and select OK .) 
3. In the Chard Editor dialog, select the Use row 1 as headers

check box if the first row of your data is a header row 

4. Select the chart type from the Recommended charts section 

5. Select the Customize tab 

6. In the Chart section , enter a title for the chart in the Chart 
title box 

7. Select the Name link and enter a name for the chart in the 

Chart name box 

8. In the Axis section, enter a title for the vertical axis in the 

Vertical name box 

9. Select the Horizontal link and enter a title for the horizontal 

axis in the Horizontal name box 

10. Define any other available options that may be associated with 

the chart 

11. Select Insert 

To add titles and labels 

1. Double-click on the chart you want to change. 

2. At the right, click Customize. 

3. Select Series. 

Optional: Next to “Apply to,” choose the data series you want to 

add a label to. 

4. Click Data labels. 

Optional: Under “Position,” choose where you want the data 

labels to show. 

Optional: Make changes to the label font. 
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To add alternative text to a chart 

1. In the top right corner of the chart, click on the three dots. 

2. From the drop-down menu, select Alt text. 

3. In the Description field type or paste appropriate alt text. 
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Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9) 

Technique 7. Provide Structure for Tables 

At this time (December 2019), Google Sheets does not include an 

“Insert Table” feature. 

If you use the Grackle Sheets add-on, tables can be given 

structure and table headings can be indicated. While these fixes 

won’t be useful for making tables more accessible in Google Sheets, 

it does allow you to export the document into another format with 

appropriate table tags intact. For more on Grackle Sheets, see 

Technique 11. 

Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 
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8.1 Add a Document Title 

At this time, Google Sheets makes use of a single document name. 

Within Google Sheets, this serves well as a title, but when exporting 

to ODT, the document name is used to form the file name and the 

ODT “Title” properties field is left blank. 

In case the document is ever converted into another format (e.g., 

HTML or PDF), it should be given a descriptive and meaningful title. 

To change the file name of the current document 

1. Go to menu item: File > Rename 
2. In the Rename Document dialog, enter a new document name 

3. Click OK 

8.2 Avoid “Floating” Elements 

Avoid “floating” elements (other than charts) such as floating 

images, objects, tables or text boxes. Similarly, avoid placing 

drawing objects directly into the document (e.g., as borders, to 

create a diagram). Instead, create borders with page layout tools and 

insert complete graphical objects. 

To learn how to insert images and graphical object into Google 

Sheets, see Google: Add an image to a spreadsheet. 

8.3 Use Descriptive Sheet Names 

In Google Sheets, spreadsheets have the default name “Sheet1” and 
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so on. To improve the accessibility and navigability of your 

spreadsheets, follow these recommendations: 

• Name sheets with a sheet name that describes its content. 

• Delete unused sheets to avoid unnecessary navigation. 

To rename a spreadsheet 

1. At the bottom of your Google Sheet, click on the drop-down 

arrow beside the sheet name. 

Note: Alternately, you can double click on the sheet name. 
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2.  Type a descriptive name for your sheet and hit Enter. 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 
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font sizes directly will change document details such the pagination, 

the layout of tables, etc., it is best practice to always format text for 

a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ratio of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 
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distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Google Sheets’s 

review functionality features to track changes, such as revision 

history. 

• Do not distinguish between images by referring to their 

appearance (e.g. ,“the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 
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to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. If you are using this cell for a label or data, you can 
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attach a comment note to the cell containing navigational 

instructions. 

10.3 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Go to menu item: Insert > Link. Alternately, you can select the 

text you’d like to add a link to and press Ctrl+K (or Cmd+K on 

Macs). 

2. In the pop-up box, enter descriptive text in the Text display 

box. 

3. Enter the link address in the Link. 

4. Select Apply. 
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Technique 11. Check Accessibility 

At this time (December 2019), Google Sheets does not offer a 

mechanism to check for potential accessibility errors in your 

document prior to publishing. However, a third-party add-on called 

Grackle Sheets can be used to check the accessibility of your 

workbook (see below). 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats (see Evaluating the Accessibility in 

Other Formats). 

Grackle Sheets 

What is Grackle Sheets? Grackle Sheets is a third-party add-on 

that runs on spreadsheets created in Google Sheets. It helps with 

checking and improving the digital accessibility of your document. 

Due to the nature of Google Sheets, some accessibility features, 

such as tables, are only fully accessible when exporting the 

document to another format, like an HTML file. 

How does it work? After Grackle is launched, It scans the current 

spreadsheet for accessibility issues and identifies and locates 

errors. Feedback appears in a sidebar that is docked on right-side 

of the screen. By exploring the sidebar, you can immediately learn 

about accessibility issues and find and fix the detected errors by 

interacting with the Grackle sidebar. 

Note: Grackle’s accessibility checker is free to use; however, the 

ability to export and produce accessible HTML spreadsheets, and so 

on, is only free for the first 30 days (as of December 2019). 

At the time of testing, Grackle Sheets performs the following 13 

accessibility checks: 
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• Sheets 

◦ Sheets document needs a proper title 

◦ Sheet names should be descriptive 

◦ The number of sheets should be reasonable 

◦ Avoid making sheets too large 

◦ Sheets should not be empty 

• Tables 

◦ Tables should have headers 

◦ Tables should not be too long 

◦ The number of tables should be reasonable 

◦ The use of merged cells is not recommended 

◦ Avoid isolated cells 

• Charts 

◦ Charts should have alternate text 

• Contents 

◦ High color contrast should be used 

◦ Fine print should be avoided 

How to install Grackle Sheets 

Grackle Sheets can be installed from the Add-ons menu of a Google 

Docs document. 

1. Open a Google document. 

2. Select Add-ons > Get Add-ons. 

◦ Search for “Grackle” in the search field. 

◦ Select the add-on and click Install. 

3. Note: A message will appear requesting access to data that the 

add-on needs to work. Review the message and click Allow. 
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How to launch and use Grackle Sheets 

Grackle Sheets is simple to launch and is accessed from the Add-
ons menu. 

1. Open a Google document 

2. From the Add-ons menu, select Grackle Docs, then select 

Launch. 
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3. A sidebar launches that identifies errors and warnings. 

◦ Clicking on each error and warning will expand the 

selection and provide guidance on how to resolve each 

issue. 

◦ Select the “Locate” button on any flagged item will take 

you to that line of the document to review. 

4. Continue to review and address each flagged item. 

◦ Select the “Re-Check” button at the top of the sidebar to 

update the report. 

◦ Continue to revise until all checks have passed. 
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Note: During testing, we noticed that Grackle Sheets may flag a 

chart as needing alt text even though alt text has been provided. 

Automated accessibility checkers cannot be trusted to check for 

all accessibility concerns, so be sure to review the recommended 

techniques in this document. 

Evaluating Accessibility in Other Formats 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Share a presentation in HTML view 

When using Google Slides’ HTML view, your  whole presentation is 

displayed in a single, scrollable HTML page, instead of displaying 

the presentation one slide at a time. This is a helpful feature if your 

audience includes people who use screen readers. 

To access a presentation in HTML view, use the keyboard 

shortcut Ctrl + Alt + Shift + p (Windows or Chrome OS) or ⌘ + 

Option + Shift + p (Mac). 
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Export to alternate formats 

1. Go to menu item: File > Download as 
2. Select the file type 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 
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not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• OOo2GD – an extension that allows you to export, update and 

import all your documents, spreadsheet and presentations 

between OpenOffice.org applications and Google docs. 

• Google Sheets Section 508 Compliance 

• Keyboard shortcuts for Google Sheets 

• Google: Make your document or presentation more accessible 

Accessibility Help 

If you are interested in what features are provided to make using 

Google Sheets more accessible to users, documentation is provided 

through online articles and Help forums: 

• Go to menu item: Help > Google Docs Help Center 
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Microsoft Excel 2010, 2013, 
2016, and 2019 

Usage Notes 

At the time of testing (December 2019), Excel 2010 and later versions 

provide a set of accessibility features that are sufficient to enable 

the production of accessible digital office documents. In addition, 

Excel includes an accessibility checking feature. 

How to Create an Accessible Office Document 

You should use these techniques when you are using Excel to create 

documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
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Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Excel is Office Open XML (XSLX). In 

addition, Excel offers many other spreadsheet processor and web 

format saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12 (below): 

• MS Excel 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using Microsoft Excel 2010 (ver.14.0.4760.1000, 

Windows XP, Sept. 2010)  and Microsoft Excel included with Office 

365 while creating a XLSX document. Files are also easily saved as 

other file formats (see  Technique 12, below). 

Technique 1: Using Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11, below). 

Excel’s default template for new documents is a blank page. The 

basic installation also includes other blank office-related 

documents. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Excel. You can also edit and modify the existing 

prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 
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How to Create an Accessible Template 

1. Create a new document. 

2. Ensure that you follow the techniques in this document. 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11, below). 

4. Go to menu item: File > Save As 
5. In the Save as type list, select Excel Template 
6. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Inventory Template”) 

will increase the prominence of the accessibility status. Also, 

filling in the text box labeled Tags with the term “accessibility” 

will improve its searchability as an accessible file. 

7. Select Save. 

Editor’s note: For those using later versions of Excel, 
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here’s a video about finding and exploring features of 

accessible Excel templates. 

Selecting an Accessible Template 

Only use these steps if you have an accessible template available 

(e.g. that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: File > New. 

2. Under Available Templates, select My Templates. 

3. In the New document dialog, select your accessible template 

from the list. 

4. Select OK. 
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5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2: Setting the Document Language 

At this time (December 2019), it is not possible to indicate the 

natural language of selected cells within an Excel workbook. 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

How to Change the Default Language for a Workbook 

1. Go to menu item: File. 

2. Select Options from the list in the left window pane. 
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3. Select Language from the list in the left of the Options dialog. 

4. Under Chose Editing Languages, select the editing language 

you want to use. 

Note: to add an editing language, select the language from the 

drop down list labeled. [Add additional editing languages] 
5. Select Set as Default. 

6. Close all Office programs and open them again for the changes 

to take effect. 

Technique 3: Providing Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 
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Tips for writing alternative text (use “Description” 
in Excel) 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank. 

• If the image contains meaningful text, ensure all 

of the text is replicated. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below. 

• Test by having others review the document with 

the images replaced by the alternative text. 

Tips for writing longer descriptions (use 
“Description” in Excel) 

• Long descriptions should be used when text 
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alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone. 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

 

To add alternative text to images and graphical objects 

1. Right-click* the object. 

2. Select Format Picture… 
3. Select the Alt Text option from the list. 

4. Fill in the description. 

358  |  Microsoft Excel 2010, 2013, 2016, and 2019



If an Excel document is saved to HTML, the Title and Description 
fields are combined into a single entry within the HTML <alt> tag. 

Editor’s note: To add alt text to a picture in later versions 

of Excel, follow these instructions: 

1. Right-click* on the object. 

2. Select Edit Alt Text. 

3. Add a description in the Description field. 
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For more details, 

see how to add alt 

text to an image or 

graphical object. 

 

Technique 4. Format Your Cells 

As you begin adding content, your 

spreadsheet will require structuring to 

bring meaning to the data, make it easier to navigate, and help 

assistive technologies read it accurately. One of the easiest ways to 

do this is to ensure that you properly format the cells. 

4.1 Named Styles 

You should make use of the named styles that are included with the 

office application (e.g., “Heading”, “Result”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). For more information on 

formatting using named styles, see Technique 9. 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 
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Formatting header and result cells brings order to the 

spreadsheet and makes it easier for users to navigate effectively. For 

example, you can format header rows and columns using “Heading” 

styles to apply bolded, enlarged, and italicized text (among other 

characteristics). You may also want to format cells containing 

results of calculations to appear bold and underlined to help 

distinguish them from the rest of your data. 

To format a cell with default named styles 

1. Highlight the cells that you want to format 

Note: to apply a style to an entire row or column, select the 

row or column indicator and follow the next steps 

2. Go to menu item: Home. 

3. In the Styles section, select the Cell Styles icon. 

4. Select the desired formatting style from the drop-down menu. 

Note: To modify a style, right-click* the desired formatting 

style from the drop-down menu and select Modify. Changes 

made to the style will affect all instances of the style within 

your workbook. 

4.2 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 

To format cell characteristics 

1. Highlight the cells that you want to format 

2. Go to menu item: Home. 

Microsoft Excel 2010, 2013, 2016, and 2019  |  361



3. In the relevant sections (e.g., Numbers, Font, etc.) make your 

adjustments. 

Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing 

5.1 Define Names 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. It can also be use as a navigation. When using the 

shortcut Ctrl + G a dialog box will open and layout all the names 

define in the cells. When selected and the OK button is pressed it 

will navigate to the located place. 

By associating a meaningful name to a data range, you will be 

enhancing the readability of your document. These named ranges 

can be referenced in multiple locations of your document and 

within calculations and equations. 

To define a name 

1. Highlight the cells you would like to name. 

2. Go to menu item: Formulas. 

3. In the Defined Names section, select the Define Name button. 

4. In the Name text box, enter the name for the data range 

5. In the Scope drop-down list, select scope within which the 
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name can be referenced 

6. Select OK 

Technique 6. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 
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Editor’s note: For later versions of Excel, here’s a video 

on how to create accessible charts. 

To create a chart 

1. Select the data that you want to include in the chart 

2. Go to menu item: Insert 
3. In the Charts section, select the icon of the type of chart you 

would like to insert 

4. Select a Chart Type from the Chart Gallery in the drop-down 

menu 

To add titles and labels 

1. In the Chart Tools menu section, go to menu item: Layout 
2. In the Labels section, select the type of title or label you would 

like to define (e.g., Chart Title, Axis Titles, Data Labels) 

Note: It is a good idea to use as many of the titles and labels 

available in this section as possible. 

To apply a predefined Chart Layout 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Chart Layouts section, select a Quick Layout from the 

scrolling Chart Layouts gallery 
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To change to a different predefined Chart Type 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Type section, select the Change Chart Type icon 

3. In the Change Chart Type dialog, select a chart type from the 

left pane 

4. Select a Chart Design from the right pane 

5. Select OK 

To apply alternative text to a chart 

1. Right-click* the chart 

Note: Make sure you are right-clicking the whole chart, not 

just an element within the chart. It is possible to add 

descriptions to the many elements that make up a chart, but 

this is not recommended. 

2. In the Format Chart Area dialog, select Alt Text 
3. Enter a Title in the Title box 

4. Enter a longer description of the chart contents in the 

Description box 

5. Select Close 

Other chart considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9, below) 
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Selecting charts with the keyboard: 

You can select charts from selection pane. 

This can be launched with keyboard sequence ALT+H,FD,P 

1. Press ALT+H and release the buttons

2. Type press FD 

3. Then Type P 
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This is a toggle command, so if the selection pane is already visible, 

it gets hidden after this. 

When the selection pane is active, by default the first object (chart 

or shape) will be highlighted. You can select it by pressing enter or 

tab to move to other options or use the arrow keys. 

Technique 7. Provide Structure for Tables 

Excel includes an “Insert Table” feature, but this works by applying 

cell formatting to spreadsheet cells. As such, it is not a structural 

feature in the same way that tables are in Word and PowerPoint. 
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Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 

8.1 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File 
2. Select Info from the list in the left window pane 

3. In the right window pane, select the Title text box 

4. Enter the Title 
Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

8.2 Avoid “Floating” Objects 

Avoid placing drawing objects directly into the document (e.g., as 

borders, to create a diagram). Instead, create borders with page 

layout tools and insert complete graphical objects. 
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Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

To change the text size for a default named style 

1. Go to menu item: Home 
2. In the Styles section, select the Cell Styles icon 
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3. Select the style to modify from the list 

4. Right-click* and select: Modify… 
5. In the Style dialog, select the Format button 

6. In the Format Cells dialog, select the Font tab 

7. In the Size text box, type the desired size or select it from the 

list 

8. Select OK 

370  |  Microsoft Excel 2010, 2013, 2016, and 2019



9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. In order to determine whether the colors in your 

Microsoft Excel 2010, 2013, 2016, and 2019  |  371



document have sufficient contrast, you can consult an online 

contrast checker, such as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 
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• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Google docs: 

Spreadsheet’s review functionality features to track changes, 

such as revision history. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 
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within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. For example, the first cell might read: “This worksheet 

includes two data tables. The first begins at cell A1 and lists travel 

expenses. The second begins at cell A50 and lists moving expenses.” 

Technique 11. Check Accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1, above), Excel offers an “Accessibility Checker” to 

review your document against a set of possible issues that users 

with disabilities may experience in your file. 

The “Accessibility Checker” classifies issues as 

• Error – content that makes a file very difficult or impossible 

for people with disabilities to understand 

• Warning – content that in most, but not all, cases makes a file 

difficult for people with disabilities to understand 

• Tip – content that people with disabilities can understand, but 

that might be better organized or presented in a way that 

would maximize their experience 
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To learn more about the Accessibility Checker and the rules it uses 

to identify and classify accessibility issues in your document, visit 

the Excel help section (see Accessibility Help, below). Use the search 

term “accessibility checker rules” in the help search box. 

To use the “Accessibility Checker” 

1. Go to menu item: File 
2. Select Info in the left window pane 

3. Under Prepare for Sharing, an alert will appear if a potential 

accessibility issue has been detected 

4. To view and repair the issues, select Check for Issues and then 

Check Accessibility 

5. An Accessibility Checker task pane will open, showing the 

inspection results 
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6. Select a specific issue to see Additional Information 
7. Follow the steps provided to fix or revise the content 
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In order to get further indication of the accessibility of your 

document or template (see Technique 1), then you may consider 
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saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 
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Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 (above). 

1. Go to menu item: File 
2. Select Save As 
3. In the File name box, type a name for the file 

4. In the Save as type list, select PDF or XPS Document 
5. Select the Options button 

6. Under Include non-printing information in the Options 
dialog, ensure that the Document structure tags for 
accessibility check box is selected 

7. Select OK and Save 
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HTML 

1. Go to menu item: File 
2. Select Save As 
3. In the File name box, type a name for the file 

4. In the Save as type box, select Web Page 
5. Select Save 
6. Check the HTML file for accessibility (see Technique 11, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 
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• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Keyboard shortcuts in Excel 2010 

• Microsoft Accessibility Page 

• Office 2010 Accessibility Tutorials 

Accessibility Help 

If you are interested in what features are provided to make using 

Excel more accessible to users, documentation is provided in the 

Help system: 

1. Go to menu item: File 
2. Select Help from the list on the left 

3. Under the Support section, select the Help icon 

4. Enter “Accessibility” as your search term in the Help dialog box 
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Editor’s note: For later versions of Excel, here are 

resources to help you create accessible workbooks. 

• Microsoft Excel Accessibility Video Training 

• Make your Excel documents accessible to people 

with disabilities 

References and Resources 

1. Microsoft Excel Help 

2. GAWDS Writing Better Alt Text 

3. Microsoft: Create Accessible Workbooks 
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(PDF) 
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Microsoft Excel 2010 by the Inclusive Design Research Centre 

(IDRC) used under CC-BY-SA 3.0. 

Microsoft Excel 2010, 2013, 2016, and 2019  |  383

https://adod.idrc.ocadu.ca/excel2010.html
https://adod.idrc.ocadu.ca/excel2010.html
https://idrc.ocadu.ca/
https://idrc.ocadu.ca/
https://creativecommons.org/licenses/by-sa/3.0/


Microsoft Excel for Mac 2008, 
2011, 2016, and 2019 

Usage Notes 

At the time of testing (December 2019), as long as images and 

graphical objects are avoided, Excel for Mac provides a set of 

accessibility features that is sufficient to enable the production of 

accessible digital office documents. However, Excel 2008 for Mac 

does not include an accessibility checking feature. 

Editor’s note: In the later versions of Excel for Mac, users 

can add alt text for images and graphical objects and check 

accessibility. For more information, see Excel for Mac Help. 

What’s an “Office Document”? 

You should use these techniques when you are using Excel for Mac 

to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
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• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Excel for Mac is Office Open XML (XLSX). 
In addition, Excel for Mac offers many other spreadsheet 

processor and web format saving options. Most of these have not 

been checked for accessibility, but some information and/or 

instructions are available for the following formats in Technique 12 

(below): 

• XLS (MS Excel 97 – 2004) 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 
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*Right-click: To right-click with the keyboard, select the object 

using the Shift+Arrow keys and then press either (1) the “Right-

Click” key (some keyboard have this to the right of the spacebar) or 

Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using Microsoft Excel 2008 for Mac (ver. 12.0 (071130), 

Mac OS X, Jan. 2011) and Microsoft Excel (version 16.16.16) while 

creating a XLSX document. Files are also easily saved as other file 

formats (see Technique 12, below). 

This document is provided for information purposes only and is 

neither a recommendation nor a guarantee of results. If errors are 

found, please report them to: adod-comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 
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template is accessible, you should check a sample document 

produced when the template is used (see Accessibility Checking, 

below). 

Excel for Mac’s default template for new documents is a blank 

page. The basic installation also includes other blank office-related 

documents. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Excel for Mac. As well, you can edit and modify the 

existing prepackaged templates, ensuring their accessibility as you 

do so and saving them as a new template. 

To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 10, below) 

4. Go to menu item: File > Save As 
5. In the Save As box, type a name for the template. Using a 

descriptive file name (e.g., “Accessible Inventory Template”) will 

increase the prominence of the accessibility status. 

6. In the Format list, select Excel 97–2004 Template (.xlt) 
7. Select Save 
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To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g., that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > Project Gallery… 
2. In the Category section, select My Templates (or select where 

you saved your accessible template) 

3. Select your accessible template from the template gallery 

4. Select Open 

5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 
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Technique 2. Set Document Language 

At this time, it is not possible to indicate the natural language of 

selected cells within an Excel for Mac workbook. As well, it is not 

possible to change the default language of an Excel for Mac 

workbook. 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

At this time, Excel 2008 for Mac does not offer the functionality of 

adding alternative text to images or graphical objects. 

Editor’s note: For later versions of Excel for Mac, users 

can add alt text. For more information, see how to add alt 

text for images and graphical objects. 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information conveyed by the 

image within the body of the document, providing the images as 

an alternate to the text. In that case, you do not have to provide 

alternate text within the image. 

To add alternative text to images and graphical objects 

 

1. Select the object, then choose one of the options below: 

◦ Right-click the object and select Edit Alt Text…. The Alt 
Text pane opens. 
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▪ Note: If the Edit Alt Text… option is not visible, select 

Format Object/Picture. 

◦ Alternately, select an object. In the menu, select the 

object’s Format tab. Then, select Alt Text. 

2. In the Alt Text pane, add the alternative text to the 

Description field. 
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Technique 4. Format Your Cells 

As you begin adding content, your spreadsheet will require 

structuring to bring meaning to the data, make it easier to navigate, 

and help assistive technologies read it accurately. One of the easiest 

ways to do this is to ensure that you properly format the cells. 
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4.1 Named Styles 

At this time, Excel for Mac does not offer a Named Styles feature. 

You should make use of the named styles that are included with 

the office application (e.g., “Heading”, “Result”, etc.) before creating 

your own styles or using the character formatting tools directly. 

Named styles help your readers understand why something was 

formatted in a given way, which is especially helpful when there are 

multiple reasons for the same formatting (e.g., it is common to use 

italics for emphasis, Latin terms and species names). 

For more information on formatting using named styles, see 

Technique 9. 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Formatting header and result cells brings order to the 

spreadsheet and makes it easier for users to navigate effectively. For 

example, you can format header rows and columns using “Heading” 

styles to apply bolded, enlarged, and italicized text (among other 

characteristics). You may also want to format cells containing 

results of calculations to appear bold and underlined to help 

distinguish them from the rest of your data. 

4.2 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 

To format cell characteristics 

1. Highlight the cells that you want to format 

2. Go to menu item: Format > Cells… 
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3. In the relevant sections (e.g., Numbers, Alignment, etc.) make 

your adjustments 

Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing 

5.1 Define Names 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. By associating a meaningful name to a data range, you 

will be enhancing the readability of your document. These named 

ranges can be referenced in multiple locations of your document 

and within calculations and equations. 

To define a name 

1. Highlight the cells you would like to name 

2. Go to menu item: Insert > Name > Define… 
3. In the Define Name dialog, enter the name for the data range 

in the Names in workbook text box 

4. Select Add 
5. Select OK 
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Technique 6. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 

To create a chart 

1. Select the data that you want to include in the chart 

2. Go to menu item: Insert > Chart… 
3. Select your chart type from the Charts section that opens 

above the document pane 

Note: This applies a predefined Chart Layout, which can be 
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changed at any time simply by selecting the chart and 

following Steps 2 and 3 above. 

To add titles and labels 

1. Select the chart 

2. If the Formatting Palette is not open, go to menu item: View > 
Toolbox, Formatting Palette 

3. Select Chart Options to open the Chart Options section, if it is 

not already open 

4. Under Titles, select the title from the Chart Title drop-down 

list or enter a title in the text box below the drop-down list 

5. Under Other options, select the Labels and Legends you 

would like to include from their respective drop-down lists 

6. Under Chart Data, select Data Table with Legend Keys from 

the Data Table drop-down list to include a data table to help 

further support the chart 

Note: It is a good idea to use as many of the titles and labels as 

possible. 
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Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9, below) 

Technique 7. Provide Structure for Tables 

Excel for Mac includes a “Data Table” feature, but this meant for 

analyzing data by applying preformatted formulas within the data 

table. As such, it is not a structural feature in the same way that 

tables are in Word. 

Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 

8.1 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 
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To change the title of the current document 

1. Go to menu item: File > Properties… 
2. Select Summary 
3. In the Title text box and enter the Title 

Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

8.2 Avoid “Floating” Elements 

Avoid “floating” elements (other than charts) such as floating 
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images, objects, tables or text boxes. 

Similarly, avoid placing drawing objects directly into the document 

(e.g., as borders, to create a diagram). Instead, create borders with 

page layout tools and insert complete graphical objects. 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 
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9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 
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• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Excel for Mac’s 

“Track Changes” features to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 
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Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of white 

space and by avoiding too many different colors, fonts and 

images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. If you are using this cell for a label or data, you can 

attach a comment note to the cell containing navigational 

instructions. 
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Technique 11. Check Accessibility 

At this time, Excel 2008 for Mac does not offer a mechanism to 

check for potential accessibility errors in your document prior to 

publishing. 

Editor’s note: Later versions of Excel for Mac include an 

accessibility checker. For detailed instructions about how 

to use the accessibility checker, see how to make your 

Excel documents accessible to people with disabilities. 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML in order to perform an accessibility check 

in one of those formats, as described below. 

To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

Microsoft Excel for Mac 2008, 2011, 2016, and 2019  |  405

https://support.office.com/en-us/article/make-your-excel-documents-accessible-to-people-with-disabilities-6cc05fc5-1314-48b5-8eb3-683e49b3e593
https://support.office.com/en-us/article/make-your-excel-documents-accessible-to-people-with-disabilities-6cc05fc5-1314-48b5-8eb3-683e49b3e593
http://achecker.ca/checker/index.php
http://wave.webaim.org/


• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option. 

3. Select the Start Checking button. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Note: Before saving in other formats, you may want to run the 

Compatibility Report feature by selecting Compatibility Report… 
from the Save As dialog. This checks the compatibility of your 

existing document with the format you have selected save your 

document as. The results of this check are revealed in the 

Compatibility Report dialog, where you have explanations of errors 
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and options to fix them. To run this check at any time, go to menu 

item: View > Toolbox, Compatibility Report. 

XLS 

1. Go to menu item: File > Save As… 
2. In the Save As box, type a name for the file 

3. In the Format drop-down list, select Excel 97 – 2004 
Workbook (.xls) 

4. Select Save 

HTML 

1. Go to menu item: File > Save as Web Page… 
2. In the Save As box, type a name for the file 

3. Select Save 
4. Check the HTML file for accessibility (see Technique 11, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 
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Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results by 

the IDRC. 

• Coming soon… 

Accessibility Help 

If you are interested in what features are provided to make using 

Excel for Mac more accessible to users, documentation is provided 

in the Help system: 

1. Go to menu item: Help > Microsoft Excel Help 
2. Enter “Accessibility” as your search term in the Help dialog box 

To use the accessibility checker in Word for Mac 

1. Select Review > Check Accessibility. 

2. Review the results in the Accessibility Checker pane. 

3. Select a specific issue to see why and how to address the items 

flagged in the Accessibility Checker results. 

For more information, see the following resources from Microsoft: 

408  |  Microsoft Excel for Mac 2008, 2011, 2016, and 2019



• Everything you need to know to write effective alt text 

• Make your content accessible to everyone with the 

Accessibility Checker 

References and Resources 

1. Microsoft Excel 2008 for Mac Help — Note: Excel 2008 for Mac 

is no longer supported, but you still have access to offline help 

by going to Help > Excel Help. 

2.  GAWDS Writing Better Alt Text 

3. Microsoft Excel 2016 for Mac Help 

4. Ryerson University: Microsoft Excel Accessibility Tipsheet 

(PDF) 

5. Microsoft Excel: Video Tutorials 
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Microsoft Excel 2007 

Usage Notes 

At the time of testing (January 10, 2011), Excel 2007 provides a set of 

accessibility features that is sufficient to enable the production of 

accessible digital office documents. However, Excel 2007 does not 

include an accessibility checking feature. 

What’s an “Office Document”? 

You should use these techniques when you are using Excel 2007 to 

create documents that are: 

• Intended to be used by people(i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
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specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Excel 2007 is Office Open XML (XLSX). 
In addition, Excel 2007 offers many other spreadsheet processor 

and web format saving options. Most of these have not been 

checked for accessibility, but some information and/or instructions 

are available for the following formats in Technique 12 (below): 

• MS Excel (XLS) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. The application-

specific steps and screenshots in this document were created using 

Microsoft Excel 2007 (ver.12.0.6545.5000, Windows 7, Jan. 2011) 

while creating a XLSX document. Files are also easily saved as other 

file formats (see Technique 12, below). 

This document is provided for information purposes only and is 

neither a recommendation nor a guarantee of results. If errors are 

found, please report them to: adod-comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11, below). 

Excel 2007’s default template for new documents is a blank page. 

The basic installation also includes other blank office-related 

documents. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in Excel 2007. As well, you can edit and modify the existing 
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prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 

To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11, below) 

4. Go to menu item: Office > Save As > Other Formats 
5. In the Save as type list, select Excel Template 
6. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Inventory Template”) 

will increase the prominence of the accessibility status. As well, 

filling in the text box labeled Tags with the term “accessibility” 

will improve its searchability as an accessible file. 

7. Select Save 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: Office > New 
2. Under Templates, select My templates… 
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3. In the New document dialog, select your accessible template 

from the list 

4. Select OK 
5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

At this time, it is not possible to indicate the natural language of 

selected cells within an Excel 2007 workbook. [Tested: Jan 10, 2011] 
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To change the default language for a workbook 

1. In the operating system, activate the keyboard layout for the 

language in which you want to create and edit text 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 
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• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 
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document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* the object 

2. Select Size… 
3. Select the Alt Text tab 

4. Fill in the Alternative text box 
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Technique 4. Format Your Cells 

As you begin adding content, your spreadsheet will require 

structuring to bring meaning to the data, make it easier to navigate, 

and help assistive technologies read it accurately. One of the easiest 

ways to do this is to ensure that you properly format the cells. 

4.1 Named Styles 

You should make use of the named styles that are included with the 

office application (e.g., “Heading”, “Result”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). For more information on 

formatting using named styles, see Technique 9. 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Formatting header and result cells brings order to the 

spreadsheet and makes it easier for users to navigate effectively. For 

example, you can format header rows and columns using “Heading” 

styles to apply bolded, enlarged, and italicized text (among other 

characteristics). You may also want to format cells containing 

results of calculations to appear bold and underlined to help 

distinguish them from the rest of your data. 

To format a cell with default named styles 

1. Highlight the cells that you want to format 

Note: to apply a style to an entire row or column, select the 
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row or column indicator and follow the next steps 

2. Go to menu item: Home 
3. In the Styles section, select the Cell Styles icon 

4. Select the desired formatting style from the drop-down menu 

Note: To modify a style, right-click* the desired formatting 

style from the drop-down menu and select Modify. Changes 

made to the style will affect all instances of the style within 

your workbook. 

4.2 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 

To format cell characteristics 

1. Highlight the cells that you want to format 

2. Go to menu item: Home 
3. In the relevant sections (e.g. Numbers, Font, etc.) make your 

adjustments 

Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing 
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5.1 Define Names 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. By associating a meaningful name to a data range, you 

will be enhancing the readability of your document. These named 

ranges can be referenced in multiple locations of your document 

and within calculations and equations. 

To define a name 

1. Highlight the cells you would like to name 

2. Go to menu item: Formulas 
3. In the Defined Names section, select the Define Name button 

4. In the Name text box, enter the name for the data range 

5. In the Scope drop-down list, select scope within which the 

name can be referenced 

6. Select OK 

Microsoft Excel 2007  |  421



Technique 6. Create Accessible Charts 

Spreadsheet applications support various types of charts, which 

can be used to display your spreadsheet data in meaningful ways 

for your audience. It is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help to 

correctly interpret the information. 

To create a chart 

1. Select the data that you want to include in the chart 

2. Go to menu item: Insert 
3. In the Charts section, select the icon of the type of chart you 

would like to insert 

4. Select a Chart Type from the Chart Gallery in the drop-down 

menu 

To add titles and labels 

1. In the Chart Tools menu section, go to menu item: Layout 
2. In the Labels section, select the type of title or label you would 

like to define (e.g., Chart Title, Axis Titles, Data Labels) 

Note: It is a good idea to use as many of the titles and labels 

available in this section as possible. 
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To apply a predefined chart layout 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Chart Layouts section, select a Quick Layout from the 

scrolling Chart Layouts gallery 

To change to a different predefined chart type 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Type section, select the Change Chart Type icon 

3. In the Change Chart Type dialog, select a chart type from the 

left pane 

4. Select a Chart Design from the right pane 

5. Select OK 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Other Considerations, below) 

Technique 7. Provide Structure for Tables 

Excel 2007 includes an “Insert Table” feature but this works by 

applying cell formatting to spreadsheet cells. As such, it is not a 
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structural feature in the same way that tables are in Word 2010 and 

PowerPoint 2010. 

Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 

8.1 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: Office > Prepare > Properties 
2. In the Document Properties section that appears, select the 

Title text box 

3. Enter the Title 
Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

8.2 Avoid “Floating” Elements 

Avoid “floating” elements such as floating images, objects, tables or 

424  |  Microsoft Excel 2007



text boxes. 

Similarly, avoid placing drawing objects directly into the document 

(e.g., as borders, to create a diagram). Instead, create borders with 

page layout tools and insert complete graphical objects. 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 
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To change the text size for a default named style 

1. Go to menu item: Home 
2. In the Styles section, select the Cell Styles icon 

3. Select the style to modify from the list 

4. Right-click* and select: Modify… 
5. In the Style dialog, select the Format button 

6. In the Format Cells dialog, select the Font tab 

7. In the Size text box, type the desired size or select it from the 

list 

8. Select OK 
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9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 
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In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 
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should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Google docs: 

Spreadsheet’s review functionality features to track changes, 

such as revision history. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 
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whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. If you are using this cell for a label or data, you can 

attach a comment note to the cell containing navigational 

instructions. 

Technique 11. Check Accessibility 

At this time, Excel 2007 does not offer a mechanism to check for 

potential accessibility errors in your document prior to publishing. 

[Tested: January 10th, 2011] 
In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 
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• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 
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Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 (above). 

1. Go to menu item: Office > Save As > PDF or XPS 
2. In the File name box, type a name for the file 

3. Select the Options button 

4. Under Include non-printing information in the Options 
dialog, ensure that the Document structure tags for 
accessibility check box is selected 

5. Under PDF options, ensure that Bitmap text when fonts may 
not be embedded check box is de-selected 

6. Select OK and Save 
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HTML 

1. Go to menu item: Office > Save As > Other Formats 
2. In the File name box, type a name for the file 

3. In the Save as type box, select Web Page 
4. Select Save 
5. Check the HTML file for accessibility (see Technique 11, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 
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• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Office 2007 Accessibility Tutorials 

• Excel 2007 Shortcut and Function Keys 

Accessibility Help 

If you are interested in what features are provided to make using 

Excel 2007 more accessible to users, documentation is provided in 

the Help system: 

1. Select Help icon in the right corner of the application window 

or select F1 
2. Enter “Accessibility” as your search term in the Help dialog box 
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Numbers for Mac 

Usage Notes 

At the time of testing (September 30, 2010), Numbers ‘09 lacks 

several features that enable accessible office document authoring, 

most notably: the ability to add alternative text to images and 

objects, the ability to indicate nature language, and 

programmatically determined named styles, cell naming, image and 

object anchoring, or change tracking features. As a result, some of 

the other features that might otherwise support accessibility, such 

as its extensive templates are not as effective. In addition, Numbers 

‘09 does not include an accessibility checking feature, which is a 

more advanced accessibility feature. 

Editor’s note: In later versions of Numbers, Apple added 

some updates to improve accessibility, including the ability 

to add alt text to images and graphical objects. To learn 

more about accessibility tips in Numbers, see how to create 

accessible spreadsheets with Numbers. 

What’s an “Office Document”? 

You should use these techniques when you are using Numbers to 

create documents that are: 

• Intended to be used by people (i.e., not computer code), 
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• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Numbers is the native iWork format. 

In addition, Numbers ‘09 offers many other spreadsheet 

processor and web format saving options. Most of these have not 

been checked for accessibility, but some information and/or 

instructions are available for the following formats in Technique 13: 

• MS Excel 

• TSV 

• CSV 

• PDF 
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Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using iWork Numbers ‘09 (ver.2.0.3 (332), Mac OS X, 

Sept. 2010) and Numbers 6.1 (December 2019) while producing a 

document in the proprietary file format. Files are also easily saved 

as other file formats (see Technique 13). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 
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“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 12). 

The default template for new documents in Numbers is a blank 

spreadsheet, which is accessible by virtue of being blank. 

To create an accessible template 

1. Go to menu item: File > New or File > New from Template 
Chooser… (Shift+Apple+N) 

2. In the Template Chooser dialog, select the Blank template or 

select one of the other existing template designs 

3. A new document in your selected template style will open 

4. Ensure that you follow the techniques in this document 

5. When you are finished you should also check the accessibility 

of the document (see Technique 12) 

6. Go to menu item: File > Save as Template… 
7. In the Export As box, type a name for the template. Using a 

descriptive template name (e.g. “Accessible Memo Template”) 

will increase the prominence of the accessibility status. 

8. In the Where drop-down list, specify a folder in which to save 

your template. 

Note: By default, your template will be saved in the home 

folder in Library/Application Support/iWork/Numbers/
Templates/My Templates pane of the Template Chooser. To 

save the template in a different location than the default, 

create a new folder in the Templates folder. The folder name is 

then used as a template category in the Template Chooser.

Numbers for Mac  |  439



9. Click Save 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > New from Template Chooser…
(Shift+Apple+N) 

2. In the Template Chooser dialog, select My Templates from the 
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left pane

3. Select your accessible template and click Choose 

Technique 2. Set Document Language 

At this time, it is not possible to manually indicate the natural 

language for specific cells or blocks of cells in Numbers ‘09. As well, 

it is not possible to change the natural language of the document 

itself from the default language. [Tested: September 29th, 2010] 

Editor’s note: In later versions of Numbers, users can set 

the document language for a spreadsheet within a 

workbook. For detailed instructions, see how to format a 

spreadsheet for another language in Numbers on Mac. 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 
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natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

At this time, Numbers ’09 does not offer a mechanism which enables 

the user to add alternative text descriptions to images or objects. 

[Tested: September 28, 2010] 

Editor’s note: In later versions of Numbers, users can add 

alt text for images and graphical objects. To add alt text 

descriptions, follow these steps: 

• Click the object to select it, click the Format button 

in the toolbar, then click image in the inspector. 

• Click in the Description text box, then enter your 

description. 

For detailed instructions, see how to add an image 

description on the Numbers User Guide for Mac. 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

Technique 4. Format Your Cells 

As you begin adding content, your spreadsheet will require 

structuring to bring meaning to the data, make it easier to navigate, 

and help assistive technologies read it accurately. One of the easiest 

ways to do this is to ensure that you properly format the cells. 

4.1 Named Styles 

At this time (December 2019), Numbers does not offer named styles 
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that can be applied to format and distinguish specific cells from the 

rest of your data. 

You should make use of the named styles that are included with 

the office application (e.g., “Heading”, “Result”, etc.) before creating 

your own styles or using the character formatting tools directly. 

Named styles help your readers understand why something was 

formatted in a given way, which is especially helpful when there are 

multiple reasons for the same formatting (e.g., it is common to use 

italics for emphasis, Latin terms and species names). 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Formatting header and result cells brings order to the 

spreadsheet and makes it easier for users to navigate effectively. For 

example, you can format header rows and columns using “Heading” 

styles to apply bolded, enlarged, and italicized text (among other 

characteristics). You may also want to format cells containing 

results of calculations to appear bold and underlined to help 

distinguish them from the rest of your data. 

4.2 Table Styles 

Table styles are useful for applying consistent formatting to tables. 

In Numbers, each template has one or more table style that formats 

various characteristics of your tables. A table style predefines the 

table background, the characteristics of cell borders, header rows 

and columns, footer rows, and the background and text attributes 

of cells. Table styles are useful for distinguishing different types of 

information in your spreadsheet. 

Note: While the visual characteristics may not necessarily be 

helpful for accessibility, identifying the header rows and columns 

and pre-formatting text characteristics for these columns is helpful. 
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To apply a table style 

1. In the left pane, go to the Styles section 

2. Select the style of table from the list 

Note: You can modify any attribute of the table style and your 

modifications will remain even if you decide to change to a 

different table style. 

4.3 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 
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To format cell characteristics 

1. Highlight the cells that you want to format 

Note: to format a row or column, select the row or column 

indicator and follow the next steps 

2. In the Toolbar, select Inspector 
3. In the Inspector dialog, select Cells inspector 
4. Select the Cell Format drop-down list and choose the format 

5. Customize the format options 

Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing 

5.1 Define Names 

At this time (December 2019), Numbers does not provide a 

mechanism for applying names to specific data ranges. Rather, it 
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advises authors that they can use existing header row and column 

names to address cells within a table. While this may be useful when 

defining formulas, it does not provide the necessary support for 

accessibility. 

Editor’s note: To see header names more clearly, be sure 

to make the following change under preferences: 

1. Go to Numbers > Preferences. 

2. Under Cell References, ensure that the check box 

is checked off for the option “Use header names as 

labels.” 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. By associating a meaningful name to a data range, you 
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will be enhancing the readability of your document. These named 

ranges can be referenced in multiple locations of your document 

and within calculations and equations. 

Technique 6. Create Accessible Charts 

Spreadsheet applications support various types of charts, which 

can be used to display your spreadsheet data in meaningful ways 

for your audience. It is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help to 

correctly interpret the information. 

To create a chart 

1. In the Toolbar, select Charts or go to menu item: Insert > 
Chart 

2. Select the chart type 

3. In the Toolbar, select Inspector 
4. In the Inspector dialog, select the Chart inspector 
5. Format the chart type and chart colors by selecting Choose a 

chart type and Chart Colors… options 

6. Select Chart 
7. In the Chart section, select the Show Title and Show Legend 

check boxes 

8. Select Axis 
9. In the Axis section, select Choose Axis Options for both Value 
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Axis (Y) and Category Axis (X) 
Note: It is a good idea to “show” as many title and labeling 

elements as possible (e.g. Show Axis, Show Title, Show 
Categories, Show Series Names, etc.) 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 10) 

Technique 7. Provide Structure for Tables 

To add a table with headers 

1. Go to menu item: Insert > Table 
2. Select table style 

3. In the Toolbar, select Inspector 
4. In the Inspector dialog, select the Table inspector 
5. In the Name box, enter a name for the table 

6. In the Headers & Footer section, select the number of header 

rows and columns using the drop-down menus (Note: It is 

recommended to keep your tables simple by using only one 

header row and column). 

450  |  Numbers for Mac



Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 

8.1 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. In the Toolbar, select Inspector 
2. In the Inspector dialog, select the Document inspector button 

3. In the Spotlight section, type a descriptive name for the 

document in the Title box 

Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 
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8.2 Avoid “Floating” Elements 

Avoid “floating” elements (other than charts) such as floating 

images, objects, tables or text boxes. 

Similarly, avoid placing drawing objects directly into the 

document (e.g., as borders, to create a diagram). Instead, create 

borders with page layout tools and insert complete graphical 

objects. 

Technique 9. Make Content Easier to See 
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9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 
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Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 
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However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text 

you have edited and noting the color. Instead use the 

applications revision tracking feature to track changes. 

At this time (December 2019), Numbers does not offer a mechanism 

to track changes in its documents. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the steps noted in Technique 

3. 
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Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. If you are using this cell for a label or data, you can 

attach a comment note to the cell containing navigational 

instructions. 
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Technique 11. Check Accessibility 

At this time (December 2019), Numbers does not offer an 

accessibility checking mechanism to identify potential accessibility 

errors prior to publishing. 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Alternate formats 

1. Go to menu item: Share > Export… 
2. In the dialog, select the type of file format you would like to 

export 

3. Customize the export options for that file format 

4. Click Next 
5. In the Save As box, enter a file name for your document 

6. In the Where drop-down menu, select the location you would 

like to save your document 
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7. Click Export 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

1. 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• iWork Numbers Support Page 
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• Exporting a spreadsheet in Excel format 

Accessibility Help 

If you are interested in what features are provided to make using 

Numbers more accessible to users, documentation is provided in 

the Help system: 

1. Go to menu item: Help 
2. Enter your search terms in the Search box 

References and Resources 

1. Numbers User Guide for Mac 
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OpenOffice Calc 

Usage Notes 

At the time of testing (December 2019), Calc provides a set of 

accessibility features that is sufficient to enable the production of 

accessible digital office documents. However, Calc does not include 

an accessibility checking feature, which is a more advanced 

accessibility feature. 

What’s an “Office Document”? 

You should use these techniques when you are using Calc to create 

documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
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specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Calc is ODF Spreadsheet (ODS). In 

addition, Calc offers many other spreadsheet processor and web 

format saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12: 

• MS Excel 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. The application-

specific steps and screenshots in this document were created using 

Calc (ver. 3.2.1, Windows XP, Aug. 2010 and Apache OpenOffice 4.1.7) 

while creating an ODT document. Files are also easily saved as other 

file formats (see Technique 12). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). Calc’s 

default template for new documents is a blank spreadsheet, which 

is accessible by virtue of being blank. It is possible to create your 

own accessible templates from scratch in Calc. As well, you can 

edit and modify the existing prepackaged templates, ensuring their 

accessibility as you do so and saving them as a new template. 
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To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11) 

4. Go to menu item: File > Properties 
5. Use the Title and/or Comments to indicate the accessibility 

status of the template. Using Title (e.g., “Accessible Memo 

Template”) will increase the prominence of the accessibility 

status because this is used in place of the template’s file name. 

Comments can be used to add more information if necessary 

(e.g., “This memo template has been checked for accessibility.”). 

6. Close the dialog with OK 

7. Go to menu item: File > Templates > Save (Shift+F11) 

8. In the New Template box, type a name for the template. Again, 

using a descriptive template name (e.g. “Accessible Memo 

Template”) will increase the prominence of the accessibility 

status of the template. 

9. Select the category you would like to save it in, under 
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Categories Note: the category is simply the folder into which 

you are saving the template 

10. Close the dialog with OK 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > New > Templates and Documents 
2. Select the Templates icon 

3. Select a template from the list Note: A properties pane appears 

on the right side of the window, where you can read the 

document properties (Title, By, Date, Modified by, Modified on, 

Description, Size). If you placed information about the 

accessibility of the template in the Title and/or Comments 
when you created the template (see above), this will be 

displayed in the Title and/or Description, respectively. 

4. Select Open 
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5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To select a language for the whole document 

1. Go to menu item: Tools > Options 
2. Select Language Settings > Languages 
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3. Under Default languages for documents, select the document 

language for all newly created documents Note: If you mark For 
the current document only, your choice will only apply to the 

current document. 

4. Close the dialog with OK

To format the language for a block of cells 

1. Select the cells to which you want to apply a language 

2. Go to menu item: Format > Cells… (Ctrl+1) 

3. Select the Font tab 

4. Select the Language and click OK 

To apply a language directly to selected text 

1. Select the text to which you want to apply a language 

2. Go to menu item: Format > Character 
3. Select the Font tab 

4. Select the Language and click OK 
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Technique 3. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

to each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click on object 

2. Select Description… option 

3. Enter alternative text in the Title box 
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4. 

To add long descriptions to images and graphical objects 

1. Right-click on object 

2. Select Description… option 

3. Enter description in Description box 

4. 

Technique 4. Format Your Cells 

As you begin adding content, your spreadsheet will require 
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structuring to bring meaning to the data, make it easier to navigate, 

and help assistive technologies read it accurately. One of the easiest 

ways to do this is to ensure that you properly format the cells. 

4.1 Named Styles 

You should make use of the named styles that are included with the 

office application (e.g., “Heading”, “Result”, etc.) before creating your 

own styles or using the character formatting tools directly. Named 

styles help your readers understand why something was formatted 

in a given way, which is especially helpful when there are multiple 

reasons for the same formatting (e.g., it is common to use italics for 

emphasis, Latin terms and species names). For more information on 

formatting using named styles, see Technique 9. 

Note: While office application suites support headings in much 

the same way, the named styles often differ. Formatting header and 

result cells brings order to the spreadsheet and makes it easier for 

users to navigate effectively. For example, you can format header 

rows and columns using “Heading” styles to apply bolded, enlarged, 

and italicized text (among other characteristics). You may also want 

to format cells containing results of calculations to appear bold and 

underlined to help distinguish them from the rest of your data. 

To format a cell with default named styles 

1. Highlight the cells that you want to format Note: to apply a 

style to an entire row or column, select the row or column 

indicator and follow the next steps 

2. Go to menu item: Format > Styles and Formatting (F11) 

3. Double click on the desired formatting style Note: If a style is 

modified in the Styles and Formatting panel, the modification 

will apply to every application of that style
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4.2 Other Cell Characteristics 

Ensure your cells are formatted to properly represent your data, 

including number and text attributes. 

To format cell characteristics 

1. Highlight the cells that you want to formatNote: to format a 

row or column, select the row or column indicator and follow 

the next steps 

2. Go to menu item: Format > Cell… (Ctrl+1) 

3. Select the relevant tabs (e.g. Numbers, Font, etc.) and make 

your adjustments 

4. Click OK 
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Note: When formatting your spreadsheet, it is best to avoid 

merging cells. At times, it may seem easier to present your data 

by merging cells, but this can make it more difficult for users 

of assistive technologies and people navigating your 

spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing 

5.1 Define Label Range 

Label ranges help to logically define the contents of specific cells 

as either labels or data. This is useful for navigational purposes, 

allowing users to jump between ranges of data and navigate within 

each range. This is also useful for calculations, as you may reference 

an entire label range within an equation. 
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To define a label range 

1. Select the header cells 

2. Go to menu item: Insert > Names > Labels… 
3. Select the Minimize button beside the For data range box 

4. Highlight the data cells within the label range 

5. Select the Maximize button to view the dialog 

6. Click OK 

5.2 Define Names 

Naming the different data ranges within your spreadsheet makes 

it easier to navigate through the document and find specific 

information. By associating a meaningful name to a data range, you 

will be enhancing the readability of your document. These named 

ranges can be referenced in multiple locations of your document 

and within calculations and equations. 
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To define a name 

1. Go to menu item: Insert > Names > Define… (Ctrl+F3) 

2. Enter the name in the Name text box 

3. Select the Minimize button next to the Assigned to text box 

4. Highlight the cells you would like to assign the name to 

5. Select the Maximize button next to the text box to view the 

dialog 

6. Click OK 

Technique 6. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 
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should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 

To create a chart 

1. Go to menu item: Insert > Chart… 
2. In the Chart Wizard dialog, follow steps 1 to 4 to format your 

chart Note: When you are selecting your formatting options in 

each step, ensure that your selections align with the 

accessibility techniques in this document. 

3. In Step 4, make sure to define all chart elements (e.g. title, 

subtitle, legend, etc.) 

To name a chart 

1. Right-click* the chart 

2. Select Name… 
3. In the Name dialog, enter a unique chart name in the Name 

text box 

4. Select OK 

To provide alternative text for the chart 

1. Right-click* the chart 

2. Select Description… 
3. In the Description dialog, enter alternative text in the Title

box 

4. Enter a longer description of the chart contents in the 

Description box 

5. Select OK 
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Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9) 

Technique 7. Provide Structure for Tables 

Calc has an “Insert table” feature. 

To insert a new table 

1. Place the cursor where you would like the table to appear. 

2. To insert a table, you have two options: 

◦ From the main menu, select Table > Insert >  Table 
(keyboard shortcut: Ctrl+F12). 

◦ Alternately, from the toolbar, click on the Table icon (

) 

3. In the Insert Table dialog box, specify the properties for the 

new table. 
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Technique 8. Use Other Content Structuring 
Features 

While cell formatting is the most common method of structuring 

documents, other content structuring features should be used 

where appropriate: 

8.1 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File > Properties 
2. Select the Description tab 
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3. Type the new title in the Title box and click OK 
Note: The title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

8.2 Avoid “Floating” Elements 

Avoid “floating” elements (other than charts) such as floating 

images, objects, tables or text boxes. Similarly, avoid placing 

drawing objects directly into the document (e.g., as borders, to 

create a diagram). Instead, create borders with page layout tools and 

insert complete graphical objects. 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

• Use font sizes between 12 and 18 points for cell contents. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 
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But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

To change the text size for a default named style 

1. Go to menu item: Format > Styles and Formatting (F11) 

2. Select the style to modify from the list 

3. Right click and select: Modify… 
4. Select the Font tab 

5. Select a font size under Size 
6. Exit with OK 
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9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ratio of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. In order to determine whether the colors in your 

document have sufficient contrast, you can consult an online 

contrast checker, such as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 
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Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use OpenOffice Calc’s 

review functionality features to track changes, such as revision 

history. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
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Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Navigational Instructions 

Provide a general description of the spreadsheet contents and 

instructions on how to navigate the data effectively. The best way 

to do this is to make a cell at the beginning of the data (e.g., A1) 

with this information. It will be the first cell accessed by assistive 

technologies. If you are using this cell for a label or data, you can 

attach a comment note to the cell containing navigational 

instructions. 

Technique 11. Check Accessibility 

At this time, Calc does not offer a mechanism to check for potential 

OpenOffice Calc  |  485



accessibility errors in your document prior to publishing. [Tested: 
September 30th, 2010] 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 
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3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 

HTML 

1. Apply one of the default heading paragraph styles to the 

paragraphs where you want to generate an HTML page 

2. Go to menu item: File > Send > Create HTML Document 
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3. In the Styles box, select the paragraph style that you want to 

use to generate a new HTML page 

4. Enter a path and a name for the HTML document 

5. Click Save 
6. Check the HTML file for accessibility (see Technique 11) 

To clean up your HTML file 

1. Remove unnecessary styles, line breaks, etc. 

2. Remove unnecessary id, class, and attributes 

3. Remove font tags 

4. Remove styles in the <head> tag 

5. Ensure the <th> tags have a scope attribute 

6. Remove <p> tags nested inside <th> and <td> tags 

7. Check for accessibility (see Technique 11) Note: you may wish to 

use HTML editors or utilities to help with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

• Read Text – an extension that reads text from Calc 

• OOo2GD – an extension that allows you to export, update and 

import all documents, spreadsheets and presentations 

between OpenOffice.org applications and Google docs. 
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Accessibility Help 

If you are interested in what features are provided to make using 

Calc accessible, documentation is provided in Calc’s Help system: 

1. Go to menu item: Help > OpenOffice.org Help (F1) 

2. Enter “accessibility” as the Search Term 
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Office Documents: Presentation





Google Slides 

Usage Notes 

At the time of testing (December 2019), Google Slides lacks several 

features that enable accessible office document authoring, most 

notably: a separate document title field and the ability to indicate 

headings for rows and columns. With this in mind, be cautious of 

templates available in the Google Slides template gallery and be sure 

that they comply the techniques discussed here. 

While there is no accessibility checking feature built into Google 

Slides, you can install a third-party add-on called Grackle Slides. 

Grackle is a third-party plug-in that includes an accessibility 

checker along with other features that enhance accessibility on 

Grackle Slides (see Technique 11). Due to the nature of Google Slides, 

some accessibility features, such as tables, are only fully accessible 

when exporting the document to another format, like a HTML or 

PDF file. 

What’s an “Office Document”? 

You should use these techniques when you are using Google Slides 

to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
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• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

Google Slides does not have a default file format, as it is a web-

based authoring tool. 

Google Slides offers a number of presentation processor and web 

format saving options. Most of these have not been checked for 

accessibility, but some information and/or instructions are 

available for the following formats in Technique 12. 

• Microsoft PowerPoint (.pptx) 

• ODP Document (.odp) 

• PDF Document (.pdf) 

• Plain Text (.txt) 

• JPEG image (.jpg, current slide) 

• PNG image (.png, current slide) 

• Scalable Vector Graphics (.svg, current slide) 
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Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. Files are easily saved 

as various file formats (see Technique 12). 

Editor’s note: Since the content of this page has been 

heavily updated from the original article (Authoring 

Techniques for Accessible Office Documents: Google docs: 

Presentations), the usual editor’s notes that flag new 

content will be omitted. The application-specific steps and 

screenshots were updated in December 2019. 
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Technique 1. Use Accessible Templates 

At this time (December 2019), Google Slides lacks support for 

accessibility features such as table headings. 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

Google Slides’s default template for new documents is a blank 

presentation. The basic installation also includes a wide variety of 

templates for business presentations. These are all accessible by 

virtue of being blank. 

It is possible to create your own templates from scratch in Google 

Slides. As well, you can edit and modify the existing templates, 

ensuring their accessibility as you do so and saving them as a new 

template. 

To select a template 

1. Go to Google Sheets. 

2. At the top right, click on Template Gallery. 
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3. Select a template. 

4. A copy of the template will open. 

To create an accessible template 

1. Create a new document (from the default template or from an 

existing template). 

Note: If creating a template from an existing document, go to 

File > Make a copy. Type a name and choose where to save it, 

then, click Ok. 

2. Rename your document. Be sure to indicate that the document 

is an accessible template by using terms such as “accessible” 

(e.g., “Accessible Memo Template”). This will improve its 

searchability and promote its use as an accessible template. 

3. Ensure that you follow techniques in this document. You may 

also check the accessibility (see Technique 11). 

To share your accessible template as a new document 

You can share your accessible template, but it may be more useful 

to share the file as copy that other users can add to their Google 

Drive. 

1. Go to the address bar change the end of the URL before 

sending it. 

2. Replace “edit” at the end of the URL with “copy”. 

For example: 

Before: http://docs.google.com/document/d/12345678/edit 
After: http://docs.google.com/document/d/12345678/copy 

3. Send the modified copy link. 

4. When the recipient follows the modified copy link, they’re 

instructed to click on Make a copy. 
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5. They can then work on a copy of the accessible template. 

For more information, see the resources below: 

• Google: Create document templates 

• Google: Share “Make a copy” links to your files 

Technique 2. Set Document Language 

At this time, Google Slides does not offer an explicit language 

selection mechanism to indicate the natural language of your 

document or changes in natural language at any point within the 

content. Google Slides defaults the natural language to the language 

selected for your Google Account. When exporting to other 

document formats, there is no guarantee that the natural language 

of your Google Account will be indicated as the natural language of 

your document. 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

Technique 3. Use Built-In Layout and Styling 
Features 

Google Slides does not offer “True Headings” or “Named Styles”. 
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3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. 

Note: The built-in layouts can be more accessible to users of 

assistive technologies because they technologies sometimes read 

the floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order elements were placed. 

To apply “true layout” to a slide 

1. Go to menu item: Slide > New Slide… (Ctrl+M). 

2. In the Layout drop-down on the toolbar, select a slide layout 

from the options. 
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3. A new slide will be inserted into the presentation with the 

layout you selected 

3.2 Customize Using Master Slides 

Google Slides is  packaged with master slides available for your use. 

If a layout must be customized, it is recommended that Master 

Slides be used. 

Every slide layout in a presentation is defined by its master slide. 

A master slide determines the formatting style for various elements 

of the slide layout. This includes font styles, character formatting, 
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and the positioning of elements. Essentially, each master slide acts 

as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, 

the change will affect all slides that were created based on it. For 

this reason, it is good practice to edit the master slide and use 

the slide layouts before building individual slides. It is essential 

that you create and use master slides that meet the accessibility 

requirements outlined in this document. 

One way around this is to format a slide, ensuring its accessibility, 

and then create duplicates of that slide within your presentation. 

You can then edit the content of the duplicate slides, while ensuring 

that its layout meets accessibility requirements. In this way, the 

original slide acts as design template for the slides derived from it. 

To duplicate a slide 

1. Go to menu item: Slide > Duplicate slide. 

2. Edit the content of your duplicate slide, ensuring your changes 

do not negatively affect accessibility of the slide. 

To change a theme 

1. Go to the menu item Slide, then select Change theme. 
2. On the right sidebar, select the theme you want. 

Note: If you would like to include a unique slide layout for a single 

slide, see Google: Learn how to apply a theme to only one slide. 

To customize a master slide 

1. Go to the menu item Slide > Edit master. 
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Optional:  Before editing the master, you can first select a 

theme that is similar to the design you want before editing the 

master (select Theme, then select a theme from the right). 

2. In the master template editor, select the Master slide at the 

top. 

3. Make your edits to the master slide. 

4. When finished, select the “x” at the top-righthand side of the 

menu to close. 

5. Your presentation should be updated with the changes. 

For more details on how to customize your presentation, see 

Google: Change the theme, background, or layout in Google Slides. 

Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 

objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. 

However, when you are working with “floating” objects, it is 

important to remember that the way objects are positioned in two 
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dimensions on the screen may be completely different from how 

the objects will be read by a screen reader or navigated using a 

keyboard. The order that content is navigated sequentially is called 

the “Tab Order” because often the “Tab” key is used to navigate from 

one “floating” object to the next. 

Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 

when they are inserted, the default tab order is 

from the first object inserted to the last. However, 

this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 

for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 

• For more complex layouts, it may be easier to 

simply to create the slide as usual and then set the 

tab order (see below). 
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To set the tab order 

1. Select the object. 

2. Go to menu item Arrange > Order > Bring to front, Bring 
forward, Send backward, or Send to back. 

Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 

of your slides in text format. Slide notes can be created as you build 

your presentation. 

To add notes to your slides 

1. Go to menu item: View > Show Speaker Notes 
Note: Once you have selected this option, the Speaker notes 
pane will appear on the right side of the window for each slide. 

If you close the Speaker notes pane, you will have to perform 
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the above step to access it again. 

2. In the Speaker notes pane on the right, enter notes to 

accompany each slide. 

Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

Google Slides offers a mechanism for adding alternative text to 

images and objects where it can be readily accessed by screen 

reader users. While you can add alt text, you will need to ensure that 

you provide the longer descriptions in the body of the document, 

near the images and objects. While this solution is not optimal 

for screen reader users and will complicate your own accessibility 

testing, it is necessary until long descriptions are supported. 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 

convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

of each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 
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information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 
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the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* on the image. 

2. Select Alt Text from the contextual menu. 
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3. Add your alt text to the Description field. 

4. Press OK to saveNote: Enter a description in the Title field will 

show a pop-up tooltip when users hover over the image with 

their mouse.  However, it is recommended to put the image 

description in the Description field. 

Technique 7. Use Built-In Structuring Features 

7.1 Tables 

At this time (December 2019), Google Slides does not offer a 

mechanism that allows you to select and indicate headings for rows 

and columns. Since it is not possible to create complex tables in 

Google Slides that are accessible, avoid creating complex tables 

since table headers cannot be designated. 

If you use the Grackle Slides add-on, tables can be given structure 

and table headings can be indicated. While these fixes won’t be 

useful for making tables more accessible in Google Slides, it does 
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allow you to export the document into another format with 

appropriate table tags intact. For more on Grackle Slides, see 

Technique 11. 

 

When using tables, it is important to ensure that they are clear 

and appropriately structured. This helps all users to better 

understand the information in the table and allows assistive 

technologies (e.g., screen readers) to provide context so that the 

information within the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 
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the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Select the text box or highlight the text 

2. Go to the menu bar 

3. Click the Numbered list or Bullet list button 
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7.3 Columns 

Use Columns feature for placing text in columns. 

Note: Because columns can be a challenge for users of some assistive 

technologies, consider whether a column layout is really necessary. 

7.4 Document Title 

At this time (December 2019), Google Slides makes use of a single 

document name. Within Google Slides, this serves well as a title, but 

when exporting to ODT, the document name is used to form the file 

name, and the ODT “Title” properties field is left blank, or it lists the 

title used in the first slide of the presentation. 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the file name of the current document 

1. Go to menu item: File > Rename 
2. In the Rename Document dialog, enter a new document name 

3. Click OK 
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Technique 8. Create Accessible Charts 

In Google Slides, you can insert data charts linked to an existing 

Google Sheet file (see Google Help: Link a chart or table to Google 

Slides for instructions). 

Charts can be used to display data in meaningful ways for your 

audience. It is important to ensure that your chart is as accessible 

as possible to all members of your audience. All basic accessibility 

considerations that are applied to the rest of your document must 

also be applied to your charts and the elements within your charts. 

For example, use shape and color, rather than color alone, to convey 

information. As well, some further steps should be taken to ensure 

that the contents are your chart are appropriate labeled to give 

users reference points that will help to correctly interpret the 

information. 

To add a new chart to a presentation 

1. Go to Insert > Chart. 
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2. Select the type of chart you want to add. 

Note: To edit a chart, see Google Help: Edit or Update Chart 

Data. 

Note: To learn more about how to customize the chart you 

created, see BrightCarbon: Google Slides: The ULTIMATE guide 

(blog post). 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 
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who are color blind 

• When creating bar charts, it is helpful to apply textures instead 

of colors to differentiate the bars 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2) 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 
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font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ratio of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 
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distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use Google Slides’s 

change tracking features to track changes, such as revision 

history. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 
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to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 
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10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. 

To add hyperlinks with meaningful text 

1. Go to menu item: Insert > Link. Alternately, you can select the 

text you’d like to add a link to and press Ctrl+K (or Cmd+K on 

Macs). 

2. In the pop-up box, enter descriptive text in the Text display 

box. 

3. Enter the link address in the Link. 

4. Select Apply. 

10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 
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presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 

Enable live automatic captions when presenting 

In Google Slides, you can present slides with automatic captions 

that displays the speaker’s words in real time at the bottom of the 

screen. 

Note: This feature is only available on Chrome devices in U.S. 

English. Also, captions are not stored. 

Step 1: Set up your microphone 

1. Google Slides requires your computer’s microphone or an 

external microphone paired with your computer to be turned 

on and working. 

2. Devices and microphones vary, so be sure to check your 

computer’s settings. Typically, these settings are found under 

System Preferences on a Mac or in the Control Panel on a PC. 

Step 2: Present with captions 

1. Connect to the internet. 

2. Open your presentation. 

3. To start presenting, click Present. 

4. To turn on captions, click CC. 

As you speak, the captions (without punctuation) appear at the 

bottom of the screen. 

5. To turn off captions, click CC again. 
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For more details on enabling live automatic captions when 

presenting, see Google: Present slides with captions. 

Technique 11. Check Accessibility 

At this time (December 2019), Google Slides does not offer a 

mechanism to check for potential accessibility errors in your 

document prior to publishing. However, a third-party add-on called 

Grackle Sheets can be used to check the accessibility of your 

workbook (see below). 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 
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• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Grackle Slides 

Warning: Automated accessibility checkers cannot be trusted to 

check for all accessibility concerns, so be sure to review the 

recommended techniques in this document. 

What is Grackle Slides? Grackle Slides is a third-party add-on 

that runs on spreadsheets created in Google Sheets. It helps with 

checking and improving the digital accessibility of your document. 

Due to the nature of Google Sheets, some accessibility features, 

such as tables, are only fully accessible when exporting the 

document to another format, like an HTML file. 

How does it work? After Grackle is launched, It scans the current 

spreadsheet for accessibility issues and identifies and locates 

errors. Feedback appears in a sidebar that is docked on right-side 
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of the screen. By exploring the sidebar, you can immediately learn 

about accessibility issues and find and fix the detected errors by 

interacting with the Grackle sidebar. Due to the nature of Google 

Slides, some accessibility features, such as tables, are only fully 

accessible when exporting the document to another format, like a 

HTML or PDF file. 

Note: Grackle’s accessibility checker is free to use; however, the 

ability to export and produce accessible HTML spreadsheets, and so 

on, is only free for the first 30 days (as of December 2019). 

At the time of testing, creating tagged PDFs in Grackle Slides is 

still in beta testing. While there are some export limitations, Grackle 

Slides performs accessibility checks that are valuable. 

Grackle Slides performs the following 16 accessibility checks: 

• Presentation 

◦ Presentation title is required 

◦ Document language should be specified 

• Slides 

◦ A slide should have a title 

◦ Slide title should be unique 

◦ A slide should not be empty 

• Tables 

◦ Tables should be tagged and described 

◦ The use of merged cells is not recommended 

◦ The use of empty cells is not recommended 

• Elements 

◦ Images should have alternative text 

◦ Elements should have alternative text 

◦ Text boxes should not be empty 

◦ Lists should not be broken apart 

• Content 

◦ Fine print should be avoided 

◦ High color contrast should be used 

◦ In-line style changes may lack clear meaning 
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◦ Empty trailing lines should be removed 

How to install Grackle Slides 

Grackle Slides can be installed from the Add-ons menu of a Google 

Slides document. 

1. Open a Google presentation document. 

2. Select Add-ons > Get Add-ons. 

◦ Search for “Grackle” in the search field. 

◦ Select the add-on and click Install. 

3. Note: A message will appear requesting access to data that the 

add-on needs to work. Review the message and click Allow. 

How to launch and use Grackle Sheet 

Grackle Sheets is simple to launch and is accessed from the Add-ons 

menu. 

1. Open a Google Slide document. 

2. From the Add-ons menu, select Grackle Slides, then select 

Launch. 
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3. A sidebar launches that identifies errors and warnings. 

◦ Clicking on each error and warning will expand the 

selection and provide guidance on how to resolve each 

issue. 

◦ Select the “Locate” button on any flagged item will take 

you to that line of the document to review. 

◦ Continue to review and address each flagged item. 

4. Select the “Re-Check” button at the top of the sidebar to 

update the report. 

5. Continue to revise until all checks have passed. 

Troubleshooting Grackle Slides 

When testing the Grackle Slides, we found that the plugin would 

sometimes error out. Grackle Slides would indicate that the checks 

are complete, but the remediation functionality in the Grackle 

sidebar is not responsive. 
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Steps you can take when the Grackle Slide plugin does not 

function correctly: 

1. Export as a Microsoft PowerPoint file 

2. Open a new presentation file. 

3. Go to File > Import slides 

4. Run Grackle again 

Note: After exporting to PowerPoint, you can run Microsoft’s built-

in accessibility checker. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

To save in a different format 

1. Go to menu item: File > Download as 
2. Select format 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 
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To clean up your HTML file 

1. Remove unnecessary styles, line breaks, etc. 

2. Remove unnecessary id, class, and attributes 

3. Remove font tags 

4. Remove styles in the <head> tag 

5. Ensure the <th> tags have a scope attribute 

6. Remove <p> tags nested inside <th> and <td> tags 

7. Check for accessibility (see Technique 11) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

The following accessibility related plug-ins and support are 

available for Google Slides: 

• Grackle Slides 

• Keyboard shortcuts for Google Slides 

• Google Slides Section 508 Compliance 

Accessibility Help 

If you are interested in what features are provided to make using 

Google Slides more accessible to users, documentation is provided 

in online articles and Help forums: 
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1. Go to menu item: Help > Google Docs Help Center 

References and Resources 

1. Google Slides Help Center (a list of help topics) 

2. Google Slides Learning Center (list of tutorials and guides) 

3. Grackle Slides (plugin that checks for accessibility) 

4. Google: Make your document or presentation more accessible 

5. GAWDS Writing Better Alt Text 
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Microsoft PowerPoint 2010, 
2013, 2016, and 2019 

Usage Notes 

At the time of testing (December 2019), PowerPoint provides a set 

of accessibility features that is sufficient to enable the production 

of accessible digital office documents. In addition, PowerPoint 

includes an accessibility checking feature. 

What’s an “Office Document”? 

You should use these techniques when you are using PowerPoint to 

create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc., and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
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Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for PowerPoint is Office Open XML (PPTX). 
In addition, PowerPoint offers many other presentation processor 

and web format saving options. Most of these have not been 

checked for accessibility, but some information and/or instructions 

are available for the following formats in Technique 12 (below): 

• MS PowerPoint (PPT) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. The application-

specific steps and screenshots in this document were created using 

Microsoft PowerPoint 2010 (ver. 14.0.4760.1000, Windows XP, Sept. 

2010)  while creating a PPTX document. Files are also easily saved as 

other file formats (see Technique 12, below). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11, below). 

PowerPoint’s default template for new documents is a blank 

presentation. If you are connected to the internet, you can access 

a variety of blank business presentation templates through 

Office.com. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in PowerPoint. As well, you can edit and modify the existing 

prepackaged templates, ensuring their accessibility as you do so and 

saving them as a new template. 
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To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11, below) 

4. Go to menu item: File > Save As 
5. In the Save as type list, select PowerPoint Template 
6. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Sales Template”) will 

increase the prominence of the accessibility status. As well, 

filling in the text box labeled Tags with the term “accessibility” 

will improve its searchability as an accessible file. 

7. Select Save 

To select an accessible template 

Only use these steps if you have an accessible template available 
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(e.g., that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: File > New 
2. Under Available Templates, select My Templates 

3. In the New document dialog, select your accessible template 

from the list 

4. Select OK 

5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 
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Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To change the default language 

1. Go to menu item: File 
2. Select Options from the list in the left window pane 

3. Select Language from the list in the left of the Options dialog 

4. Under Chose Editing Languages, select the editing language 

you want to use 

Note: to add an editing language, select the language from the 

drop down list labeled [Add additional editing languages] 
5. Select Set as Default 
6. Close all Office programs and open them again for the changes 

to take effect 
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To apply a language directly to selected text 

1. Select the text 

2. Go to menu item: Review 
3. In the Language section, select the Language button 

4. Select Set Proofing Language 
5. In the Mark selected text as box, select the language from the 

list 

6. Select OK 
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Technique 3. Use Built-In Layout and Styling 
Features 

PowerPoint does not provide “True Headings” or “Named Styles” as 

does Word. 

3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. 

Note: The built-in layouts can be more accessible to users of 

assistive technologies because these technologies sometimes read 

the floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order in which elements were placed. 

536  |  Microsoft PowerPoint 2010, 2013, 2016, and 2019



To apply “true layout” to a slide 

1. Go to menu item: Home 
2. In the Slides section, select the Layout button 

3. Select the layout you would like to use from the drop down 

menu 

3.2 Customize Using Master Slides 

If a layout must be customized, it is recommended that Master 

Slides be used. 

Every slide layout in a presentation is defined by its master slide. 

A master slide determines the formatting style for various elements 

of the slide layout. This includes font styles, character formatting, 

and the positioning of elements. Essentially, each master slide acts 

as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, 

the change will affect all slides that were created based on it. For 
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this reason, it is good practice to edit the master slide and use 

the slide layouts before building individual slides. It is essential 

that you create and use master slides that meet the accessibility 

requirements outlined in this document. 

To create or customize a master slide 

1. Go to menu item: View 
2. In the Master Views section, select the Slide Master icon 

3. The current slide master with its associate layouts appears 

Note: If you have the Normal view open, the slide master is the 

larger slide image in the slide thumbnail pane. The associated 

layouts are positioned beneath the slide master. 

4. Customize the existing master slide and its associated layouts 

to suit your needs (e.g., apply a design, theme-based colours, 

fonts, effects, backgrounds) ensuring that your changes meet 

accessibility requirements 

5. Go to menu item: File > Save As 
6. In the File name box, type a file name 

7. In the Save as type list, select PowerPoint template 
8. Select Save 
9. On the Slide Master tab, in the Close section, select Close 

Master View 
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Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 

objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. 

However, when you are working with “floating” objects, it is 

important to remember that the way objects are positioned in two 

dimensions on the screen may be completely different from how 

the objects will be read by a screen reader or navigated using a 

keyboard. The order that content is navigated sequentially is called 

the “Tab Order” because often the “Tab” key is used to navigate from 

one “floating” object to the next. 
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Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 

when they are inserted, the default tab order is 

from the first object inserted to the last. However, 

this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 

for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 

• For more complex layouts, it may be easier to 

simply create the slide as usual and then set the 

tab order (see below). 

To set the tab order using the ‘Selection Pane’ 

1. Go to menu item: Home 
2. In the Drawing section, select Arrange > Selection Pane… 
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3. In the Selection and Visibility pane, all the elements on the 

slide are listed in reverse chronological order under Shapes on 
this Slide 

4. Elements can be re-ordered using the Re-order buttons 

located at the bottom of the Selection and Visibility pane 

Note: The tab order of elements begins at the bottom of the list 

and tabs upwards. 

Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 

of your slides in text format. Slide notes can be created as you build 

your presentation. 

To add notes to your slides 

1. Go to menu item: View 
2. In the Presentation Views section, select Normal to ensure 

that the notes panel is in view 

Note: You can then select menu item Home, to access text 

formatting options 

3. The Notes Pane can be found at the bottom of the window, 

below the slide 

4. Type and format your notes within the Notes Pane below each 

slide 

Microsoft PowerPoint 2010, 2013, 2016, and 2019  |  541



Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 
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Tips for writing alternative text (“Title” in 
PowerPoint) 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the title 

text (e.g., a summary of the trend) and more detail 

in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions (“Description” 
in PowerPoint) 

• Long descriptions should be used when text 
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alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* the object 

2. Select Format Picture… 
3. Select the Alt Text option from the list 

4. Fill in the Title. If more description is required (e.g., for a chart 

or graph), provide a short description in the Title (e.g., a 

summary of the trend) and more detail in the Description. 

Note: If the document is ever saved to HTML, the Title and 

Description fields are combined into a single HTML <alt> tag. 
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Editor’s note: For more details about adding alternative 

text to your PowerPoint slides, including how to toggle 

automatic alt text, see how to add alt text. 

Technique 7. Use Built-In Structuring Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 
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appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables are split across pages, set the header to 

show at the top of each page. Also, set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 
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when they serve as labels to help interpret the 

other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

To add a table with headings 

1. Go to menu item: Insert 
2. In the Tables section, select the Tables icon 

3. Select the number of rows and columns you would like your 

table to have 

4. Select the table and a Table Tools menu item should appear 

5. Go to menu item: Table Tools > Design 
6. In the Table Style Options section, select the Header Row 

check box 

Note: Whenever possible, keep tables simple with just 1 row of 

headings. 

7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 
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To create an ordered or unordered list 

1. Go to menu item: Home 
2. In the Paragraph section, select the Bullets icon for unordered 

lists or select the Numbering icon for ordered lists 

3. To select a different list format, select the arrow beside the 

icon 

4. Select a format from the format Library that appears in the 

drop-down menu 

To modify list styles 

1. Go to menu item: Home 
2. In the Paragraph section, select the arrow beside the Bullets 

icon for unordered lists or select the arrow beside the 

Numbering icon for ordered lists 

3. Select Define New Bullet… to create a new unordered list 

format 

4. Select Define New Number Format… to create a new ordered 

list format 

5. In the New Bullet dialog or the New Number Format dialog, 

select the list characteristics 

6. Select OK 

7.3 Columns 

Use Columns feature for placing text in columns. 

Note: Because columns can be a challenge for users of some assistive 

technologies, consider whether a column layout is really necessary. 
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7.4 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File 
2. Select Info from the list in the left window pane 

3. In the right window pane, select the Title text box 

4. Enter the Title 
Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

7.5 Slide Titles 

Unique slide titles aid navigation for non-visual users. 

To add a visible title to a slide 

1. Go to menu item: Home. 
2. Select Reset in the Slides section. 

3. Enter a title at the top of the slide. 

Note:Slide titles should be unique for clarity and ease of 

navigation. 
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To add an invisible title to a slide 

1. Enter your title at the top of the slide. 

2. Go to menu item: Home. 
3. From the Drawing menu, select Arrange > Selection Pane. This 

will open the Selection and Visibility pane. 

4. In the Selection and Visibility pane, click on the eyeball icon 

next to the slide title to change visibility settings. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and colour, rather than 

colour alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriately labeled to give users reference points that will help 

them to correctly interpret the information. 

To create a chart 

1. Select a Slide Layout that contains a placeholder for a chart 

(see Technique 3.1, above) 

2. Select the Insert Chart icon from the center of the placeholder 

3. Select a Chart Type from the Insert Chart dialog 

4. Select OK 
Note: This will open the Excel document titled “Chart in 

Microsoft Office PowerPoint”, where you can input the data 
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you would like to include in the chart. When you have done 

this, simply close the Excel window and the data will appear on 

the chart in the PowerPoint presentation. 

To add titles and labels 

1. In the Chart Tools menu section, go to menu item: Layout 
2. In the Labels section, select the type of title or label you would 

like to define (e.g., Chart Title, Axis Titles, Data Labels) 

To apply a predefined Chart Layout 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Chart Layouts section, select a Quick Layout from the 

scrolling Chart Layouts gallery 

To change to a different predefined Chart Type 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Type section, select the Change Chart Type icon 

3. In the Change Chart Type dialog, select a chart type from the 

left pane 

4. Select a Chart Design from the right pane 

5. Select OK 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 
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who are colour blind 

• When creating bar charts, go to menu item: Chart Tools > 
Format and in the Shape Styles section select Shape Fill to 

apply a texture to help distinguish the bars 

• Change the default colours to a colour safe or gray-scale 

palette 

• Use the formatting options to change predefined colours, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2, below) 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 
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documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change document details such the pagination, 

the layout of tables, etc., it is best practice to always format text for 

a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ratio of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid colour for a text background rather 

than a pattern. 

In order to determine whether the colours in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 
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9.3 Avoid Using Colour Alone 

Colour should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where colour might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the colour 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the colour of text 

you have edited and noting the colour. Instead use 

PowerPoint’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 
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9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or colour combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colours, fonts 

and images. 
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• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To change link text 

1. Highlight the link and right-click* 

2. Select Edit Hyperlink (Ctrl + K) 

3. Change the text in the Text to display box to something 

descriptive 

10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 
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presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 

Technique 11. Check Accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1, above), PowerPoint offers an “Accessibility 

Checker” to review your document against a set of possible issues 

that users with disabilities may experience in your file. 

The “Accessibility Checker” classifies issues as: 

• Error – content that makes a file very difficult or impossible 

for people with disabilities to understand 

• Warning – content that in most, but not all, cases makes a file 

difficult for people with disabilities to understand 

• Tip – content that people with disabilities can understand, but 

that might be better organized or presented in a way that 

would maximize their experience 

To learn more about the Accessibility Checker and the rules it uses 

to identify and classify accessibility issues in your document, visit 

the PowerPoint help section (see Accessibility Help, below). Use the 

search term “accessibility checker rules” in the help search box. 
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To use the “Accessibility Checker” 

1. Go to menu item: File 
2. Select Info in the left window pane 

3. Under Prepare for Sharing, an alert will appear if a potential 

accessibility issue has been detected 

4. To view and repair the issues, select Check for Issues and then 

Check Accessibility 

5. An Accessibility Checker task pane will open, showing the 

inspection results 
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6. Select a specific issue to see Additional Information 
7. Follow the steps provided to fix or revise the content 
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In order to get further indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 
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To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking options 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 
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Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 (above). 

1. Go to menu item: File 
2. Select Save As 
3. In the File name box, type a name for the file 

4. In the Save as type list, select PDF or XPS Document 
5. Select the Options button 

6. Under Include non-printing information in the Options 
dialog, ensure that the Document structure tags for 
accessibility check box is selected 

7. Select OK and Save 
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HTML 

1. Go to menu item: File 
2. Select Save As 
3. In the File name box, type a name for the file 

4. In the Save as type box, select Web Page 
5. Select Save 
6. Check the HTML file for accessibility (see Technique 11, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 
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• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

The following accessibility related plug-ins and support are 

available for PowerPoint 2007: 

• PPT2HTML – offers an accessibility tool bar for adding alt-text 

to charts. 

• PowerTalk – an accessibility tool that provides a good 

approximation of how presentations will sound with a screen 

reader. [Editor’s note: Tool no longer available.] 

• HiSoftware – desktop add-ins that will create a Section 508 or 

WAI Fully Compliant Web pages from PowerPoint 

presentations (some knowledge of HTML code is required). 

• Keyboard shortcuts in PowerPoint 

• Accessibility Tutorials for Office 

Accessibility Help 

If you are interested in what features are provided to make using 
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PowerPoint more accessible to users, documentation is provided in 

the Help system: 

1. Go to menu item: File 
2. Select Help from the list on the left 

3. Under the Support section, select the Help icon 

4. Enter “Accessibility” as your search term in the Help dialog box 

References and Resources 

1. Microsoft PowerPoint Help 
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Microsoft PowerPoint for 
Mac 2008, 2011, 2016, and 2019 

Usage Notes 

Overview 

At the time of testing (January 17, 2011), as long as images are 

avoided, PowerPoint for Mac provides a set of accessibility features 

that is sufficient to enable the production of accessible digital office 

documents. However, PowerPoint 2008 for Mac does not include an 

accessibility checking feature. 

Editor’s note: Later versions of PowerPoint for Mac 

include an accessibility checking feature. For more 

information, please see the following: 

• Make your PowerPoint presentations accessible to 

people with disabilities 

• What’s new in accessibility for PowerPoint for Mac 

and iOS 
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What’s an “Office Document”? 

You should use these techniques when you are using PowerPoint for 

Mac to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for PowerPoint for Mac is Office Open XML 
(PPTX). 

In addition, PowerPoint for Mac offers many other presentation 

processor and web format saving options. Most of these have not 

been checked for accessibility, but some information and/or 

instructions are available for the following formats in Technique 12 

(below): 

568  |  Microsoft PowerPoint for Mac 2008, 2011, 2016, and 2019

http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php
http://www.w3.org/WAI/intro/wcag.php


• PPT (MS PowerPoint 97–2004) 

• POTX (PowerPoint Template) 

• PDF 

• ODP (OpenDocument Presentation) 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

*Right-click: To right-click with the keyboard, select the object 

using the Shift+Arrow keys and then press either (1) the “Right-

Click” key (some keyboard have this to the right of the spacebar) or 

Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using Microsoft PowerPoint 2008 for Mac (ver. 12.0 

(071130), Mac OS X, Jan. 2011)  and Microsoft PowerPoint for Mac 

(version 16.16.17) while creating a PPTX document. Files are also 

easily saved as other file formats (see Technique 12, below). 

This document is provided for information purposes only and is 
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neither a recommendation nor a guarantee of results. If errors are 

found, please report them to: adod-comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11, below). 

PowerPoint for Mac’s default template for new documents is a 

blank presentation. If you are connected to the internet, you can 

access a variety of blank business presentation templates through 

Office.com. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 

scratch in PowerPoint for Mac. As well, you can edit and modify the 

existing prepackaged templates, ensuring their accessibility as you 

do so and saving them as a new template. 

To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11, below) 

4. Go to menu item: File > Save As 
5. In the Save As box, type a name for the template. Using a 
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descriptive File name (e.g., “Accessible Sales Template”) will 

increase the prominence of the accessibility status. 

6. In the Format list, select PowerPoint 97–2004 (.pot) 
7. Select Save 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > Project Gallery… 
2. Under Category, select My Templates (or select where you 

saved the template) 

3. Select your accessible template from the template gallery 

4. Select Open 

Microsoft PowerPoint for Mac 2008, 2011, 2016, and 2019  |  571



5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To change the default language 

1. Go to menu item: Tools > Language 
2. In the Mark select text as box, select the language from the 
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list 

3. Select Default… 
4. Select OK 

To apply a language directly to selected text 

1. Select the text 

2. Go to menu item: Tools > Language… 
3. In the Mark selected text as box, select the language from the 

list 

4. Select OK 

Microsoft PowerPoint for Mac 2008, 2011, 2016, and 2019  |  573



Technique 3. Use Built-In Layout and Styling 
Features 

PowerPoint does not provide “True Headings” or “Named Styles” as 

does Word. 

3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. 

Note: The built-in layouts can be more accessible to users of 

assistive technologies because these technologies sometimes read 

the floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order elements were placed. 
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To apply “true layout” to a slide 

1. Go to menu item: Format > Slide Layout 
2. In the Slide Layout section that opens, select the layout you 

would like to use 

3.2 Customize Using Master Slides 

If a layout must be customized, it is recommended that Master 

Slides be used. 

Every slide layout in a presentation is defined by its master slide. 

A master slide determines the formatting style for various elements 

of the slide layout. This includes font styles, character formatting, 

and the positioning of elements. Essentially, each master slide acts 

as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, the 

change will affect all slides that were created based on it. For this 

reason, it is good practice to edit the master slide and use the 

slide layouts before building individual slides. It is essential that 
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you create and use master slides that meet the accessibility 

requirements outlined in this document. 

To create or customize a master slide 

1. Go to menu item: View > Master > Slide Master 
2. The current slide master with its associate layouts appears 

Note: If you have the Normal view open, the slide master is the 

larger slide image in the slide thumbnail pane. The associated 

layouts are positioned beneath the slide master. 

3. Customize the existing master slide and its associated layouts 

to suit your needs (e.g., apply a design, theme-based colors, 

fonts, effects, backgrounds) ensuring that your changes meet 

accessibility requirements 

4. To create a new master slide, select the Insert New Master 
icon 

5. On the Slide Master toolbar, select Close Master 
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Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 

objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. 

However, when you are working with “floating” objects, it is 

important to remember that the way objects are positioned in two 

dimensions on the screen may be completely different from how 

the objects will be read by a screen reader or navigated using a 

keyboard. The order that content is navigated sequentially is called 

the “Tab Order” because often the “Tab” key is used to navigate from 

one “floating” object to the next. 

Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 

when they are inserted, the default tab order is 

from the first object inserted to the last. However, 

this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 
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for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 

• For more complex layouts, it may be easier to 

simply to create the slide as usual and then set the 

tab order (see below). 

To set the tab order 

1. Right-click* the image or object 

2. Select Order > Bring to Front, Send to back, Bring Forward or 

Send Backward 

Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 

of your slides in text format. Slide notes can be created as you build 

your presentation. 
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To add notes to your slides 

1. To ensure the notes panel is in view, go to menu item: View > 
Normal 

2. The Notes Pane can be found at the bottom of the window, 

below the slide 

3. Type and format your notes within the Notes Pane below each 

slide 

Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 
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describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 
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alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

 

1. Select the object, then choose one of the options below: 

◦ Right-click the object and select Edit Alt Text…. The Alt 
Text pane opens. 
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▪ Note: If the Edit Alt Text… option is not visible, select 

Format Object/Picture. 

◦ Alternately, select an object. In the menu, select the 

object’s Format tab. Then, select Alt Text. 

2. In the Alt Text pane, add the alternative text to the 

Description field. 
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Technique 7. Use Built-In Structuring Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 
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screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. Whenever possible, use 

just one row of headings. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 
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other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

To insert a table with header rows: 

1. Go to menu item: Insert > Table… 
2. Select the number of columns and rows 

3. Select OK 
4. In the Table Styles section that opens above the document 

pane, select the Options drop-down menu 

5. Select Header Row 
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7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Select the text 

2. If the Formatting Palette is not in view, go to menu item: View 
> Toolbox, Formatting Palette 

3. In the Formatting Palette, select Bullets and Numbering if it is 

not already open 

4. In the Bullets and Numbering section, select Type, Bullets for 

bulleted lists or Type, Numbering for numbered lists 

5. To change the style, select a list style from the Style drop-

down list 
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At this time, it is not possible to modify pre-formatted list styles or 

to create your own list styles. [Tested: January 26, 2011] 

7.3 Columns 

Use Columns feature for placing text in columns. However, because 

columns can be a challenge for users of some assistive technologies, 

consider whether a column layout is really necessary. 
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7.4 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File > Properties 
2. Enter the Title in the Title text box 

3. Select OK 
Note: The title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 
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Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 
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To create a chart 

1. Select a Slide Layout that contains a placeholder for a chart 

(see Technique 3.1, above) 

2. Select the Insert Chart icon from the center of the placeholder 

3. Select a Chart Type from the Charts section above the 

document pane 

Note: This will open the Excel document titled “Chart in 

Microsoft Office PowerPoint”, where you can input the data 

you would like to include in the chart. When you have done 

this, simply close the Excel window and the data will appear on 

the chart in the PowerPoint presentation. 

Note: This applies a predefined Chart Layout, which can be 

changed at any time simply by selecting the chart and 

following Steps 2 and 3 above. 

To add titles and labels 

1. Select the chart 

2. If the Formatting Palette is not open, go to menu item: View > 
Toolbox, Formatting Palette 

3. Select Chart Options to open the Chart Options section, if it is 

not already open 

4. Under Titles, select the title from the Chart Title drop-down 

list or enter a title in the text box below the drop-down list 

5. Under Other options, select the Labels and Legends you 

would like to include from their respective drop-down lists 

6. Under Chart Data, select Data Table with Legend Keys from 

the Data Table drop-down list to include a data table to help 

further support the chart 
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Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• When creating bar charts, go to menu item: Chart Tools > 
Format and in the Shape Styles section select Shape Fill to 

apply a texture to help distinguish the bars 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2, below) 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 
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• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 
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9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use PowerPoint for 

Mac’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 
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9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 
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• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To change link text 

1. Type (or paste in) a web address and press spacebar or “Enter” 

to convert into a hyperlink 

2. Highlight the link 

3. Go to menu item: Insert > Hyperlink… 
4. Edit the text in the Display box 

5. Select OK 
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10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 

presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 

Technique 11. Check Accessibility 

At this time, PowerPoint 2008 for Mac does not offer a mechanism 

to check for potential accessibility errors in your document prior to 

publishing. [Tested: January 17, 2011] 
In order to get some indication of your document or template (see 

Technique 1), then you may consider saving the file into HTML in 
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order to perform an accessibility check in one of those formats, as 

described below. 

Editor’s note: In later versions of PowerPoint for Mac, 

users can check the accessibility of their presentations. For 

more information, see how to use the accessibility checker 

in PowerPoint. 

To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option. 

3. Select the Start Checking button. 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

Note: Before saving in other formats, you may want to run the 

Compatibility Report feature by selecting Compatibility Report… 
from the Save As dialog. This checks the compatibility of your 

existing document with the format you have selected save your 

document as. The results of this check are revealed in the 

Compatibility Report dialog, where you have explanations of errors 

and options to fix them. To run this check at any time, go to menu 

item: View > Toolbox, Compatibility Report. 
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PPT 

1. Go to menu item: File > Save As… 
2. In the Save As box, type a name for the file 

3. In the Format box, select PowerPoint 97-2004 Presentation 
(.ppt) 

4. Select Save 

HTML 

1. Go to menu item: File > Save as Web Page… 
2. In the Save As box, type a name for the file 

3. Select Save 
4. Check the HTML file for accessibility (see Technique 11, above) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 
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Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results by 

the IDRC. 

The following accessibility related plug-ins and support are 

available for PowerPoint for Mac: 

• PPT2HTML – offers an accessibility tool bar for adding alt-text 

to charts. 

• PowerTalk – an accessibility tool that provides a good 

approximation of how presentations will sound with a screen 

reader. [Editor’s note: Tool no longer available.] 

Accessibility Help 

If you are interested in what features are provided to make using 

PowerPoint for Mac more accessible to users, documentation is 

provided in the Help system: 

1. Go to menu item: Help 
2. Enter “Accessibility” as your search term in the Search box 

References and Resources 

1. Microsoft PowerPoint for Mac Help 

2. GAWDS Writing Better Alt Text 

3. Ryerson University: Microsoft PowerPoint Accessibility 
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Microsoft PowerPoint 2007 

Usage Notes 

At the time of testing (January 10, 2011), PowerPoint 2007 provides 

a set of accessibility features that is sufficient to enable the 

production of accessible digital office documents. However, 

PowerPoint 2007 does not include an accessibility checking feature. 

What’s an “Office Document”? 

You should use these techniques when you are using PowerPoint 

2007 to create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
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specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for PowerPoint 2007 is Office Open XML 
(PPTX). 

In addition, PowerPoint 2007 offers many other presentation 

processor and web format saving options. Most of these have not 

been checked for accessibility, but some information and/or 

instructions are available for the following formats in Technique 12 

(below): 

• MS PowerPoint (PPT) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using Microsoft PowerPoint 2007 (ver. 12.0.6535.5002, 

Windows 7, Jan. 2011) while creating a PPTX document. Files are also 

easily saved as other file formats (see Technique 12, below). 

This document is provided for information purposes only and is 

neither a recommendation nor a guarantee of results. If errors are 

found, please report them to: adod-comments@idrc.ocad.ca. 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11, below). 

PowerPoint 2007’s default template for new documents is a blank 

presentation. If you are connected to the internet, you can access 

a variety of blank business presentation templates through 

Office.com. These are all accessible by virtue of being blank. 

It is possible to create your own accessible templates from 
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scratch in PowerPoint 2007. As well, you can edit and modify the 

existing prepackaged templates, ensuring their accessibility as you 

do so and saving them as a new template. 

To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11, below) 

4. Go to menu item: Office > Save As > Other Formats 
5. In the Save as type list, select PowerPoint Template 
6. In the File name box, type a name for the template. Using a 

descriptive File name (e.g., “Accessible Sales Template”) will 

increase the prominence of the accessibility status. As well, 

filling in the text box labeled Tags with the term “accessibility” 

will improve its searchability as an accessible file. 

7. Select Save 

To select an accessible template 

Only use these steps if you have an accessible template available 

(e.g., that you previously saved). Otherwise, simply open a new 

(blank) document. 

1. Go to menu item: Office > New 
2. Under Templates, select My templates… 
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3. In the New Presentation dialog, select your accessible 

template from the list 

4. Select OK 

5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 
images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 
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Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To change the default language 

1. In the operating system, activate the keyboard layout for the 

language in which you want to create and edit text 

2. Right-click* the status bar at the bottom of the window, 

ensure that Language is selected, this displays a reminder of 

the active keyboard layout in the status bar 
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To apply a language directly to selected text 

1. Select the text 

2. Go to menu item: Review 
3. In the Proofing section, select the Language button 

4. In the Mark selected text as box, select the language from the 

list 

5. Select OK 

Technique 3. Use Built-In Layout and Styling 
Features 

PowerPoint 2007 does not provide “True Headings” or “Named 

Styles” as does Word 2007. 

3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. 

Note: The built-in layouts can be more accessible to users of 

assistive technologies because technologies sometimes read the 

floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order elements were placed. 
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To apply “true layout” to a slide 

1. Go to menu item: Home 
2. In the Slides section, select the Layout button 

3. Select the layout you would like to use from the drop down 

menu 

3.2 Customize Using Master Slides 

If a layout must be customized, it is recommended that Master 

Slides be used. 

Every slide layout in a presentation is defined by its master slide. 

A master slide determines the formatting style for various elements 

of the slide layout. This includes font styles, character formatting, 

and the positioning of elements. Essentially, each master slide acts 

as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, 
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the change will affect all slides that were created based on it. For 

this reason, it is good practice to edit the master slide and use 

the slide layouts before building individual slides. It is essential 

that you create and use master slides that meet the accessibility 

requirements outlined in this document. 

To create or customize a master slide 

1. Go to menu item: View 
2. In the Presentation Views section, select the Slide Master 

icon 

3. The current slide master with its associate layouts appears 

Note: If you have the Normal view open, the slide master is the 

larger slide image in the slide thumbnail pane. The associated 

layouts are positioned beneath the slide master. 

4. Customize the existing master slide and its associated layouts 

to suit your needs (e.g., apply a design, theme-based colors, 

fonts, effects, backgrounds) ensuring that your changes meet 

accessibility requirements 

5. Go to menu item: Office > Save As > Other Formats 
6. In the Filename box, type a file name 

7. In the Save as type list, select PowerPoint template 
8. Select Save 
9. On the Slide Master tab, in the Close section, select Close 

Master View 

Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 
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objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. 

However, when you are working with “floating” objects, it is 

important to remember that the way objects are positioned in two 

dimensions on the screen may be completely different from how 

the objects will be read by a screen reader or navigated using a 

keyboard. The order that content is navigated sequentially is called 

the “Tab Order” because often the “Tab” key is used to navigate from 

one “floating” object to the next. 

Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 

when they are inserted, the default tab order is 

from the first object inserted to the last. However, 

this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 

for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 
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• For more complex layouts, it may be easier to 

simply to create the slide as usual and then set the 

tab order (see below). 

To set the tab order using the ‘Selection Pane’ 

1. Go to menu item: Home 
2. In the Drawing section, select Arrange > Selection Pane… 
3. In the Selection and Visibility pane, all the elements on the 

slide are listed in reverse chronological order under Shapes on 
this Slide 

4. Elements can be re-ordered using the Re-order buttons 

located at the bottom of the Selection and Visibility pane 

Note: The tab order of elements begins at the bottom of the list 

and tabs upwards. 
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Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 

of your slides in text format. Slide notes can be created as you build 

your presentation. 

To add notes to your slides 

1. Go to menu item: View 
2. In the Presentation Views section, select Normal to ensure 

that the notes panel is in view 

Note: You can then select menu item Home, to access text 

formatting options 

3. The Notes Pane can be found at the bottom of the window, 

below the slide 

4. Type and format your notes within the Notes Pane below each 

slide 
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Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images and graphical objects 

1. Right-click* the object 

2. Select Size and Position… 
3. Select the Alt Text tab 

4. Fill in the Alternative text box 

616  |  Microsoft PowerPoint 2007



Technique 7. Use Built-In Structuring Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 
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screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. Whenever possible, use 

just one row of headings. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 
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other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 5). 

To add a table with headings 

1. Go to menu item: Insert 
2. In the Tables section, select the Tables icon 

3. Select the number of rows and columns you would like your 

table to have 

4. Select the table and a Table Tools menu item should appear 

5. Go to menu item: Table Tools > Design 
6. In the Table Style Options section, select the Header Row 

check box 

7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 
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To create an ordered or unordered list 

1. Go to menu item: Home 
2. In the Paragraph section, select the Bullets icon for unordered 

lists or select the Numbering icon for ordered lists 

3. To select a different list format, select the arrow beside the 

icon 

4. Select a format from the format Library that appears in the 

drop-down menu 

To modify list styles 

1. Go to menu item: Home 
2. In the Paragraph section, select the arrow beside the Bullets 

icon for unordered lists or select the arrow beside the 

Numbering icon for ordered lists 

3. Select Define New Bullet… to create a new unordered list 

format 

4. Select Define New Number Format… to create a new ordered 

list format 

5. In the New Bullet dialog or the New Number Format dialog, 

select the list characteristics 

6. Select OK 

7.3 Columns 

Use Columns feature for placing text in columns. However, because 

columns can be a challenge for users of some assistive technologies, 

you should consider whether a column layout is really necessary. 
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7.4 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: Office > Prepare > Properties 
2. In the Document Properties section that appears, select the 

Title text box 

3. Enter the Title 

Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 
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Technique 8. Create Accessible Charts 

Charts can be used to display data in meaningful ways for your 

audience. It is important to ensure that your chart is as accessible 

as possible to all members of your audience. All basic accessibility 

considerations that are applied to the rest of your document must 

also be applied to your charts and the elements within your charts. 

For example, use shape and color, rather than color alone, to convey 

information. As well, some further steps should be taken to ensure 

that the contents are your chart are appropriate labeled to give 

users reference points that will help to correctly interpret the 

information. 

To create a chart 

1. Select a Slide Layout that contains a placeholder for a chart 

(see Technique 3.1, above) 

2. Select the Insert Chart icon from the center of the placeholder 

3. Select a Chart Type from the Chart Gallery 
4. Select OK 

Note: This will open the Excel document titled “Chart in 

Microsoft Office PowerPoint”, where you can input the data 

you would like to include in the chart. When you have done 

this, simply close the Excel window and the data will appear on 

the chart in the PowerPoint presentation. 

To add titles and labels 

1. In the Chart Tools menu section, go to menu item: Layout 
2. In the Labels section, select the type of title or label you would 

like to define (e.g., Chart Title, Axis Titles, Data Labels) 
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To apply a predefined Chart Layout 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Chart Layouts section, select a Quick Layout from the 

scrolling Chart Layouts gallery 

To change to a different predefined Chart Type 

1. In the Chart Tools menu section, go to menu item: Design 
2. In the Type section, select the Change Chart Type icon 

3. In the Change Chart Type dialog, select a chart type from the 

left pane 

4. Select a Chart Design from the right pane 

5. Select OK 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• When creating bar charts, go to menu item: Chart Tools > 
Format and in the Shape Styles section select Shape Fill to 

apply a texture to help distinguish the bars 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2, below) 

Technique 9. Make Content Easier to See 
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9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 
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Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 
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However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use PowerPoint 

2007’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 
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9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 
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out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To change link text 

1. Highlight the link and right-click* 

2. Select Edit Hyperlink (Ctrl + K) 

3. Change the text in the Text to display box to something 

descriptive 

10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 

presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 

628  |  Microsoft PowerPoint 2007

http://www.w3.org/WAI/training/accessible
http://www.w3.org/WAI/training/accessible


Technique 11. Check Accessibility 

At this time, Powerpoint 2007 does not offer a mechanism to check 

for potential accessibility errors in your document prior to 

publishing. [Tested: January 10th, 2011] 
In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

Another option is to save the document into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 (above). 

1. Go to menu item: Office > Save As > PDF or XPS 
2. In the File name box, type a name for the file 
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3. Select the Options button 

4. Under Include non-printing information in the Options 
dialog, ensure that the Document structure tags for 
accessibility check box is selected 

5. Under PDF options, ensure that Bitmap text when fonts may 
not be embedded check box is de-selected 

6. Select OK and Save 

HTML 

1. Go to menu item: Office > Save As > Other Formats 
2. In the File name box, type a name for the file 

3. In the Save as type box, select Web Page 
4. Select Save 
5. Check the HTML file for accessibility (see Technique 11, above) 
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To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11, above) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 

Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

The following accessibility related plug-ins and support are 

available for PowerPoint 2007: 

• PPT2HTML – offers an accessibility tool bar for adding alt-text 

to charts. 

• PowerTalk – an accessibility tool that provides a good 

approximation of how presentations will sound with a screen 

reader. [Editor’s note: Tool no longer available.] 

• HiSoftware – desktop add-ins that will create a Section 508 or 

WAI Fully Compliant Web pages from PowerPoint 

presentations (some knowledge of HTML code is required). 
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Accessibility Help 

If you are interested in what features are provided to make using 

PowerPoint 2007 more accessible to users, documentation is 

provided in the Help system: 

1. Select Help icon in the right corner of the application window 

or select F1 
2. Enter “Accessibility” as your search term in the Help dialog box 
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Keynote for Mac 

Usage Notes 

At the time of testing (September 30, 2010), Keynote ’09 lacks 

several features that enable accessible office document authoring, 

most notably: the ability to add alternative text to images and 

objects, indicating natural language, quick styles or named styles, 

and change tracking. As a result, some of the other features that 

might otherwise support accessibility, such as its extensive 

templates are not as effective. In addition, Keynote ‘09 does not 

include an accessibility checking feature, which is a more advanced 

accessibility feature. 

Editor’s note: In later versions of Keynote, users can add 

alt text to images and objects. Apple has added significant 

accessibility improvements to its iWork applications, but an 

accessibility checker is not a feature yet. 

What’s an “Office Document”? 

You should use these techniques when you are using Keynote ’09 to 

create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 
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• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Keynote ‘09 is the native iWork format. In 

addition, Keynote ‘09 offers many other presentation processor and 

web format saving options. Most of these have not been checked 

for accessibility, but some information and/or instructions are 

available for the following formats in Technique 12: 

• MS PowerPoint (PPT) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 
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for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. The application-

specific steps and screenshots in this document were created using 

iWork Keynote ‘09 (ver.5.0.3(791), Mac OS X, Sept. 2010) and 

Keynote, version 9.1 (December 2019) while producing a document 

in the proprietary file format. Files are also easily saved as other file 

formats (see Technique 12). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table 

with rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 
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documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). The default 

template for new documents in Keynote ‘09 is a blank presentation. 

If you are connected to the internet, you can access a variety of 

blank business presentation templates. These are all accessible by 

virtue of being blank. As well, you may create your own templates. 

To create an accessible template 

1. Go to menu item: File > New or File > New from Theme 
Chooser… 

2. In the Theme Chooser dialog, select the White theme or select 

one of the other existing template designs 

3. A new document in your selected template style will open 

4. Ensure that you follow the techniques in this document 

5. When you are finished you should also check the accessibility 

of the document (see Technique 11) 

6. Go to menu item: File > Save Theme… 
7. In the Save As box, type a name for the template. Using a 

descriptive template name (e.g. “Accessible Memo Template”) 

will increase the prominence of the accessibility status. 

8. Specify a folder in which to save your template. Note: By 

default, it will be saved in your home folder in Library/

Application Support/iWork/Keynote/Templates/My 

Templates pane of the Template Chooser. To save the template 

in a different location than the default, create a new folder in 

the Templates folder. The folder name is then used as a 

template category in the Template Chooser. 
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9. Click Save 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g. that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > New from Theme Chooser… 
2. In the Template Chooser dialog, select My Templates from the 

left pane 

3. Select your accessible template and click Choose 
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Technique 2. Set Document Language 

At this time, it is not possible to manually indicate the natural 

language for specific slides or sections of text in Keynote ‘09. As 

well, it is not possible to change the natural language of the 

document itself from the default language. [Tested: September 
30th, 2010] 

Editor’s note: In later versions of Keynote, users are able 

to set a presentation’s language. 

1. Choose File > Advanced > Language & Region (from 

the File menu at the top of your screen). 

2. In the dialog that appears, click the pop-up menus 

and choose a language and a region. 

Note: You can’t change this setting for a shared 

presentation. 

3. Click OK. 

For more details, see how to change a presentation’s 

language and formatting. 

 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

Technique 3. Use Built-In Layout and Styling 
Features 
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3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. Note: 

The built-in layouts can be more accessible to users of assistive 

technologies because they technologies sometimes read the 

floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order elements were placed. Note: Each 

slide in Keynote ’09 is derived from a Master Slide (Technique 3.2) 

applying “true layouts” requires that you use Master Slides that are 

accessible and appropriately designed for your purposes. 

3.2 Customize Using Master Slides 

If a layout must be customized, it is recommended that Master 

Slides be used. Every slide layout in a presentation is defined by 

its master slide. A master slide determines the formatting style 

for various elements of the slide layout. This includes font styles, 

character formatting, and the positioning of elements. Essentially, 

each master slide acts as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, the 

change will affect all slides that were created based on it. For this 

reason, it is good practice to edit the master slide and use the 

slide layouts before building individual slides. It is essential that 

you create and use master slides that meet the accessibility 

requirements outlined in this document. 
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To create or customize a master slide 

1. Select the slide Note: To design a master slide from scratch, 

select a blank slide to start with. Otherwise, select a slide that 

resembles how you would like your slide to look and be sure to 

modify the slide characteristics to align with accessibility 

guidelines in this document. 

2. Go to menu item: View > Show Master Slides 
3. In the Master Slide Navigator in the left pane, select the 

Master Slide Layout you would like to modify

4. Customize the master slide to suit your needs (e.g., define 

placeholders for text, change background elements, add 

alignment guides, and more) ensuring that your changes meet 

accessibility requirements 
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To define default attributes of text and objects 

1. Select the slide Note: To design a master slide from scratch, 

select a blank slide to start with. Otherwise, select a slide that 

resembles how you would like your slide to look and be sure to 

modify the slide characteristics to align with accessibility 

guidelines in this document. 

2. Go to menu item: View > Show Master Slides 
3. In the Master Slide Navigator in the left pane, select the 

Master Slide Layout you would like to define default attributes 

for 

4. In the Toolbar, click the element type (e.g., text box, shapes, 

table, charts) 

5. In the Formatting bar, format the element ensuring that it 

meets accessibility guidelines outlined in this document 

6. To make the element a default for your current master slide, 
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go to menu item: Format > Advanced > Define (element type) 
for Current Master Note: To make the element a default for all 

master slides, go to menu item: Format > Advanced > Define 
(element type) for All Masters 

Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 

objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. However, when you are working with “floating” 

objects, it is important to remember that the way objects are 

positioned in two dimensions on the screen may be completely 

different from how the objects will be read by a screen reader or 

navigated using a keyboard. The order that content is navigated 

sequentially is called the “Tab Order” because often the “Tab” key is 

used to navigate from one “floating” object to the next. 

Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 

when they are inserted, the default tab order is 

from the first object inserted to the last. However, 
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this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 

for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 

• For more complex layouts, it may be easier to 

simply to create the slide as usual and then set the 

tab order (see below). 

To set the tab order 

1. Select the object 

2. Go to menu item: Arrange > Bring Forward, Bring to Front, 

Send Backward or Send to Back 

Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 
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of your slides in text format. Slide notes can be created as you build 

your presentation. 

To add notes to your slides 

1. Go to menu item: View > Show Presenter Notes 
2. In the pane at the bottom of the window (below the slide), 

enter notes to accompany each slide 

Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

At this time, Keynote ’09 does not offer a mechanism which enables 

the user to add alternative text descriptions to images or objects. 

[Tested: September 28, 2010] 

Editor’s note: For later versions of Keynote, users can 

add alternative text descriptions for images and objects. 

1. Select the image and go to the Format side bar. 

Click on the image tab. 

2. Click the Description text box, then enter your 

text. 

For more details, see the section on how to add an image 

description on the Keynote User Guide for Mac. 

 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend to 
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convey by the image is also conveyed to people who cannot see the 

image. This can be accomplished by adding concise alternative text 

of each image. If an image is too complicated to concisely describe 

in the alternative text alone (artwork, flowcharts, etc.), provide a 

short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 
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Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

Technique 7. Use Built-In Structuring Features 

648  |  Keynote for Mac



7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 
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separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 

(see Technique 4). 

To set default table attributes 

1. Go to menu item: View > Show Master Slides 
2. Select a master slide from the Master Slides Navigator in 

the left pane 
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3. In the Toolbar, click Table 

4. Select the table 

5. Go to menu item: View > Show Inspector 
6. In the Inspector dialog, select Table inspector 
7. Click the Table tab 

8. In the Headers & Footers section, select Choose the 
number of header columns or Choose the number of 
header rows drop-down menus 

9. Select the number of headers 

Note: Limiting your table to one row or column of header 

will ensure your table remains clear and easy to interpret 

by assistive technologies. 
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10. Customize the other characteristics of your table through 

the other sections of the Table inspector dialog 

11. To make the table a default for your current master slide, 

go to menu item: Format > Advanced > Define Table for 
Current Master 
Note: To make the table a default for all master slides, go to 

menu item: Format > Advanced > Define Table for All 
Masters Note: Defining the table as a default for all 

masters means that when you insert a Table element into 

any slide, it will display your preformatted characteristics 

(including appropriate headers) 

7.2 Lists 

When you create lists, it is important to format them as “real lists”. 

Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Select the text box or highlight the text 
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2. Go to menu item: View > Show Inspector 
3. In the Inspector dialog, click Text inspector 
4. Click the Bullets tab 

5. In the Bullets & Numbering section, click the drop-down 

menu and choose a bullet or numbering option 

6. Customize the list style accordingly, ensuring your selections 

align with the guidelines in this document

7.3 Columns 

Use Columns feature for placing text in columns. Note: Because 

columns can be a challenge for users of some assistive technologies, 

consider whether a column layout is really necessary. 

7.4 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. In the Toolbar, select Inspector 
2. In the Inspector dialog, select the Document inspector button 
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3. Click the Spotlight tab 

4. In the Title box, type a descriptive name for the document 

Note: The Title defined in the properties is different than the 

file name. It is also unrelated to the template name, discussed 

above. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 

654  |  Keynote for Mac



To create a chart 

1. Go to menu item: Insert > Chart 
2. Select the type of chart you want to use 

3. Update the Chart Data Editor with the data you would like to 

display 

4. Close the Chart Data Editor 

To add titles and labels 

1. Select the chart 

2. Go to menu item: View > Show Inspector 
3. In the Chart Inspector, select Chart 
4. Ensure the Show Title and Show Legend check boxes are 

selected 

5. Select Axis 
6. Under Value Axis (Y) and Category Axis (X), select Show Title 

and Show Value Labels from their respective drop-down 

menus 

To change to a different predefined Chart Type 

1. Select the chart 

2. Go to menu item: View > Show Inspector 
3. Select a chart type from the Choose a chart type drop-down 

menu 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 
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different types of dotted lines to facilitate legibility for users 

who are color blind 

• When creating bar charts, it is helpful to apply texture instead 

of color to differentiate the bars 

• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2) 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

656  |  Keynote for Mac



printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. In order to determine whether the colors in your 

document have sufficient contrast, you can consult an online 

contrast checker, such as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 
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distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use PowerPoint 

2010’s “Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 
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you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 
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10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 

out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To edit hyperlink text 

1. Enter the hyperlink 

2. Go to menu item: View > Show Inspector 
3. In the Inspector dialog, click Hyperlink inspector 
4. In the Display box, enter the text you would like to display 
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10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 

presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 

Technique 11. Check Accessibility 

At this time, Keynote ’09 does not offer a mechanism to check for 

potential accessibility errors in your document prior to publishing. 

[Tested: September 30th, 2010] In order to get some indication of 

the accessibility of your document or template (see Technique 1), 

then you may consider saving the file into HTML or PDF in order to 

perform an accessibility check in one of those formats, as described 

below. 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 
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To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 
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To export to a different format 

1. Go to menu item: Share > Export 
2. Select the file format you would like to export 

3. Customize the settings relevant to the selected file format 

4. Click Next 
5. In the Save As box, enter a descriptive file name 

6. In the Where drop-down menu, specify the location you would 

like the exported file to be saved 

7. Click Export 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11 (above). 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11) Note: you may wish to 

use HTML editors or utilities to help with this process. 
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Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. The 

following accessibility related plug-ins and support are available for 

Keynote ‘09: 

• PowerTalk – an accessibility tool that provides a good 

approximation of how presentations will sound with a screen 

reader. [Editor’s note: Tool no longer available.] 

• Keynote Support 

Accessibility Help 

If you are interested in what features are provided to make using 

Keynote ‘09 more accessible to users, documentation is provided in 

the Help system: 

1. Go to menu item: Help 
2. Enter your search term in the Search box 

References and Resources 

1. Keynote User Guide for Mac 

2. Apple: Create accessible presentations with Keynote 

3. GAWDS Writing Better Alt Text 
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OpenOffice Impress 

Usage Notes 

At the time of testing (December 2019), OpenOffice Impress 

provides a set of accessibility features that is sufficient to enable 

the production of accessible digital office documents. However, 

OpenOffice Impress does not include an accessibility checking 

feature. 

What’s an “Office Document”? 

You should use these techniques when you are using Impress to 

create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 
• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

If you are creating forms, web pages, applications, or other 
dynamic and/or interactive content, these techniques will still 
be useful to you, but you should also consult the W3C-WAI Web 
Content Accessibility Guidelines (WCAG 2.0) because these are 
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specifically designed to provide guidance for highly dynamic and/
or interactive content. 

File Formats 

The default file format for Impress is ODF Presentation (ODP). 
In addition, Impress offers many other presentation processor 

and web format saving options. Most of these have not been 

checked for accessibility, but some information and/or instructions 

are available for the following formats in Technique 12: 

• MS PowerPoint (PPT and PPTX) 

• PDF 

• HTML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or Shift+F10. 
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Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 
documents, but it does not guarantee accessibility to any specific 
disability groups. In cases where more certainty is required, it is 

recommended that you test the office documents with end users 

with disabilities, including screen reader users. 

The application-specific steps and screenshots in this document 

were created using OpenOffice Impress (ver. 3.2.1, Windows XP, 

Aug. 2010 and Apache OpenOffice 4.1.7)) while creating an ODT 

document. Files can also be easily saved as other file formats (see 

Technique 12). 

Technique 1. Use Accessible Templates 

All office documents start with a template, which can be as simple 

as a blank standard-sized page or as complex as a nearly complete 

document with text, graphics and other content. For example, a 

“Meeting Minutes” template might include headings for information 

relevant to a business meeting, such as “Actions” above a table with 

rows to denote time and columns for actions of the meeting. 

Because templates provide the starting-point for so many 

documents, accessibility is critical. If you are unsure whether a 

template is accessible, you should check a sample document 

produced when the template is used (see Technique 11). 

OpenOffice Impress’s default template for new documents is a 

blank presentation. The basic installation also includes blank 

business card and blank label templates. These are all accessible by 

virtue of being blank. As well, you may create your own templates. 

668  |  OpenOffice Impress



To create an accessible template 

1. Create a new document 

2. Ensure that you follow the techniques in this document 

3. When you are finished you should also check the accessibility 

of the document (see Technique 11) 

4. Go to menu item: File > Properties 
5. Use the Title and/or Comments to indicate the accessibility 

status of the template. Using Title (e.g., “Accessible Memo 

Template”) will increase the prominence of the accessibility 

status because this is used in place of the template’s file name. 

Comments can be used to add more information if necessary 

(e.g., “This memo template has been checked for accessibility.”). 

6. Close the dialog with OK 

7. Go to menu item: File > Templates > Save (Shift+F11) 

8. In the New Template box, type a name for the template 

9. Select the category you would like to save it in, under 

Categories 
Note: the category is simply the folder into which you are 

saving the template 
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10. Close the dialog with OK 

To select an accessible template 

Note: Only use these steps if you have an accessible template 

available (e.g., that you previously saved). Otherwise, simply open a 

new (blank) document. 

1. Go to menu item: File > New > Templates and Documents 
2. Select the Templates icon 

3. Select a template document from the list 

Note: A properties pane appears on the right side of the 

window, where you can read the document properties (Title, 

By, Date, Modified by, Modified on, Description, and Size). If 

you placed information about the accessibility of the template 

in the Title and/or Comments when you created the template 

(see above), this will be displayed in the Title and/or 

Description, respectively. 

4. Select Open 

670  |  OpenOffice Impress



5. A new document based on the template will be displayed. If 

you have chosen an accessible template, the document will be 

accessible at this point. As you add your content (e.g., text, 

images, etc.), ensure that you consult the sections that follow 
to preserve accessibility. 

Technique 2. Set Document Language 

In order for assistive technologies (e.g., screen readers) to be able 

to present your document accurately, it is important to indicate the 

natural language of the document. If a different natural language is 

used for a paragraph or selected text, this also needs to be clearly 

indicated. 

To select a language for the whole document 

1. Go to menu item: Tools > Options 
2. Select Language Settings > Languages 
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3. Under Default languages for documents, select the 

document language for all newly created documents 

Note: If you mark For the current document only, your 

choice will only apply to the current document. 

4. Close the dialog with OK 

To apply a language directly to selected text 

1. Select the text to which you want to apply a language 

2. Go to menu item: Format > Character 
3. Select the Font tab 

4. Select the Language and click OK 
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Technique 3. Use Built-In Layout and Styling 
Features 

3.1 Use Built-In Slide Layouts 

Instead of creating each slide in your presentation by starting from 

a blank slide, check whether there is a suitable built-in layout. 

Note: The built-in layouts can be more accessible to users of 

assistive technologies because they technologies sometimes read 

the floating items on the slide in the order that they were placed on 

the slide. The built-in layouts have usually taken this into account 

(e.g., “Title” first followed by other items, left to right and from top 

to bottom). If you create slide layouts from scratch, it is sometimes 

difficult to keep track of the order elements were placed. 
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To apply “true layout” to a slide 

1. Select the slide in the Slides pane on the left 

2. Go to menu item: Format > Slide Layout… 
3. Go to Tasks pane on the right 

4. Select layout under the Layouts section 
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3.2 Use Quick Styles 

You should make use of the quick styles that are included with the 

office application (e.g., pre-defined heading fonts and characters) 

before creating your own styles or using the character formatting 

tools directly. Quick styles help your readers understand why 

something was formatted in a given way, which is especially helpful 

when there are multiple reasons for the same formatting (e.g., it is 

common to use italics for emphasis, Latin terms and species names). 

Note: While office application suites support headings in much 

the same way, the named styles often differ. 

Impress provides quick styles for theme fonts, but applying these 

directly to text does not define the text as a heading or body font. To 

define the font for headings and body text, you need to apply these 

characteristics to the presentation theme. 

Impress provides named styles for “Heading”, “Title”, etc., but not 

for strong and emphasis. 

To use default named styles 

1. Go to menu item: Format > Styles and Formatting (F11) 

2. Select the Graphic Styles icon 

3. Select the named style 

4. Click the Bucket icon in the element to which you would like 

to apply the named style 

5. Close the Styles and Formatting dialog 
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To change the text size for a default named style 

1. Go to menu item: Format > Styles and Formatting (F11) 

2. Select the style to modify from the list 

3. Right click and select: Modify… 
4. Select the Font tab 

5. Select a font size under Size 
6. Exit with OK 
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3.3 Customize Using Master Slides 

If a layout must be customized, it is recommended that Master 

Slides be used. 

Every slide layout in a presentation is defined by its master slide. 

A master slide determines the formatting style for various elements 

of the slide layout. This includes font styles, character formatting, 

and the positioning of elements. Essentially, each master slide acts 

as a design template for the slide layout. 

If you edit any aspect of the slide layout in the master slide, 

the change will affect all slides that were created based on it. For 

this reason, it is good practice to edit the master slide and use 

the slide layouts before building individual slides. It is essential 

that you create and use master slides that meet the accessibility 

requirements outlined in this document. 
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To modify a Master Slide 

1. Go to menu item: View > Master > Slide Master 
2. Edit the master slide, ensuring it aligns with the guidelines in 

this document 

Technique 4. Set a Logical Tab Order 

Many presentation applications create content composed almost 

exclusively of “floating” objects. This means that they avoid the 

transitions between in-line content and secondary “floating” 

objects (text boxes, images, etc.) that can cause accessibility issues 

in word processors. 

However, when you are working with “floating” objects, it is 

important to remember that the way objects are positioned in two 

dimensions on the screen may be completely different from how 

the objects will be read by a screen reader or navigated using a 

keyboard. The order that content is navigated sequentially is called 

the “Tab Order” because often the “Tab” key is used to navigate from 

one “floating” object to the next. 

Tips for setting a logical “tab order” for “floating” 
objects 

• The tab order of floating objects is usually from 

the “lowest” object on the slide to the “highest”. 

• Because objects automatically appear “on top” 
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when they are inserted, the default tab order is 

from the first object inserted to the last. However, 

this will change if you use features such as “bring 

to front” and “send to back”. 

• The slide’s main heading should be first in the 

tab order. 

• Headings should be placed in the tab order 

immediately before the items (text, diagrams, etc.) 

for which they are acting as a heading. 

• Labels should be in the reading order placed 

immediately before the objects that they label. 

• For simple slide layouts, it may be possible to 

simply insert objects in a logical tab order. 

• For more complex layouts, it may be easier to 

simply to create the slide as usual and then set the 

tab order (see below). 

To set the tab order 

1. Right-click* the object 

2. Select Arrange > Bring to Front, Bring Forward, Send 
Backward, or Send to Back 

Technique 5. Use Slide Notes 

A useful aspect of presentation applications is the facility to add 

notes to slides, which can then be read by assistive technologies. 

You can use these slide notes to explain and expand on the contents 
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of your slides in text format. Slide notes can be created as you build 

your presentation. 

To add notes to your slides 

1. Go to menu item: View > Notes Page 
2. In the text box positioned at the bottom of the page, select 

Click to add notes 
3. Enter notes to accompany the slide 

Technique 6. Provide Text Alternatives for 
Images and Graphical Objects 

When using images or other graphical objects, such as charts and 

graphs, it is important to ensure that the information you intend 

to convey by the image is also conveyed to people who cannot see 

the image. This can be accomplished by adding concise alternative 

text to of each image. If an image is too complicated to concisely 

describe in the alternative text alone (artwork, flowcharts, etc.), 

provide a short text alternative and a longer description as well. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 
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information, leave the alternative text blank 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 
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the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

Alternatively, you can include the same information 

conveyed by the image within the body of the 

document, providing the images as an alternate to the 

text. In that case, you do not have to provide alternate 

text within the image. 

To add alternative text to images 

1. Right-click on object 

2. Select Description… option 

3. Enter alternative text in the Title box 

To add long descriptions to images 

1. Right-click on object 
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2. Select Description… option 

3. Enter description in Description box 

Technique 7. Use Built-In Structuring Features 

7.1 Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within 

the table can be conveyed in a meaningful way. 
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Tips for tables 

• Only use tables for tabular information, not for 

formatting. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 

show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table cells should be marked as table headers 

when they serve as labels to help interpret the 

other cells in the table. 

• Table header cells labels should be concise and 

clear. 

• Ensure the table is not “floating” on the page 
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(see Technique 4). 

To add a table with headings 

1. Go to menu item: Insert > Table… 
2. Specify the number of columns and rows in the new table 

3. Double-click anywhere within the table to open the Table 
menu 

4. Select the Table Design icon to open the Table Design menu in 

the Tasks window pane on the right 

5. Select the Header row check box 

7.2 Lists 

When you create lists, it is important to format them as “real lists”. 
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Otherwise, assistive technologies will interpret your list as a series 

of short separate paragraphs instead of a coherent list of related 

items. 

To create an ordered or unordered list 

1. Go to menu item: Format > Bullets and Numbering 
2. For unordered lists, select an option from the Bullets tab 

3. For ordered lists, select an option from the Numbering Type 
tab 

To modify list styles 

1. Go to menu item: Format > Bullets and Numbering 
2. In the Bullets and Numbering dialog, select the Customize tab 

3. Modify the list style by making selections from the available 

formatting options 

4. Select OK 
Note: This only modifies that instance of the list style. 

7.3 Columns 

Use Columns feature for placing text in columns. 

Note: Because columns can be a challenge for users of some 

assistive technologies, consider whether a column layout is really 

necessary. 
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7.4 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File > Properties 
2. Select the Description tab 

3. Type the new title in the Title box and click OK 
Note: The Title defined in the properties is different than 

the file name. It is also unrelated to the template name, 

discussed above. 

Technique 8. Create Accessible Charts 

Charts can be used to make data more understandable for some 

audiences. However, it is important to ensure that your chart is as 

accessible as possible to all members of your audience. All basic 

accessibility considerations that are applied to the rest of your 

document must also be applied to your charts and the elements 

within your charts. For example, use shape and color, rather than 

color alone, to convey information. As well, some further steps 

should be taken to ensure that the contents are your chart are 

appropriate labeled to give users reference points that will help 

them to correctly interpret the information. 

To create a chart 

1. Select a slide layout with a placeholder for data charts (see 
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Technique 3.1) 

2. Double-click* the center of the placeholder to insert the data 

chart 

3. Right-click* the chart and select Chart Data Table… 
4. Update the data table with the data you would like to display 

5. Close the data table 

To add titles and labels 

1. Double-click* the chart to access the chart menus 

2. Go to menu item: Insert > Titles 
3. Update the relevant fields and select OK 
4. Go to menu item: Insert > Data Labels 
5. Configure your data label selections and select OK 

To change to a different predefined Chart Type 

1. Double-click* the chart to access the chart menus 

2. Go to menu item: Format > Chart Type 
3. In the Chart Type dialog, select a predefined chart type and 

style 

4. Select OK 

Other Chart Considerations 

• When creating line charts, use the formatting options to create 

different types of dotted lines to facilitate legibility for users 

who are color blind 

• When creating bar charts, it is helpful to apply textures instead 

of color to differentiate the bars 
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• Change the default colors to a color safe or gray-scale palette 

• Use the formatting options to change predefined colors, 

ensuring that they align with sufficient contrast requirements 

(see Technique 9.2) 

Technique 9. Make Content Easier to See 

9.1 Format of Text 

When formatting text, especially when the text is likely to be 

printed, try to: 

• Use font sizes between 12 and 18 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Office applications do typically 

include accessibility features such as the ability to magnify 

documents and support for high contrast modes. However, because 

printing is an important aspect of many workflows and changing 

font sizes directly will change documents details such the 

pagination, the layout of tables, etc., it is best practice to always 

format text for a reasonable degree of accessibility. 
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9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 

contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 
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• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 

Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use PowerPoint’s 

“Track Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g. “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted, above. 
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9.6 Avoid Transitions 

Transitions between slides and elements in each slide (e.g., bullets 

in a list flying onto the screen) can be distracting to users with 

disabilities. It can also cause assistive technologies to read the slide 

incorrectly. For these reasons, it is best to avoid transitions 

altogether. 

Technique 10. Make Content Easier to 
Understand 

10.1 Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

10.2 Provide Context for Hyperlinks 

Hyperlink text in your document should be meaningful when read 
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out of context. To be an effective navigation aid, the link text should 

describe the destination of the link. 

Consider the experience of screen reader users: Generally, screen 

readers generate a list of links, and screen reader users navigate this 

list alphabetically. Hyperlink text such as “click here” or “more” is 

meaningless in this context. 

In order to be useful to someone using a screen reader, ensure 

that hyperlink text is self-describing and meaningful on its own. To 

make the address of hyperlink clear when printing, you may wish to 

include the address in brackets following the descriptive text of the 

hyperlink. 

To change link text 

1. Type the link address and Enter 
2. Highlight the link 

3. Go to menu item: Edit > Hyperlink… 
4. In the Hyperlink dialog, type meaningful descriptive text of 

the hyperlink in the field labeled Text 
5. Select Apply 
6. Select Close 

10.3 Accessible Presentations 

It is important to consider accessibility before, during, and after 

presentations. Below is a helpful link with guidance on how to make 

presentations accessible to all: 

• “How to Make Presentations Accessible to All” (Source: W3C-

WAI Draft) 
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Technique 11. Check Accessibility 

At this time (December 2019), OpenOffice Impress does not offer 

a mechanism to identify potential accessibility errors in your 

document prior to publishing. 

In order to get some indication of the accessibility of your 

document or template (see Technique 1), then you may consider 

saving the file into HTML or PDF in order to perform an accessibility 

check in one of those formats, as described below. 

To evaluate HTML accessibility 

If you wish to check the accessibility of your document or template 

(see Technique 1), one option is to save it into HTML format and use 

one of the web accessibility checkers available online. Such as: 

• AChecker 

• WebAIM Wave Web Accessibility Evaluation Tool 

To evaluate PDF accessibility 

If you saved your document in tagged PDF format, you can use the 

following tools and steps to evaluate the accessibility of the PDF 

document: 

• Adobe Acrobat Professional 

• CommonLook PDF Evaluator 

• PDF Accessibility Checker (PAC) – a free alternative provided 

by “Access for all” 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 

Technique 12. Use Accessibility Features when 
Saving/Exporting to Other Formats 

In some cases, additional steps must be taken in order to ensure 

accessibility information is preserved when saving/exporting to 

formats other than the default. 

PDF 

PDF documents are not always accessible. Accessible PDF 

documents are often called “Tagged PDF” because they include 

“tags” that encode structural information required for accessibility. 

To evaluate the accessibility of your PDF document, see Technique 

11. 

1. Go to menu item: File > Export as PDF 
2. Check box labeled Tagged PDF 
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3. Click Export 
4. Enter name and save location 

5. Select Save 

Note: You must ensure this option is selected in the PDF Options 

window dialog box before using PDF icon on menu bar. 

HTML 

1. Open the presentation that you want to save in HTML format. 

2. Go to menu item: File > Export 
3. Set the File type to HTML Document (OpenOffice.org 

Impress) (.html;.htm). 
4. Enter a File name 
5. Click Export 
6. Follow the instructions in the HTML Export Wizard 

7. Check the HTML file for accessibility (see Technique 11 ) 

To clean up your HTML file 

• Remove unnecessary styles, line breaks, etc. 

• Remove unnecessary id, class, and attributes 

• Remove font tags 

• Remove styles in the <head> tag 

• Ensure the <th> tags have a scope attribute 

• Remove <p> tags nested inside <th> and <td> tags 

• Check for accessibility (see Technique 11 ) 

Note: you may wish to use HTML editors or utilities to help 

with this process. 
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Technique 13. Consider Using Accessibility 
Support Applications/Plugins 

Disclaimer: This list is provided for information purposes only. It is 

not exhaustive and inclusion of an application or plug-in on the list 

does not constitute a recommendation or guarantee of results. 

The following accessibility related plug-ins and support are 

available for OpenOffice Impress: 

• PowerTalk – an accessibility tool that provides a good 

approximation of how presentations will sound with a screen 

reader. 

• OOo2GD – an extension that allows you to export, update and 

import documents, spreadsheets and presentations between 

OpenOffice.org applications and Google docs. 

Accessibility Help 

If you are interested in what features are provided to make using 

OpenOffice Impress more accessible to users, documentation is 

provided in the Help system: 

1. Go to menu item: Help > OpenOffice.org Help (F1) 

2. Enter “accessibility” as the Search Term 

References and Resources 
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Adobe InDesign CS6 and CC 

Usage Notes 

At the time of testing, Adobe InDesign CS6 (April 2013) and Adobe 

InDesign Creative Cloud  2019 (December 2019) provide a set of 

accessibility features that are sufficient to enable the production of 

accessible digital documents. 

What is “InDesign”? 

You should use the technique below when you are using InDesign to 

create documents that are: 

• Intended to be used by people (i.e., not computer code), 

• Text and Image based (intended for design) 

• Fully printable and can be digitized 

• Creative design (layout, e.g., books, packages, poster, interactive 

web) 

Note: InDesign is best for print design, but there are also options 

of doing web and digital publishing. If you are creating forms, web 

pages, applications, or other dynamic and/or interactive content, 

the techniques below will be useful, but consult the W3C-WAI Web 

Content Accessibility Guidelines (WCAG 2.0) because these are 

specifically designed to provide guidance for highly dynamic and/

or interactive content. 
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File Formats 

The default file format for InDesign is (.indd). 
In addition, InDesign offers many other web format saving 

options. Most of these have not been checked for accessibility. 

• ePub 

• PDF (print and interactive) 

• Flash Player SWF (for interactive) 

• HTML, XHTML 

• XML 

Document Conventions 

We have tried to formulate these techniques so that they are useful 

to all authors, regardless if they use a mouse. However, there are 

several instances where mouse-only language is used for clarity 

purposes . Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the object 

using the Shift+Arrow keys and then press either (1) the “Right-

Click” key (some keyboard have this to the right of the spacebar) 

or Shift+F10. 

Disclaimer and Testing Details: 

Following these techniques will increase the accessibility of your 

documents, but it does not guarantee accessibility to any specific 

disability groups. In cases where more certainty is required, it is 
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recommended that you test the documents with end users with 

disabilities, including screen reader users. 

Technique 1. Use Accessible Templates 

InDesign starts with a simple blank page that can be adjusted to any 

size. There are no build-in templates for InDesign. However, you can 

create your own templates from scratch or download already made 

templates from Adobe. 

Templates provide the starting point for documents, so 

accessibility is critical. If you are unsure whether a template is 

accessible, check the document using Acrobat Pro. Export the file 

and use the Accessibility Checker in Acrobat Pro. 

To create an accessible template 

• Select File > New > New Document 

Keyboard shortcut: Ctrl + N (on Windows) and Cmd + 

N (on Mac) 

1. Select print, web, or mobile and Page Size 
2. Uncheck the Facing Pages box if your document is NOT 

intended to be in book format 
3. Select OK 
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Editor’s note: Adobe InDesign CC users will see a 

different version of the dialog box with the same menu 

items. 
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To Saving File as a Template 

• Select file > Save 

Keyboard shortcut: Ctrl + S (on Windows) and Cmd + S 

(on Mac) 

1. Insert file name and under Save as type select CS6 InDesign 
template 

2. Select Save 

Editor’s note: InDesign CC, users will see the following 

dialog box. 
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Technique 2. Specify Document Language 

The language setting in InDesign will set language within the 

program only. This language setting in InDesign will not carry over 

to the exported PDF. Be sure to set the document language in Adobe 

Acrobat after exporting to PDF. 

To specify the document language for an exported PDF 

1. Choose File > Export. 

2. Specify a name and location for the file. For Compatibility, 

choose the lowest PDF version necessary to open the files you 

create. 

3. For Save As Type (Windows) or Format (Mac OS), choose Adobe 
PDF (Print), and then click Save. 

4. Find the Advanced tab, and go to Accessibility Options. 
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5. Under Language, choose the document language for the PDF. 

This determines the default language for the exported PDF. 

Technique 3. Creating Artifacts for Objects 

The artifact tag allows users to hide items on the page, such as page 

numbers or unimportant objects, when viewing the exported PDF 

file in Reflow view, which displays only tagged items. This is also 

useful when viewing PDF files on a mobile device or in other PDF 

readers. 

There are two options to creating artifacts: 

• Option 1 uses Object Export Options Dialog box where the user 

select the images in the document individually and add 
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artifact. 

• Option 2 uses Tag pane where the users individually select the 

object and add the required tagging. 

Artifact Option 1 

1. Select the image or object 

2. Select Object > Object Export Options

3. Select Tagged PDF > Apply Tag 
4. Choose either Artifact or Based on Object 
5. Select Done 
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Artifact Option 2 

1. Select the object or artifact 

2. In Tag pane select Artifact 
Note: to view Tags Panel: (Window > Utilities > Tags) 
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Note: for more detail information on tagging and structure 

pane see Technique 7. 

Technique 4. Alternative Text for Images and 
Graphical Objects 

When using images or other graphical objects, such as graphs, 

shapes, and background, it is important to ensure that the 

information you intend to convey using the image is also conveyed 

to people who cannot see the image. This can be accomplished by 

adding concise alternative text to each image. 
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Tips for Writing Alternative Text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank and 

create an artifact (e.g., background images should 

generally have no alt text, other decorative images 

should only have alt text if they form a crucial part 

of the content, message, and purpose of the 

document). 

• If the image contains meaningful text, ensure all 

of the text is replicated. 

• For logos, the alternative text should be the 

organization’s name. 

• For groups of logos, one logo can be chosen to 

represent the group. 

• Sometimes text is included as part of a logo or 

footer image (e.g. the image might contain a 

phone number), this text should be set as the 

alternative text of the image. 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences. 

• Test by having others review the document with 

the images replaced by the alternative text. 
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Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

There are two options to add Alternative Text to images Option one 

uses the Object Export Options dialog box where the user select the 

images in the document individually and add the alternative text. 

Option two uses Structure panel that create attribute to individual 

images. 

When you export the document, the alt text you’ve assigned will 

travel with the image. 

1. Select the image or object 

2. Select Object > Object Export Options 
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To add alternative text to images (Option 1) 

1. Select Alt Text > Alt Text Source drop down menu 

2. Choose Custom 

3. Type the description in the box below 

4. Select Done 

To add alternative text to images (Option 2 – Using Structure 
Panel) 

1. Structure Panel (View > Structure > Show Structure) 

2. Select the Figure in the panel. 

3. Select   or 

4. Select New Attribute 
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5. Insert Alt (case sensitive) under Name (Note: You must use 

a capital “A” and lowercase “lt” to be valid) 

6. Place the descriptions under Value 

 

Technique 5. Creating Paragraph Styles 

Any document that is longer than a few paragraphs require 

structure to make them more straightforward for readers to 

understand. Creating Paragraph styles will set the headings and 

style for the document. It will also help in creating a Table of 

Contents. The structural elements that indicate order and level 

provide a meaningful sequence to users of assistive technologies. 

• Select Paragraph Styles (in typography workspace) 

Keyboard shortcut: F11 (on Windows) Cmd + F11 (on 

Mac) 

1. Select  or  in the top right corner for more 

options. 
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2. Select New Paragraph Style…

3. Select General > Style Name and insert a title for the style 

(e.g., header, body text, caption .etc)

4. Select Basic Character Formats located in the left side 

pane 

5. Choose the font, font style and the size 
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Technique 6. Creating Accessible Tables 

When using tables, it is important to ensure that they are clear and 

appropriately structured. This helps all users to better understand 

the information in the table and allows assistive technologies (e.g., 

screen readers) to provide context so that the information within the 

table can be conveyed in a meaningful way. 

When creating accessible tables in InDesign, there are some 

things to keep in mind: 

• Be sure to add alternative text to facilitate understanding of 

the table (see Technique 3). 

• After converting your InDesign document to PDF, be sure to 

review the document in Adobe Acrobat and ensure that the 

table is properly tagged. 

Tips for tables 

• Only use tables for tabular information, not for 

formatting, such as to position columns. 

• Use “real tables” rather than text formatted to 

look like tables using the TAB key or space bar. 

These will not be recognized by assistive 

technology. 

• Keep tables simple by avoiding merged cells and 

dividing complex data sets into separate smaller 

tables, where possible. 

• If tables split across pages, set the header to 
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show at the top of each page. Also set the table to 

break between rows instead of in the middle of 

rows. 

• Create a text summary of the essential table 

contents. Any abbreviations used should be 

explained in the summary. 

• Table captions or descriptions should answer 

the question “what is the table’s purpose and how 

is it organized?” (e.g., “A sample order form with 

separate columns for the item name, price and 

quantity”). 

• Table header cell labels should be concise and 

clear. 

To create tables 

Keyboard short cut: Ctrl + Alt + Shift + T (on Windows), 

Cmd + Shift + Option + T (on Mac) 

1. Create a table, go to Table > Create Table 
2. Insert Body Rows and Columns 
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3. Select OK 

To convert Text (with tabs) to a Table 

If you have created text with tabs. To convert the text to a table: 

1. Select all the text 

2. Table > Convert To Table 
3. Column Separator > Tab 
4. Select OK 
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Removing Table Lines 

1. Place the Type cursor on top of the table until the cursor 

changes to an upside down black arrow. 

2. Click and drag the cursor to select all of the chart (or part of 

the chart) 

3. In the top navigation. It’ll show a line box where you can 

choose which side you would like to remove the line from. 

4. Once selected. Click on the “None” outline button 

Repeat table header 

If you have a table that spans more than one page or spread, it’s 

important to ensure that table headers are repeated to facilitate 

understanding of the content. 

1. Go to Table > Table Options > Table Setup… 
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2. The Table Options dialog box appears. 

3. Under the Table Setup tab, indicate the number of Header 
Rows, under Table Dimensions. 

4.  Next, go to the Headers and Footers tab.  Here you can 

indicate if you would like your table header repeated on every 

page, column, or frame. 

Technique 7. Tagging Items 

Tagging items will help assistive technologies (e.g., screen readers) 

to locate the logical order of the assigned headings. Also, when 

exporting the document to a PDF, the tagging will automatically be 

embedded, therefore, the user does not need to apply tagging in 

Acrobat. 

722  |  Adobe InDesign CS6 and CC



To quickly tag the items in the file 

Note: This does not tag all content correctly. To correctly tag all 

content, you would have to assign the tags manually (see To Assign 

Tags Manually). 

1. Structure Panel (View > Structure > Show Structure) 

keyboard shortcut Alt + Ctrl + 1 (on Window), Cmd + Option + 1 

(on Mac) 

2. In the structure pane click the three line button and choose 

Add Untagged Items
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To view which items have been tagged 

1. View > Structure > Show Tagged Frames 
2. The boxes will be coloured according to the tagging in the 

Tags Panel. (Window > Utilities > Tags)
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Note: You must be in preview mode (keyboard shortcut W) to 

view the tagged items. 

To Assign Tags Manually (and correctly) 

1. Tag pane (Window > Utilities > Tags) 

2. Click  > Map Style to Tags… 
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3. Select the style and change [Not Mapped] to a heading 
title (e.g. H, H1, H2 etc.).
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Option 2: Export Tagging (manually assign tagging) 

1. Double click on the paragraph style (e.g., “heading”). 

2. In the dialog box Paragraph Style Options choose Export 
tagging. 

3. Under PDF > Tag: select the appropriate heading title (e.g. style 

name: heading & Tag: H).

Note: To make the reading order and tags easier to manage 

make thread text boxes. If possible make one text box per 

page. 

Technique 8. Creating Table of Contents 

1. Create a paragraph style (see Technique 5) 

2. For all the contents in the table of contents assign the title to 

the style “TOC”
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Optional: creating another style for the body of the table of 

content once all the contents are in the style of “TOC” 

1. Select Layout > Table of Contents… 
2. Under Other Styles select the style 

3. Select the << Add button to transfer the style to Include 

Paragraph Styles:

Optional: to change the body of the table of contents to a different 

style than the header of the table of contents. Select entry style 
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and change same style to another style.

• Drag the cursor to create a large box for the table of content. 

Note: The table of contents will automatically create the title, 

contents and page numbers. 

8.1 Columns 

Use Columns feature for placing text in columns instead of creating 

multiple text boxes. 

8.2 Use Page Numbering 

Numbering the pages of your document helps those reading and 
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editing your document effectively navigate and reference its 

content. For users of assistive technologies, it provides a valuable 

point of reference within the document. 

8.3 Naming PDF before exporting 

1. File > File Info 
keyboard shortcut: Ctrl + Alt + Shift + I (on Window), Cmd + 

Shift + Option + I (on Mac) 

2. Descriptions > Document title: Insert the file title 

Note: You can also fill in the author’s name and description. 
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Technique 9. Make Content Easier to See 

Here are some other things to keep in mind: 

9.1 Format of Text 

When formatting text, especially when the text is likely to printed, 

try to: 

• Use font sizes between 12 and 15 points for body text. 

• Use fonts of normal weight, rather than bold or light weight 

fonts. If you do choose to use bold fonts for emphasis, use 

them sparingly. 

• Use standard fonts with clear spacing and easily recognized 

upper and lower case characters. Sans serif fonts (e.g., Arial, 

Verdana) may sometimes be easier to read than serif fonts (e.g., 

Times New Roman, Garamond). 

• Avoid large amounts of text set all in caps, italic or underlined. 

• Use normal or expanded character spacing, rather than 

condensed spacing. 

• Avoid animated or scrolling text. 

But can’t users just zoom in? Because printing is an important 

aspect of many workflows and changing font sizes directly will 

change documents details such the pagination, the layout of tables, 

etc., it is best practice to always format text for a reasonable degree 

of accessibility. 

9.2 Use Sufficient Contrast 

The visual presentation of text and images of text should have a 
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contrast ration of at least 4.5:1. To help you determine the contrast, 

here are some examples on a white background: 

• Very good contrast (Foreground=black, Background=white, 

Ratio=21:1) 

• Acceptable contrast (Foreground=#767676, Background=white, 

Ratio=4.54:1) 

• Unacceptable contrast (Foreground=#AAAAAA, 

Background=white, Ratio=2.32:1) 

Also, always use a single solid color for a text background rather 

than a pattern. 

In order to determine whether the colors in your document have 

sufficient contrast, you can consult an online contrast checker, such 

as: 

• WebAIM: Contrast Checker 

• Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

• Joe Dolson Color Contrast Spectrum Tester 

• Joe Dolson Color Contrast Comparison 

9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying 

information, indicating an action, prompting a response, or 

distinguishing a visual element. In order to spot where color might 

be the only visual means of conveying information, you can create a 

screenshot of the document and then view it with online gray-scale 

converting tools, such as: 

• GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool 
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Editor’s note: GrayBit v2.0 is no longer available. 

However, multiple tools can be found online: Google 

Search: gray-scale conversion tool. 

9.4 Avoid Relying on Sensory Characteristics 

The instructions provided for understanding and operating content 

should not rely solely on sensory characteristics such as the color 

or shape of content elements. Here are two examples: 

• Do not track changes by simply changing the color of text you 

have edited and noting the color. Instead use InDesign’s “Track 

Changes” feature to track changes. 

• Do not distinguish between images by referring to their 

appearance (e.g., “the bigger one”). Instead, label each image 

with a figure number and use that for references. 

9.5 Avoid Using Images of Text 

Before you use an image to control the presentation of text (e.g., 

to ensure a certain font or color combination), consider whether 

you can achieve the same result by styling “real text”. If this is not 

possible, as with logos containing stylized text, make sure to provide 

alternative text for the image following the techniques noted above. 

Technique 10. Make Content Easier to 
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Understand 

Write Clearly 

By taking the time to design your content in a consistent way, it will 

be easier to access, navigate and interpret for all users: 

• Whenever possible, write clearly with short sentences. 

• Introduce acronyms and spell out abbreviations. 

• Avoid making the document too “busy” by using lots of 

whitespace and by avoiding too many different colors, fonts 

and images. 

• If content is repeated on multiple pages within a document or 

within a set of documents (e.g., headings, footings, etc.), it 

should occur consistently each time it is repeated. 

Accessibility Checker 

To check for accessibility, first, the InDesign file must be exported 

to a PDF and viewed in Acrobat Pro. 

1. File > Export (keyboard shortcut: Windows: Ctrl + E; Mac: Cmd 

+ E) 

2. Save as: PDF (Interactive or Print) 

3. Select Save 
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To evaluate PDF accessibility in Adobe Acrobat Professional 

1. Go to menu item: Advanced > Accessibility > Full Check… 
2. In the Full Check dialog, select all the checking option 

3. Select the Start Checking button 

Editor’s note: For detailed instructions, see our section 

on how to check accessibility using Adobe Acrobat 

Professional. 
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Using the Acrobat 10 Action Wizard 

In Acrobat 10 Pro, there is a special accessibility Action Wizard for 

InDesign CS6 where the user can follow to make the file accessible. 

• To Follow the Action Wizard in Acrobat 10: select Tools > 

Action Wizard> InDesign (CS6) Accessibility Touch up. 

Editor’s note: At the time of testing (December 2019), we 

were not able to download and use the Acrobat 10 Action 

Wizard. If you do already have the required application, see 

how to use the Action Wizard for InDesign for more details. 

Accessibility Help 

If you are interested in what features are provided to make using 

InDesign more accessible to users, documentation is provided in the 

Help button or the search bar. 

• Adobe InDesign Accessibility 

• Creating accessible PDF documents with Adobe InDesign CS6 

(PDF) 

References and Resources 

• Adobe InDesign Tutorials 

• Adobe InDesign Accessibility 

• Adobe InDesign CS6 tutorials 
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• Adobe InDesign: Export to PDF 

• Creating Accessible PDFs from Adobe InDesign (University of 

Washington) 
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Adobe Acrobat 11 Pro and 
DC 

Usage Notes 

At the time of testing (December 2019), Acrobat 11 Pro and Acrobat 

Pro DC enables the production of accessible digital documents. 

Both Acrobat 11 Pro and DC include an accessibility checking 

feature. 

Note: While PDF accessibility has improved over the years, 

accessibility support for PDF by authoring tools, viewers, and 

assistive technologies (e.g., screen readers) is not as widespread as 

for HTML documents. 

We recommend considering HTML instead of or in addition to 
PDF where appropriate. 

Should I use ADOD or WCAG 2.0? 

These techniques can help you to use Acrobat 11 Pro to create 

documents that are: 

• Intended to be used by people (i.e. not computer code), 

• Text-based (i.e. not simply images, although they may contain 

images), 

• Fully printable (i.e. where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e. without hyperlinks to other documents, 

unlike web content), and 

738  |  Adobe Acrobat 11 Pro and DC



• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.) 

Note: If you are creating forms, web pages, applications, or other 

dynamic and/or interactive content, these you should also consult 

the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0). 

The WCAG working group has provided PDF Techniques for WCAG 

2.0. 

File Formats 

The default file format for Acrobat 11 Pro and DC is Adobe Portable 
Document Format (PDF). In addition, Acrobat 11 Pro offers several 

other word processor and web format saving options. These have 

not been checked for accessibility. 

Document Conventions 

We have tried to write these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or (2) Shift+F10. 

• *Drag: Unfortunately, there is no keyboard alternative for 

several operations in Acrobat 11 Pro that require dragging. 
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Disclaimer and Testing Details: 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Adobe Acrobat 11 Pro (ver.11.0, 

Windows 7, April. 2013) and Adobe Acrobat Pro DC (version 

2019.021.20056, macOS Mojave version 10.14.6, December 

2019). 

• Unfortunately, tasks completed in Technique 3, Technique 4, 

and Technique 5 cannot be undone. It is recommended that 

you save your PDF document often under different names, 

especially before you make significant changes. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results 

Technique 1. Use Accessible Source Documents 

In the Adobe Acrobat 11 Pro workflow, all PDF documents start 

with a source document created in an office document authoring 

application, such as Microsoft Word or OpenOffice.org Writer. 

Because source documents provide the starting-point for the PDF 

documents, accessibility is very important. 

To create an accessible source document 

1. Create a new document in the authoring application (from the 

740  |  Adobe Acrobat 11 Pro and DC



default blank template or from one of the pre-packaged 

templates). 

2. Ensure that you follow the ADOD Authoring Techniques 
provided for the authoring application (an updated version 

available at Understanding Document Accessibility). 

3. When you are finished, you should also check the accessibility 

of the document (see “Accessibility Checking” in the Authoring 

Techniques for the authoring application). 

Once you have completed the above steps, you are ready to convert 

your document to PDF using Adobe Acrobat 11 or Acrobat DC. 

To convert single source documents to PDF 

1. Go to the menu item: File > Create > PDF From file… 
2. Locate and select your source document and select the Open 

button, Acrobat will then proceed to convert the file. 

A batch conversion process is also available from the menu item: 

File > Create PDF > Batch Create Multiple Files. 

Scanned Content 

If you created a PDF from a scanned document, then it will be 

inherently inaccessible to screen readers and other assistive 

technologies. The document will be less useful because graphic 

representations of text cannot be selected, edited or searched. 

In this case, it is necessary that you convert the scanned images 

of text to searchable content using Acrobat’s optical character 
recognition (OCR) feature before addressing the accessibility 

features of the document. 
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Technique 2. Check Accessibility 

“Make Accessible Action Wizard 

The “Make Accessible” Action Wizard can help you 

create accessible PDFs by leading you through the 

techniques in this guide (e.g., setting alternative text, 

setting document properties, etc.). 
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You can complete the wizard in its entirety by 

pressing Start or you can follow the the instructions 

below: 

1. Select Add Document Description 
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2. Fill in the Title (author, subject and keywords 

can also be filled in). See also Technique 6. 

3. Select Set Open Options 
4. Select Set Tabs Order Property 
5. Select Set Reading Language 
6. In the drop down menu, select the language for 

the file). See also Technique 6.

7. Select Add Tags to Document 
Note: This will automatically add tags to the file. 

Unfortunately, this process sometimes 

misinterprets the structure and reading order of 

complex page elements. Therefore, you should 
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still manually check the tags (see Technique 3). 

8. Select Set Alternative Text. See also Technique 

4. 

The wizard automatically searches for” figures” in 

the file. You must then fill in the alternate text in 

the pop up box. 

Note: The wizard might not tag all the images as 

figures, so check if tags are correct.

9. Select Run Accessibility Full Check. See also 

Technique 2. 

10. Recognize Text using OCR. 

11. Detect Form Fields. This is only required if the 

file is intended to be a fillable form. 

See also Creating Accessible PDF Documents in Adobe 

Acrobat by the National Center on Disability and Access 

to Education for a video walkthrough and handout on 

the “Make Accessible” Wizard. 

The most basic requirement for a PDF document to be accessible 

is for it to be “tagged” with hidden labels (“tags”) that describe the 
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structure of the document (e.g. that text should be interpreted as 

a header, paragraph, table cell, etc.). Screen readers can use these 

tags to convey the document’s information effectively to people 

with visual disabilities. 

The other requirements for a PDF document to be accessible (e.g. 

alternate text, logical reading order, etc.) can only all apply once the 

document is tagged. 

Caution!: The “Quick Check” feature is not 
recommended because it misses some important 

accessibility issues. Always perform a “Full Check” 

instead. 

To perform a “Full Check” 

Note: If “Accessibility” is not visible under tools, go to menu item: 

View > Tools > Accessibility 

1. Select Tools > Accessibility > Full Check Up 
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2. Once the file is fully run through the checker, a panel will show 

which parts of the files are correct and which parts need to be 

fixed. 
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If you have a large document, it may be more efficient to run a full 

check one page or a page range at a time. 

Technique 3. Add and Edit Tags 

Caution!: Actions taken using the TouchUp Reading 

Order tool and Order Panel cannot be undone and in 

some cases Acrobat may misinterpret your intentions. 

Remember to save your work frequently! If you 

frequently create PDF files you might consider using 

one of these accessible PDF support tools. 

If tags are missing, then they must be added. When 

tags are present, they should still be checked for 

correctness and edited as needed. 

Touch Up Reading Order Tags 

The TouchUp Reading Order dialog box offers some basic 

document tag options. Acrobat’s Help text describes the tags as 

follows: 

Text 
Tags the selection as text. 

Figure 
Tags the selection as a figure. Text contained within a figure tag 

is defined as part of the image and is not read by screen readers, 

though alternate text defined for the figure is read out.Note: An 
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effective way of handling very complex text constructs (e.g. 

flow charts) is to group it all as a figure and then provide a 

unified alt text description for the entire group. 

Form Field 
Tags the selection as a form field. 

Figure/Caption 
Tags a selected figure and caption as a single tag. Any text 

contained in the tag is defined as a caption. Useful for tagging 

photos and captions and preventing caption text from being 

incorrectly added to adjacent text blocks. Note: Unless the 

caption actually describes the image, the figures will still 

require alternate text. 

Heading 1, Heading 2, Heading 3 
Tags the selection as a first, second, third, fourth, fifth, or sixth 

level heading tag. You can convert heading tags to bookmarks 

to help users navigate the document. 

Table 
Tags the selection as a table. When this selection is made, 

Acrobat analyzes the selection to determine the location of 

headings, columns, and rows. 

Note: Table editing can be especially challenging. Try to keep 

them as simple as possible in the source document. 

Cell 
Tags the selection as a table or header cell. Use this option to 

merge cells that are incorrectly split. 

Note: Table editing can be especially challenging. Try to keep 

them as simple as possible in the source document. 

Formula 
Tags the selection as a formula. Note: Because speech software 

may handle formula tags differently from normal text, you 

should still add alternate text. 
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Background 
Tags the selection as a background element, or artifact, 

removing the item from the tag tree so that it does not appear 

in the reflowed document and is not read by screen readers. 

Additional Tags 

Not all tags are available using the TouchUp Reading order dialog 

window. Additional tags can be accessed from the Tags pane. See 

the Editing tags using the Tags pane section for more information. 

Document Section Tags 

There are additional tags that help define semantic and structural 

file elements in more detail. The Adobe Acrobat website categorizes 

and defines all standard tags as follows (some appear in the section 

above): 

Container elements 
Container elements are the highest level of element and 

provide hierarchical grouping for other block-level elements. 

Document 
Document element. The root element of a document’s tag tree. 

Part 
Part element. A large division of a document; may group 

smaller units of content together, such as division elements, 

article elements, or section elements. 

Div 
Division element. A generic block-level element or group of 

block-level elements. 
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Art 
Article element. A self-contained body of text considered to be 

a single narrative. 

Sect 
Section element. A general container element type, 

comparable to Division (DIV Class=”Sect”) in HTML, which is 

usually a component of a part element or an article element. 

Heading and Paragraph Elements 

Heading and paragraph elements are paragraph-like, block-level 

elements that include specific level heading and generic paragraph 

(P) tags. A heading (H) element should appear as the first child of any 

higher-level division. Six levels of headings (H1 to H6) are available 

for applications that don’t hierarchically nest sections (See TouchUp 

Reading Order Tags section above for more). 

Label and List Elements 

Label and list elements are block-level elements used for 

structuring lists. 

L 
List element. Any sequence of items of similar meaning or 

other relevance; immediate child elements should be list item 

elements. 

LI 
List item element. Any one member of a list; may have a label 

element (optional) and a list body element (required) as a child. 

LBL 
Label element. A bullet, name, or number that identifies and 
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distinguishes an element from others in the same list. 

LBody 
List item body element. The descriptive content of a list item. 

Special Text Elements 

Special text elements identify text that isn’t used as a generic 

paragraph (P). 

BlockQuote 
Block quote element. One or more paragraphs of text 

attributed to someone other than the author of the immediate 

surrounding text. 

Caption 
Caption element. A brief portion of text that describes a table 

or a figure. 

Index 
Index element. A sequence of entries that contain identifying 

text and reference elements that point out the occurrence of 

the text in the main body of the document. 

TOC 
Table of contents element. An element that contains a 

structured list of items and labels identifying those items; has 

its own discrete hierarchy. 

TOCI 
Table of contents item element. An item contained in a list 

associated with a table of contents element. 
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Table Elements 

Table elements are special elements for structuring tables. 

Table 
Table element. A two-dimensional arrangement of data or text 

cells that contains table row elements as child elements and 

may have a caption element as its first or last child element. 

TR 
Table row element. One row of headings or data in a table; may 

contain table header cell elements and table data cell elements. 

TD 
Table data cell element. A table cell that contains non-header 

data. 

TH 
Table header cell element. A table cell that contains header 

text or data describing one or more rows or columns of a table. 

Inline-Level Elements 

Inline-level elements identify a span of text that has specific 

formatting or behavior. They are differentiated from block-level 

elements. Inline-level elements may be contained in or contain 

block-level elements. 

BibEntry 
Bibliography entry element. A description of where some cited 

information may be found. 

Quote 
Quote entry element. An inline portion of text that is 

attributed to someone other than the author of the text 

surrounding it; different from a block quote, which is a whole 

paragraph or multiple paragraphs, as opposed to inline text. 
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Span 
Span entry element. Any inline segment of text; commonly 

used to delimit text that is associated with a set of styling 

properties. 

Special Inline-Level Elements 

Similar to inline-level elements, special inline-level elements 

describe an inline portion of text that has special formatting or 

behavior. 

Code 
Code entry element. Computer program text embedded within 

a document. 

Figure 
Figure entry element. A graphic or graphic representation 

associated with text. 

Form 
Form entry element. A PDF form annotation that can be or has 

been filled out. 

Formula 
Formula entry element. A mathematical formula. 

Link 
Link entry element. A hyperlink that is embedded within a 

document. The target can be in the same document, in another 

PDF document, or on a website. 

Note 
Note entry element. Explanatory text or documentation, such 

as a footnote or endnote, that is referred to in the main body 

of text. 
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References 
Reference entry element. A citation to text or data that is 

found elsewhere in the document. 

To add tags automatically 

Note: The automatic tagging feature may be sufficient on simple 

layouts, but it sometimes misinterprets the structure and reading 

order of complex page elements (e.g. closely spaced columns, 

irregular text alignment, and tables without borders.). Therefore, 

use the automatic tagging feature as a starting point, and always 

manually check and edit the tags as explained below. 

1. Go to menu item: Tools > Accessibility > Add Tags To 
Document 
*To Show the hidden “Accessibility” drop down menu Go to 

menu item: View > Tools > Accessibility 
Note: This command removes any tags that were in the 

document before the command was run. If any potential 

problems were encountered, an Add Tags Report appears in 

the navigation pane. 

To add/edit tags manually 

There are two ways of adding and editing tags in Adobe Acrobat. You 

can either do it through the TouchUp Reading Order dialog box, or 

using the Tags navigation pane. 

Note: Some tag types are not available through the TouchUp 

Reading Order dialog box. For documents with complex layouts and 

elements, use it together with the Tags pane method described 

below. 
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Adding/Editing tags using TouchUp Reading Order 

1. Go to menu item: Tools > Accessibility > TouchUp Reading 
Order… 
In most cases, it will help to have the four checkboxes checked 

(Show page content groups, Show table cells, Display like 
elements in a single block, Show tables and figures) 

2. Using the TouchUp Reading Order tool, drag* within the 

document pane to select a region of the page that contains one 

type of content (e.g. a text block) 

Note: If you drag* over part of an already tagged element, the 

element is sometimes split up. This is helpful when splitting 

larger elements to ensure correct reading over of sub-

elements. 

3. To add more page content to the current selection, Shift + 
drag* 

4. To remove page content from the current selection, Ctrl + 
drag* 

5. Select the appropriate button in the TouchUp Reading Order 
dialog to specify the tag type, a box should now encapsulate 

the element (the tags are explained here). 
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Tips for Tagging 

• On the “Touch Up Reading Order” dialog, make 

sure to select the Show page content groups 
checkbox and the Structure types radio button. 

This will display the type of structure for each tag, 

which will help you to spot mis-tagged content. 

• A good place to start is tagging “Background” 

content, since this will reduce the number of tags 

to deal with. Background content should include: 

◦ empty boxes, 

◦ visible or invisible text box borders 

(especially in busy areas where they overlap 

with text), 

◦ visuals that are decorative or redundant 

(e.g., backgrounds, illustrations), whose 

content is described adequately in the text . 

• If you are having difficulty tagging complex 

content (e.g., a complex table), consider either: 

◦ Editing the source document to simplify 

it, or 

◦ Selecting the complex content and 

tagging it as a figure for which you must 

then add alternative text that properly 

conveys all of the information in the new 

figure 
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Editing tags using the Tags pane 

1. Go to menu item: View > Show/Hide > Navigation Panes > 
Tags… 
Note: For best results, use ‘Add Tags to Document’ first. You 

can also create a new tag using the TouchUp Reading Order 

dialog box and then edit it in the Tags Pane. 

2. To change a tag, locate it in the structure tree. 

3. Right-click* on the tag, and select Properties. From the drop-

down menu next to tag type, select the tag you would like to 

use. 

4. Alternatively, you can edit tags by clicking on the tag name 

drop-down menu, and then typing the appropriate tag name 

(see list of tags above). 
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Technique 4. Provide Alternative Text 

When using images, it is important to ensure that the information 

you intend to convey by the image is also conveyed to people who 

cannot see the image. This can be accomplished by adding concise 

alternative text to each image. If the image is purely decorative, 

mark it as background. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank (e.g. 

Background images should generally have no alt 

text, other decorative images should only have alt 

text if they form a crucial part of the content, 

message, and purpose of the document) 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• For logos, the alternative text should be the 

organization’s name 

• For groups of logos, one logo can be chosen to 

represent the group 

• Sometimes text is included as part of a logo or 

footer image (e.g. the image might contain a 

phone number), this text should be set as the 

alternative text of the image 

• Alternative text should be fairly short, usually a 
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sentence or less and rarely more than two 

sentences 

• If more description is required (e.g. for a chart 

or graph), provide a short description in the 

alternative text (e.g. a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g. an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 
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• Alternatively, you can include the same 

information conveyed by the image within the 

body of the document, providing the images as an 

alternate to the text. In that case, the images 

should be marked as “Background” and you do not 

have to provide alternate text within the image. 

To add alternative text to images 

1. Tools > Accessibility > Set Alternate Text 
(If “Accessibility” is not listed, it can be opened from menu 

item: View > Tools > Accessibility 
2. Select Ok the Adobe Acrobat pop up box 

3. Type in the description in the Set Alternative Text pop up box 

4. Select the right arrow to set alternative text on the next figure 

5. When complete select Save & Close 

The dialog box will automatically select all the objects that are tags 

as figure. 

To add alternative text to links 

1. Select the text or object for which you want to create a link. 

2. Right-click* the selection, and choose Create Link from the 

context menu. 

3. In the Create Link dialog box, select the appropriate options, 

and then follow the onscreen instructions to specify a URL, 

page view, or file as the link target. 
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Technique 5. Set a Logical Reading Order 

Setting up reading order will set up the way the device will read the 

file out loud to view and change reading order: 

1. Select the Order Pane (View > Show/Hide > Navigation Panes 
> Order) 

2. Once the order pane is selected the file will show numbers per 

page showing the reading order. 
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3. If the reading order is incorrect, select the following 

information from the pane and move the information bellow or 

above to make the reading order correct. 

To test the reading order 

Sometimes it may not be clear by looking at content, what would 

be the most logical aural reading order. In these cases, it is 

recommended to preview the reading order. 

Caution!: The “Read Out Loud” feature is not 
recommended for checking the aural order because it 

will provide inaccurate results. 

One method for testing the reading order of your document is 

called “reflowing”, which temporarily presents it as a single column 

that is the width of the document pane. Only readable text appears 

in the reflow view. 
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If the tagged PDF does not reflow the way you want, it means 

that the content order or reading order of the PDF contains 

inconsistencies. If this is the case, in addition to correcting the 

reading order, it may also be helpful to edit the document tags. 

1. Go to menu item: View > Zoom > Reflow 
2. To return to regular view, go to menu item: View > Zoom > 

Reflow 

Another way to test the aural accessibility of a document is to 

attempt to access the document with the screen readers that your 

readers will use (e.g., NVDA or JAWS on Windows, VoiceOver on Mac 

OS). 

Technique 6. Set Document Properties 

It is important to set up the PDF correctly in order for assistive 

technologies (e.g., screen readers) to be able to present your 

document accurately. 

1. File > Properties 
keyboard shortcut: Ctrl + D (on windows), Cmd + D (on Mac) 

2. Under Descriptions tab fill in the title and author. (Subject and 

Keywords can also be filled in) 

3. Under Initial Views change the following 

◦ Layout and Magnification 
◦ Navigation Tab: Bookmarks Panel and pages 
◦ Magnification: Fit Page 
◦ Open to Page: 1 
◦ Window Options 
◦ Check Center window on Screen 
◦ Show > Document Title 
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4. Under the Advanced tab select Language and change to the 

preferred language. If a different natural language is used for a 

paragraph or selected text, this also needs to be clearly 

indicated. 
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5. Select OK 

To apply a language directly to selected element 

1. Go to menu item: View > Navigation Panels > Tags 
2. In the Tags tab, select the element 

3. Right-click* the element and select Properties… 
4. In the Content tab, select the language from the Language 

drop-down list 

5. Select Close 

To set the page structure to document structure 

1. Select all the pages (ctrl + A or cmd + A) in the page 
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Thumbnails Panel 
2. Select Page Properties 

3. Under Tab Order select Use Document Structure. 
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4. Select OK. 

Technique 7. Adjust Security Settings 

It is possible to specify that no part of an accessible PDF is to be 

copied, printed, extracted, commented on, or edited. This can be 

accomplished by encrypting the document with password security. 

However, this could interfere with a screen reader’s ability to read 

the document, because screen readers must be able to copy or 

extract the document’s text in order to convert it to speech. In 

Acrobat 11 Pro, it is possible to maintain high-encryption-level 

security while at the same time providing the necessary access to 

assistive technologies. 
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To allow assistive technologies access to content 

1. Go to menu item: File >Properties > Security. 
2. In the Security Method drop down menu select Password 

Security. 
3. In the Password Security – Settings dialog, under 

Permissions, select Restrict editing and printing of the 
document. 

4. For low-encryption-level security, select Enable copying of 
text, images, and other content. 

5. For high-encryption-level security, select Enable text access 
for screen reader devices for the visually impaired (this 

overrides the document’s security settings only for the 

purpose of giving assistive software, such as screen readers, 

access to the content). 

6. Select OK. 
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Technique 8. Set Bookmarks 

A bookmark is a type of link with representative text in the 

Bookmarks panel in the navigation pane. Each bookmark goes to a 

different view or page in the document. In Acrobat 11 Pro, you can 

use bookmarks to mark a place in the PDF to which you want to 

return, or to jump to a destination in the PDF, another document, or 

a web page. There are several ways to create bookmarks. 

Note: An Acrobat user can only add bookmarks to a document only 

if the security settings allow it. 

To add a bookmark manually 

1. Bookmark > New Bookmark 

2. Insert the title of the content 
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3. Scroll to the page that the bookmark is intended to link. 

4. *Right click the bookmark title > Set Destination 

To add bookmarks automatically 

Bookmarks can also be generated automatically from various types 

of structures that will be in your document if you have tagged it 

properly: 

1. Bookmark > New Bookmark from Structure (in the drop down 

menu in the bookmark pane). 

2. Select the structure to generate bookmarks from. 
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Accessibility Support Tools 

• axesPDF: A plug-in for Microsoft Word 2007/2010 that makes 

it easier to create accessible PDFs (free public beta program); 

• CommonLook Office: A plug-in for Microsoft Word 2007/2010 

and PowerPoint 2007/010 that makes it easier to create 

accessible PDFs. 

• CommonLook PDF: A plug-in for Adobe Acrobat that helps 

identify, report and correct accessibility problems. 

• MadeToTag: A plug-in for for Adobe InDesign that makes it 

easier to create accessible PDF from InDesign documents. 

• PDFGoHTML: A free Adobe Acrobat plug-in that converts 

tagged PDF into HTML, which can be useful in debugging 

tagging structures. 

References and Resources 

• Adobe Acrobat XI Pro Accessibility Guide [PDF] 

• Using the Acrobat X Pro Accessibility Checker [PDF] 

• PDF Techniques for WCAG 2.0 

• WebAIM PDF Accessibility: Acrobat and Accessibility 

• GAWDS Writing Better Alt Text 

• Ryerson University: Adobe Acrobat Accessibility Tipsheet (PDF) 

• Create and verify PDF accessibility (Acrobat Pro) 

• PDF Accessibility Training (Video Tutorials) — This PDF 

Accessibility training series was provided to Microsoft 

employees on creating accessible PDF documents. Use these 

videos, along with documentation from https://adobe.com/

accessibility to learn to create, remediate, and check for 

accessibility issues. To test your knowledge, use the PDF 

sample documents at https://aka.ms/PDFSamples. 
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Adobe Acrobat 10 Pro 

Usage Notes 

At the time of testing (March 2013), Acrobat 10 Pro (Windows) 

enables the production of accessible digital documents. Acrobat 10 

Pro includes an accessibility checking feature. 

Note: While PDF accessibility has improved over the years, 

accessibility support for PDF by authoring tools, viewers, and 

assistive technologies (e.g., screen readers) is not as widespread as 

for HTML documents. We recommend considering HTML instead 
of or in addition to PDF where appropriate. 

Should I use ADOD or WCAG 2.0? 

These techniques can help you to use Acrobat 10 Pro to create 

documents that are: 

• Intended to be used by people (i.e. not computer code), 

• Text-based (i.e., not simply images, although they may contain 

images), 

• Fully printable (i.e., where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e., without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

Note: If you are creating forms, web pages, applications, or other 
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dynamic and/or interactive content, these you should also consult 

the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0). 

The WCAG working group has provided PDF Techniques for WCAG 

2.0. 

File Formats 

The default file format for Acrobat 10 Pro is Adobe Portable 
Document Format (PDF). In addition, Acrobat 10 Pro offers several 

other word processor and web format saving options. These have 

not been checked for accessibility. 

Document Conventions 

We have tried to write these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or (2) Shift+F10. 

• *Drag: Unfortunately, there is no keyboard alternative for 

several operations that require dragging. 
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Disclaimer and Testing Details: 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Adobe Acrobat 10 Pro (ver.10.0, 

Windows 7, Mar. 2011) while creating a PDF document. 

• Tasks completed in Technique 3, Technique 4, and Technique 5 

cannot be undone. It is recommended that you save your PDF 

document before and after you make significant changes. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. 

• If errors are found, please report them to: adod-

comments@idrc.ocad.ca 

Technique 1. Use Accessible Source Documents 

In the Adobe Acrobat 10 Pro workflow, all PDF documents start 

with a source document created in an office document authoring 

application, such as Microsoft Word or OpenOffice.org Writer. 

Because source documents provide the starting-point for the PDF 

documents, accessibility is very important. 

To create an accessible source document 

1. Create a new document in the authoring application (from the 

default blank template or from one of the prepackaged 
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templates). 

2. Ensure that you follow the ADOD Authoring Techniques 
provided for the authoring application (available at: How to Use 

This Resource). 

3. When you are finished, you should also check the accessibility 

of the document (see Accessibility Checking in the Authoring 

Techniques for the authoring application). 

Once you have completed the above steps, you are ready to convert 

your document to PDF using Adobe Acrobat 10. 

To convert single source documents to PDF 

1. Go to the menu item: File > Create PDF > From file… 
2. Locate and select your source document and select the Open 

button, Acrobat will then proceed to convert the file. 

Note: A batch conversion process is also available from the menu 

item: File > Create PDF > Batch Create Multiple Files 

Scanned Content 

If you created a PDF from a scanned document, then it will be 

inherently inaccessible to screen readers and other assistive 

technologies. The document will be less useful because graphic 

representations of text cannot be selected, edited or searched. In 

this case, it is necessary that you convert the scanned images of text 

to searchable content using Acrobat’s optical character recognition 
(OCR) feature before addressing the accessibility features of the 

document. 
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Technique 2. Check Accessibility 

The most basic requirement for a PDF document to be accessible 

is for it to be “tagged” with hidden labels (“tags”) that describes 

the structure of the document (e.g. that text should be interpreted 

as a header, paragraph, table cell, etc.). Screen readers can then 

use these tags to convey the document’s information effectively to 

people with visual disabilities. The other requirements for a PDF 

document to be accessible (e.g. alternate text, logical reading order, 

etc.) can only all apply once the document is tagged. 

Caution!: The “Quick Check” feature is not 
recommended because it misses some important 

accessibility issues. Always perform a “Full Check” 

instead. 

To perform a “Full Check” 

Note: If “Accessibility” is not visible under tools, go to menu item: 

View > Tools > Accessibility 

1. Select Tools > Accessibility > Full Check Up 
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Running a Wizard Action Full Check when the file is first created 

would be ideal. This allows you to fix a few mistakes before the 

check up. 
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1. Select Tools > Action Wizard > Create Accessible PDF’sNote: If 

the PDF file was created from InDesign, then select “InDesign 

CS6 Accessibility Touch up” 

2. Select “5 Accessibility Check (Full)” (in the Action: Create 

Accessible PDFs) 

Adobe Acrobat 10 Pro  |  783



3. Select Next 
4. Select the folder to save the file (in Browse For Folder) 

5. Insert Title and Author (you can also insert subject and 

keyword). In order to insert you must uncheck the “Leave As 
Is” button. 
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6. Follow the Wizard (a yellow sticky note-like pop-up box) 

7. In the Remove Hidden Information pop up box select OK. All 

of the checked items will be removed. 
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8. Start Checking 
9. Save file. If the file is not fully accessible the errors (report) will 

be shown on the left panel). 

Technique 3. Add and Edit Tags 
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Caution!: Actions taken using the TouchUp Reading 

Order tool and Order Panel cannot be undone. 

Remember to save your work frequently. If you 

frequently create PDF files you might consider using 

one of these accessible PDF support tools. 

If tags are missing, then they must be added. When tags are present, 

they should still be checked for correctness. Acrobat’s Help text 

describes the tags as follows: 

Text 
Tags the selection as text. 

Figure 
Tags the selection as a figure. Text contained within a figure tag 

is defined as part of the image and is not read by screen readers, 

though alternate text defined for the figure is read out. Note: An 

effective way of handling very complex tex constructs (e.g. 

flow charts) is to group it all as a figure and provide alt text. 

Form Field 
Tags the selection as a form field. 

Figure/Caption 
Tags a selected figure and caption as a single tag. Any text 

contained in the tag is defined as a caption. Useful for tagging 

photos and captions and preventing caption text from being 

incorrectly added to adjacent text blocks. Note: Unless the 

caption actually describes the image, the figures will still 

require alternate text. 

Heading 1, Heading 2, Heading 3 
Tags the selection as a first, second, third, fourth, fifth, or sixth 

level heading tag. You can convert heading tags to bookmarks 

to help users navigate the document. 
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Table 
Tags the selection as a table. When this selection is made, 

Acrobat analyzes the selection to determine the location of 

headings, columns, and rows. Note: Table editing can be 

especially challenging. Try to keep them as simple as possible 

in the source document. 

Cell 
Tags the selection as a table or header cell. Use this option to 

merge cells that are incorrectly split. Note: Table editing can be 

especially challenging. Try to keep them as simple as possible 

in the source document. 

Formula 
Tags the selection as a formula. Note: Because speech software 

may handle formula tags differently from normal text, you 

should still add alternate text. 

Background 
Tags the selection as a background element, or artifact, 

removing the item from the tag tree so that it does not appear 

in the reflowed document and is not read by screen readers. 

To add tags automatically 

Note: The automatic tagging feature may be sufficient on simple 

layouts, but it sometimes misinterprets the structure and reading 

order of complex page elements (e.g. closely spaced columns, 

irregular text alignment, and tables without borders.). Therefore, 

you should still manually check the tags as explained below. 

 

• Go to menu item: Advanced > Accessibility > Add Tags To 
Document 
Note: This command removes any tags that were in the 
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document before the command was run. If any potential 

problems were encountered, an Add Tags Report appears in 

the navigation pane. 

To add/edit tags manually 

1. TouchUp Reading Order… In most cases, it will help to have 

the three checkboxes checked (Show page content order, 

Show table cells, Show tables and figures) 

2. Using the TouchUp Reading Order tool, drag* within the 

document pane to select a region of the page that contains one 

type of content (e.g. a text block) 

3. To add more page content to the current selection, Shift + 
drag* 

4. To remove page content from the current selection, Ctrl + 
drag* 

5. Select the appropriate button in the TouchUp Reading Order 
dialog to specify the tag type, a box should now encapsulate 

the element (the tags are explained here) 
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Tips for Tagging 

• A good place to start is tagging “Background” 

content, since this will reduce the number of tags 

to deal with. Background content should include: 

◦ empty boxes, 

◦ visible or invisible textbox borders 

(especially in busy areas where they overlap 

with text), 

◦ visuals that are decorative or redundant 

(e.g. backgrounds, illustrations), whose 

content is described adequately in the text . 

• If you are having difficulty tagging complex 

content (e.g. a complex table), consider either: 

◦ Editing the source document to simplify 

it, or 

◦ Selecting the complex content and 

tagging it as a figure for which you must 

then add alternative text that properly 

conveys all of the information in the new 

figure. 

To change the tag for a region 

1. With the TouchUp Reading Order tool… 

2. In the document pane, drag* to select a highlight region or 
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select the number of the highlighted region (or select from the 

Order Panel) 
Note: If you drag* over part of an already tagged element, the 

element is sometimes split up. This is helpful when splitting 

larger elements to ensure correct reading over of sub-

elements. 

3. Select the appropriate button in the TouchUp Reading Order 
dialog to specify the tag (the tags are explained here) 

To Modify Tagging 

1. Tools > Content > Edit Object 
2. Select items required to be tagged*right click > properties… 
3. Under Tag select type (paragraph, heading level, span etc.) Tip:

Tagging items and adding alternative text before converting to 

PDF will save time. 
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Correcting Visual Side-Effects of Tagging 

Sometimes tagging can result in unexpected visual side effects, such 

as text disappearing behind background images. The following steps 

can be taken to correct such side-effects: 

1. Open Content panel (View > Show/Hide > Navigation Panes > 

Content) 

2. Move any <Artifact> elements to the top (this places them 

behind all other elements). 

3. See if this fixes the problem. If not, continue: 

4. Click Gears icon > Highlight Content 
5. Drag* mouse over unwanted element or the area where 

missing element should be 

6. Click Gears icon > “Find content from selection” to locate 
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selection in Content tree 

7. In the Content panel tree, click on the “Container” node of the 

selected element and then adjacent nodes. 

8. As you click, note which element is highlighted on screen. When 

you have found the element you want to correct, continue: 

9. If you found text that is hidden behind another element, move 

the hidden element DOWN within the Content panel tree (this 

moves it above other elements). 

10. If you found an element that should not be there, move it UP 

within the Content panel tree (this moves in behind other 

elements) or delete it if necessary (remember to Save 

beforehand) 

Note: The order of items in the Content panel tree indicates their 

layer order in the document. If item A is lower in the tree than item 

B, then if item A and B overlap in the document, A will be in front. 

Some people find this confusing, so a good way to remember how 

this works is to imagine putting documents in a pile and noting their 

names in a list. The last document placed will be on top of the pile, 

covering the others, and its name will be on the bottom of the list. 

Technique 4. Provide Alternative Text 

When using images, it is important to ensure that the information 

you intend to convey by the image is also conveyed to people who 

cannot see the image. This can be accomplished by adding concise 

alternative text to each image. If the image is purely decorative, 

mark it as background. 
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Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank (e.g. 

Background images should generally have no 

alternative text, other decorative images should 

only have alt text if they form a crucial part of the 

content, message, and purpose of the document) 

• If the image contains meaningful text, ensure all 

of the text is replicated 

• For logos, the alternative text should be the 

organization’s name 

• For groups of logos, one logo can be chosen to 

represent the group 

• Sometimes text is included as part of a logo or 

footer image (e.g. the image might contain a 

phone number), this text should be set as the 

alternative text of the image 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g. for a chart 

or graph), provide a short description in the 

alternative text (e.g. a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 
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Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 

conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g. an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description 

• Alternatively, you can include the same 

information conveyed by the image within the 

body of the document, providing the images as an 

alternate to the text. In that case, the images 

should be marked as “Background” and you do not 

have to provide alternate text within the image. 

To add alternative text to images 

1. Tools > Content > Edit Object 
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2. Select image *right click > properties… 
3. Under Tag select type (figure, table etc.) 

4. Alternative text inserts text 
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To add alternative text to links 

1. In the tag tree, select the Link tag for the link 

2. Select Options > Properties 
3. In the TouchUp Properties dialog, select the Tag tab 

4. Type alternative text for the link 

5. Select Close 

To create an artifact 

Artifacts are for objects that are not required to be read out loud (eg. 

background colours) 

1. Tools > Content > Edit Object 
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2. Select image *right click > Create Artifact 

Technique 5. Set a Logical Reading Order 

Setting up reading order will set up the way the device will read the 

file out loud to view and change reading order: 

1. Select the Order Pane (View > Show/Hide > Navigation Panes 
> Order) 

2. Once the order pane is selected the file will show numbers per 

page showing the reading order. 
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3. If the reading order is incorrect select the following 

information from the pane and move the information bellow or 

above to make the reading order correct. 

To test the reading order 

Sometimes it may not be clear by looking at content, what would 

be the most logical aural reading order. In these cases, it is 

recommended to preview the reading order. 

Caution!: The “Read Out Loud” feature is not 
recommended for checking the aural order because it 

will provide an inaccurate . 

One method for testing the reading order of your document is 

called “reflowing”, which temporarily presents it as a single column 

that is the width of the document pane. Only readable text appears 

in the reflow view. If the tagged PDF does not reflow the way you 
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want, it means that the content order or reading order of the PDF 

contains inconsistencies. If this is the case, in addition to correcting 

the reading order, it may also be helpful to edit the document tags. 

1. Go to menu item: View > Zoom > Reflow 
2. To return to regular view, go to menu item: View > Zoom > 

Reflow 

Another way to test the aural accessibility of a document is to 

attempt to access the document with the screen readers that your 

readers will use (e.g., NVDA or JAWS on Windows, VoiceOver on Mac 

OS). 

Technique 6. Set Document Properties 

It is important to set up the PDF correctly in order for assistive 

technologies (e.g. screen readers) to be able to present your 

document accurately. 

1. File > Properties keyboard shortcut: Ctrl + D (on windows), 

Cmd + D (on Mac) 

2. Under Descriptions tab fill in the title and author. (Subject and 

Keywords can also be filled in) 

3. Under Initial Views change the following 

◦ Layout and Magnification 
◦ Navigation Tab: Bookmarks Panel and pages 
◦ Magnification: Fit Page 
◦ Open to Page: 1 Window Options 
◦ Check Center window on Screen 
◦ Show > Document Title 
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4. Under the Advanced tab select Language and change to the 

preferred language If a different natural language is used for a 

paragraph or selected text, this also needs to be clearly 

indicated. 
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5. Select OK 

To apply a language directly to selected element 

1. Go to menu item: View > Navigation Panels > Tags 
2. In the Tags tab, select the element 

3. Right-click* the element and select Properties… 
4. In the Content tab, select the language from the Language 

drop-down list 

5. Select Close 
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To set the page structure to document structure 

1. Select all the pages (ctrl + A or cmd + A) in the page 

Thumbnails Panel 
2. Select Page Properties 

3. Under Tab Order select Use Document Structure 
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4. Select OK 

Technique 7. Adjust Security Settings 

It is possible to specify that no part of an accessible PDF is to be 

copied, printed, extracted, commented on, or edited. This can be 

accomplished by encrypting the document with password security. 

However, this could interfere with a screen reader’s ability to read 

the document, because screen readers must be able to copy or 

extract the document’s text in order to convert it to speech. In 

Acrobat 10 Pro, it is possible to maintain high-encryption-level 

security while at the same time providing the necessary access to 

assistive technologies. 
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To allow assistive technologies access to content 

1. Go to menu item: File >Properties > Security Properties 
2. Security Method > Password Security 
3. In the Password Security – Settings dialog, under 

Permissions, select Restrict editing and printing of the 
document 

4. For low-encryption-level security, select Enable copying of 
text, images, and other content 

5. For high-encryption-level security, select Enable text access 
for screen reader devices for the visually impaired (this 

overrides the document’s security settings only for the 

purpose of giving assistive software, such as screen readers, 

access to the content) 

6. Select OK 
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Technique 8. Set Bookmarks 

A bookmark is a type of link with representative text in the 

Bookmarks panel in the navigation pane. Each bookmark goes to a 

different view or page in the document. In Acrobat 10 Pro, you can 

use bookmarks to mark a place in the PDF to which you want to 

return, or to jump to a destination in the PDF, another document, or 

a web page. There are several ways to create bookmarks. 

Note: An Acrobat user can only add bookmarks to a document only 

if the security settings allow it. 

To add a bookmark manually 

1. Bookmark > New Bookmark 

2. Insert the title of the content 
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3. Scroll to the page that the bookmark is intended to link. 

4. *Right click the bookmark title > Set Destination 

To add bookmarks automatically 

Bookmarks can also be generated automatically from various types 

of structure that will be in your document if you have tagged it 

properly: 

1. Bookmark > New Bookmark from Structure (in the drop down 

menu in the bookmark pane) 

2. Select the structure to generate bookmarks from. 
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Accessibility Support Tools 

• axesPDF: A plug-in for Microsoft Word 2007/2010 that makes 

it easier to create accessible PDFs (free public beta program); 

• CommonLook Office: A plug-in for Microsoft Word 2007/2010 

and PowerPoint 22007/010 that makes it easier to create 

accessible PDFs. 

• CommonLook PDF: A plug-in for Adobe Acrobat that helps 

identify, report and correct accessibility problems. 

• MadeToTag: A plug-in for for Adobe InDesign that makes it 

easier to create accessible PDF from InDesign documents. 

• PDFGoHTML: A free Adobe Acrobat plug-in that converts 

tagged PDF into HTML, which can be useful in debugging 

tagging structures. 
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Adobe Acrobat 9 Pro 

Usage Notes 

At the time of testing (January 19, 2011), Acrobat 9 Pro (Windows) 

enables the production of accessible digital office documents. 

Acrobat 9 Pro includes an accessibility checking feature. 

Note: While PDF accessibility has improved over the years, 

accessibility support for PDF by authoring tools, viewers and 

assistive technologies (e.g. screen readers) is not as widespread as 

for HTML documents. We recommend considering HTML instead 
of or in addition to PDF where appropriate. 

Should I use ADOD or WCAG 2.0? 

These techniques can help you to use Acrobat 9 Pro to create 

documents that are: 

• Intended to be used by people (i.e. not computer code), 

• Text-based (i.e. not simply images, although they may contain 

images), 

• Fully printable (i.e. where dynamic features are limited to 

automatic page numbering, table of contents, etc. and do not 

include audio, video, or embedded interactivity), 

• Self-contained (i.e. without hyperlinks to other documents, 

unlike web content), and 

• Typical of office-style workflows (Reports, letters, memos, 

budgets, presentations, etc.). 

Note: If you are creating forms, web pages, applications, or other 
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dynamic and/or interactive content, these you should also consult 

the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0). 

The WCAG working group has provided PDF Techniques for WCAG 

2.0. 

File Formats 

The default file format for Acrobat 9 Pro is Adobe Portable 
Document Format (PDF). Several other word processor and web 

format saving options are also offered, but these have not been 

checked for accessibility. 

Document Conventions 

We have tried to write these techniques so that they are useful 

to all authors, regardless of whether they use a mouse. However, 

for clarity there are several instances where mouse-only language 

is used. Below are the mouse-only terms and their keyboard 

alternatives: 

• *Right-click: To right-click with the keyboard, select the 

object using the Shift+Arrow keys and then press either (1) the 

“Right-Click” key (some keyboard have this to the right of the 

spacebar) or (2) Shift+F10. 

• *Drag: Unfortunately, there is no keyboard alternative for 

several operations that require dragging. 
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Disclaimer and Testing Details: 

• Following these techniques will increase the accessibility of 
your documents, but it does not guarantee accessibility to 
any specific disability groups. In cases where more certainty 

is required, it is recommended that you test the office 

documents with end users with disabilities, including screen 

reader users. 

• The application-specific steps and screenshots in this 

document were created using Adobe Acrobat 9 Pro (ver.9.0.0, 

Windows 7, Jan. 2011) while creating a PDF document. 

• Tasks completed in Technique 3, Technique 4, and Technique 5 

cannot be undone. It is recommended that you save your PDF 

document before and after you make significant changes. 

• This document is provided for information purposes only and 

is neither a recommendation nor a guarantee of results. 

• If errors are found, please report them to: adod-

comments@idrc.ocad.ca 

Technique 1. Use Accessible Source Documents 

In the Adobe Acrobat 9 Pro workflow, all PDF documents start 

with a source document created in an office document authoring 

application, such as Microsoft Word or OpenOffice.org Writer. 

Because source documents provide the starting-point for the PDF 

documents, accessibility is very important. 

To create an accessible source document 

1. Create a new document in the authoring application (from the 

default blank template or from one of the prepackaged 
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templates). 

2. Ensure that you follow the ADOD Authoring Techniques 
provided for the authoring application (available at: How to Use 

This Resource). 

3. When you are finished, you should also check the accessibility 

of the document (see “Accessibility Checking” in the Authoring 

Techniques for the authoring application). 

Once you have completed the above steps, you are ready to convert 

your document to PDF using Adobe Acrobat 9. 

To convert single source documents to PDF 

1. Go to the menu item: File > Create PDF > From file… 
2. Locate and select your source document and select the Open 

button, Acrobat will then proceed to convert the file. 

Note: A batch conversion process is also available from the menu 

item: File > Create PDF > Batch Create Multiple Files 

Scanned Content 

If you created a PDF from a scanned document, then it will be 

inherently inaccessible to screen readers and other assistive 

technologies.The document will be less useful because graphic 

representations of text cannot be selected, edited or searched. 

In this case, it is necessary that you convert the scanned images 

of text to searchable content using Acrobat’s optical character 
recognition (OCR) feature before addressing the accessibility 

features of the document. 
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Technique 2. Check Accessibility 

The most basic requirement for a PDF document to be accessible 

is for it to be “tagged” with hidden labels (“tags”) that describes 

the structure of the document (e.g. that text should be interpreted 

as a header, paragraph, table cell, etc.). Screen readers can then 

use these tags to convey the document’s information effectively to 

people with visual disabilities. 

The other requirements for a PDF document to be accessible (e.g. 

alternate text, logical reading order, etc.) can only all apply once the 

document is tagged. 

Caution!: The “Quick Check” feature is not recommended because 

it misses some important accessibility issues. Always perform a “Full 

Check” instead. 

To perform a “Full Check” 

1. Go to menu item: Advanced > Accessibility > Full check 
2. Under Report and Comment Options, select how you would 

like to view the results 

3. If you would like to do a full check on individual sections of a 

document, under Page Range, select a page range (when you 

have a large document, running a full check on one section at a 

time can be more efficient.) 

4. Under Checking Options, select an accessibility standard from 

the Name drop-down list 

5. Under Checking Options, select Select All to run a complete 

accessibility check 

6. Select Start Checking 
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Technique 3. Add and Edit Tags 

Caution!: Actions taken using the TouchUp Reading 

Order tool and Order Panel cannot be undone. 

Remember to save your work frequently. If you 

frequently create PDF files you might consider using 

one of these accessible PDF support tools. 
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If tags are missing, then they must be added. When tags are present, 

they should still be checked for correctness. Acrobat’s Help text 

describes the tags as follows: 

Text 
Tags the selection as text. 

Figure 
Tags the selection as a figure. Text contained within a figure tag 

is defined as part of the image and is not read by screen readers, 

though alternate text defined for the figure is read out.Note: An 

effective way of handling very complex tex constructs (e.g. 

flow charts) is to group it all as a figure and provide alt text. 

Form Field 
Tags the selection as a form field. 

Figure/Caption 
Tags a selected figure and caption as a single tag. Any text 

contained in the tag is defined as a caption. Useful for tagging 

photos and captions and preventing caption text from being 

incorrectly added to adjacent text blocks. Note: Unless the 

caption actually describes the image, the figures will still 

require alternate text. 

Heading 1, Heading 2, Heading 3 
Tags the selection as a first, second, third, fourth, fifth, or sixth 

level heading tag. You can convert heading tags to bookmarks 

to help users navigate the document. 

Table 
Tags the selection as a table. When this selection is made, 

Acrobat analyzes the selection to determine the location of 

headings, columns, and rows. Note: Table editing can be 

especially challenging. Try to keep them as simple as possible 

in the source document. 
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Cell 
Tags the selection as a table or header cell. Use this option to 

merge cells that are incorrectly split. Note: Table editing can be 

especially challenging. Try to keep them as simple as possible 

in the source document. 

Formula 
Tags the selection as a formula. Note: Because speech software 

may handle formula tags differently from normal text, you 

should still add alternate text. 

Background 
Tags the selection as a background element, or artifact, 

removing the item from the tag tree so that it does not appear 

in the reflowed document and is not read by screen readers. 

To add tags automatically 

Note: The automatic tagging feature may work for simple layouts, 

but it sometimes misinterprets the structure and reading order of 

complex page elements (e.g., closely spaced columns, irregular text 

alignment, and tables without borders). Therefore, you should still 

manually check the tags as explained below. 

1. Go to menu item: Advanced > Accessibility > Add Tags To 
Document 
Note: This command removes any tags that are present in the 

document before the command was run. If any potential 

problems are encountered, an Add Tags Report appears in the 

navigation pane. 
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To add/edit tags manually 

1. Go to menu item: Advanced > Accessibility > TouchUp 
Reading Order… 
In most cases, it will help to have the three checkboxes 

checked (Show page content order, Show table cells, Show 
tables, and figures). 

2. Using the TouchUp Reading Order tool, drag* within the 

document pane to select a region of the page that contains one 

type of content (e.g., a text block). 

3. To add more page content to the current selection, Shift + 
drag* 

4. To remove page content from the current selection, Ctrl + 
drag* 

5. Select the appropriate button in the TouchUp Reading Order 
dialog to specify the tag type, a box should now encapsulate 

the element (the tags are explained above) 
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Tips for Tagging 

• A good place to start is tagging “Background” 

content, since this will reduce the number of tags 

to deal with. Background content should include: 

◦ empty boxes, 

◦ visible or invisible textbox borders 

(especially in busy areas where they overlap 

with text), 

◦ visuals that are decorative or redundant 

(e.g., backgrounds, illustrations), whose 

content is described adequately in the text . 

• If you are having difficulty tagging complex 

content (e.g., a complex table), consider either: 

◦ Editing the source document to simplify 

it, or 

◦ Selecting the complex content and 

tagging it as a figure for which you must 

then add alternative text that properly 

conveys all of the information in the new 

figure 

To change the tag for a region 

1. With the TouchUp Reading Order tool… 

2. In the document pane, drag* to select a highlight region or 
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select the number of the highlighted region (or select from the 

Order Panel) 
Note: If you drag* over part of an already tagged element, the 

element is sometimes split up. This is helpful when splitting 

larger elements to ensure correct reading over of sub-

elements. 

3. Select the appropriate button in the TouchUp Reading Order 
dialog to specify the tag (the tags are explained here) 

Technique 4. Provide Alternative Text 

When using images, it is important to ensure that the information 

you intend to convey by the image is also conveyed to people who 

cannot see the image. This can be accomplished by adding concise 

alternative text to each image. If the image is purely decorative, 

mark it as background. 

Tips for writing alternative text 

• Try to answer the question “what information is 

the image conveying?” 

• If the image does not convey any useful 

information, leave the alternative text blank (e.g., 

Background images should generally have no alt 

text, other decorative images should only have alt 

text if they form a crucial part of the content, 

message, and purpose of the document) 
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• If the image contains meaningful text, ensure all 

of the text is replicated 

• For logos, the alternative text should be the 

organization name 

• For groups of logos, one logo can be chosen to 

represent the group 

• Sometimes text is included as part of a logo or 

footer image (e.g., the image might contain a 

phone number), this text should be set as the 

alternative text of the image 

• Alternative text should be fairly short, usually a 

sentence or less and rarely more than two 

sentences 

• If more description is required (e.g., for a chart 

or graph), provide a short description in the 

alternative text (e.g., a summary of the trend) and 

more detail in the long description, see below 

• Test by having others review the document with 

the images replaced by the alternative text 

Tips for writing longer descriptions 

• Long descriptions should be used when text 

alternatives (see above) are insufficient to answer 

the question “what information is the image 
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conveying?” 

• In some situations, the information being 

conveyed will be how an image looks (e.g., an 

artwork, architectural detail, etc.). In these cases, 

try to describe the image without making too 

many of your own assumptions. 

• One approach is to imagine you are describing 

the image to a person over the phone 

• Ensure that you still provide concise alternative 

text to help readers decide if they are interested 

in the longer description. 

• Alternatively, you can include the same 

information conveyed by the image within the 

body of the document, providing the images as an 

alternate to the text. In that case, the images 

should be marked as background and you do not 

have to provide alternate text within the image. 

To add alternative text using the Navigation Panel 

1. Go to menu item: View > Navigation Panels > Tags 
2. In the Tags tab, select the element 

3. Right-click* the element and select Properties… 
4. In the Tag tab, fill in the alternative text in the Alternative Text 

box 
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5. Select Close 

Tip: If you have a number of images arranged together, pick the 

main image and assign alternative text to it that describes the 

whole. Then, mark the secondary images as Background to be 

ignored (i.e. untag them) 

To add alternative text directly to the element 

1. Right-click* the element and select Edit Alternate Text… 
2. Enter the alternative text in the Alternate Text box 

3. Select OK 
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To add alternative text to links 

1. In the tag tree, select the Link tag for the link 

2. Select Options > Properties 
3. In the TouchUp Properties dialog, select the Tag tab 

4. Type alternative text for the link 

5. Select Close 

Correcting visual side-effects of tagging 

Sometimes tagging can result in unexpected visual side effects, such 

as text disappearing behind background images. The following steps 

can be taken to correct such side-effects: 

1. Open Content panel (this is another option in the same 

location as the Order panel) 

2. Move any <Artifact> elements to the top (this places them 

behind all other elements). 

3. See if this fixes the problem. If not, continue: 

4. Click Gears icon > Highlight Content 
5. Drag* mouse over unwanted element or the area where 

missing element should be 

6. Click Gears icon > “Find content from selection” to locate 

selection in Content tree 

7. In the Content panel tree, click on the “Container” node of the 

selected element and then adjacent nodes. 

8. As you click, note which element is highlighted on screen. 

When you have found the element you want to correct, 

continue: 

9. If you found text that is hidden behind another element, move 

the hidden element DOWN within the Content panel tree (this 

moves it above other elements). 

10. If you found an element that should not be there, move it UP 
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within the Content panel tree (this moves in behind other 

elements) or delete it if necessary (remember to Save 

beforehand) 

Note: The order of items in the Content panel tree indicates their 

layer order in the document. If item A is lower in the tree than item 

B, then if item A and B overlap in the document, A will be in front. 

Some people find this confusing, so a good way to remember how 

this works is to imagine putting documents in a pile and noting their 

names in a list. The last document placed will be on top of the pile, 

covering the others, and its name will be on the bottom of the list. 

Technique 5. Set a Logical Reading Order 

The order in which elements in a document are read by assistive 

software is determined by the reading order. Each section of page 

content appears as a separate highlighted region and is numbered 

according to its placement in the reading order. You can change 

the reading order of the highlighted regions without changing the 

actual appearance of the PDF. For example, by reordering 

highlighted regions on the page, you can make a figure and caption 

read at the specific point that they are referenced in the text 

without actually moving the elements on the page. 

To correct the reading order 

1. Go to menu item: Advanced > Accessibility > TouchUp 
Reading Order… 

2. Select Show Order Panel 
3. In the Order tab, navigate through the list of highlighted 

regions that appear in the document pane 
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4. If a highlighted region is misplaced, right-click* and select Cut 
5. Navigate to the location where the region should be placed, 

right-click* the item above the location in the list and select 

Paste. After you drag* an item to a new location, the 

highlighted regions are renumbered accordingly. 

Note: You can also complete steps 4 and 5 by dragging* the tag 

for the region to the location you want. As well, you can select 

and move multiple adjacent regions at once. 

To test the reading order 

Sometimes it may not be clear by looking at content, what would 

be the most logical aural reading order. In these cases, it is 

recommended to preview the reading order. 

Caution!: The “Read Out Loud” feature is not recommended for 

checking the aural order because it will provide an inaccurate . 

One method for testing the reading order of your document is 

called “reflowing”, which temporarily presents it as a single column 

that is the width of the document pane. Only readable text appears 

in the reflow view. 

If the tagged PDF does not reflow the way you want, it means 

that the content order or reading order of the PDF contains 
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inconsistencies. If this is the case, in addition to correcting the 

reading order, it may also be helpful to edit the document tags. 

1. Go to menu item: View > Zoom > Reflow 
2. To return to regular view, go to menu item: View > Zoom > 

Reflow 

Another way to test the aural accessibility of a document is to 

attempt to access the document with the screen readers that your 

readers will use (e.g. NVDA or JAWS on Windows, VoiceOver on Mac 

OS). 

Technique 6. Set Document Properties 

6.1 Document Language 

It is important to set up the PDF correctly in order for assistive 

technologies (e.g. screen readers) to be able to present your 

document accurately. 

To change the default language 

1. Go to menu item: File > Properties 
2. Select the Advanced tab 

3. In the Reading Options section, select the language from the 

Language drop-down list 

4. Select OK 
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To apply a language directly to selected element 

1. Go to menu item: View > Navigation Panels > Tags 
2. In the Tags tab, select the element 

3. Right-click* the element and select Properties… 
4. In the Tag tab, select the language from the Language drop-

down list 

5. Select Close 

6.2 Document Title 

In case the document is ever converted into HTML, it should be 

given a descriptive and meaningful title. 

To change the title of the current document 

1. Go to menu item: File > Properties 
2. Select the Description tab 

3. Enter a descriptive title in the Title box. It is also helpful to 

enter descriptive information in the text boxes that follow 

(Author, Subject, Keywords or select Additional Metadata) 

4. Select OK 

Technique 7. Adjust Security Settings 

It is possible to specify that no part of an accessible PDF is to be 

copied, printed, extracted, commented on, or edited. This can be 

accomplished by encrypting the document with password security. 

However, this could interfere with a screen reader’s ability to read 
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the document, because screen readers must be able to copy or 

extract the document’s text in order to convert it to speech. In 

Acrobat 9 Pro, it is possible to maintain high-encryption-level 

security while at the same time providing the necessary access to 

assistive technologies. 

To allow assistive technologies access to content 

1. Go to menu item: Advanced > Security > Show Security 
Properties 

2. Set the Security Method field to “No Security” or enable 

“Content Copying for Accessibility” in the Document 

Restrictions 

3. Go to menu item: Advanced > Security > Encrypt with 
Password 

4. In the Password Security – Settings dialog, under 

Permissions, select Restrict editing and printing of the 
document 

5. For low-encryption-level security, select Enable copying of 
text, images, and other content 

6. For high-encryption-level security, select Enable text access 
for screen reader devices for the visually impaired (this 

overrides the document’s security settings only for the 

purpose of giving assistive software, such as screen readers, 

access to the content) 

7. Select OK 
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Technique 8. Set Bookmarks 

A bookmark is a type of link with representative text in the 

Bookmarks panel in the navigation pane. Each bookmark goes to a 

different view or page in the document. In Acrobat 9 Pro, you can 

use bookmarks to mark a place in the PDF to which you want to 

return, or to jump to a destination in the PDF, another document, or 

a web page. 

Note: An Acrobat user can only add bookmarks to a document only 

if the security settings allow it. 

To create a bookmark 

1. Select text to bookmark 

2. Type Ctrl+B 
3. Type a name the bookmark (or leave the default text) 
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4. To create a bookmark without keyboard shortcuts 

To delete a bookmark 

1. In the Bookmarks pane, *right-click on the bookmark 

2. Select Delete 

To create a bookmark hierarchy 

1. In the Bookmarks pane, *right-click on the bookmark to move 

2. Select Cut 
3. *right-click on the new bookmark you would like the moved 

bookmark to appear under 

4. Select Paste Under Selected Bookmark 

Accessibility Support Tools 

• axesPDF: A plug-in for Microsoft Word 2007/2010 that makes 

it easier to create accessible PDFs (free public beta program); 

• CommonLook Office: A plug-in for Microsoft Word 2007/2010 

and PowerPoint 2007/010 that makes it easier to create 

accessible PDFs. 

• CommonLook PDF: A plug-in for Adobe Acrobat that helps 

identify, report and correct accessibility problems. 

• MadeToTag: A plug-in for for Adobe InDesign that makes it 

easier to create accessible PDF from InDesign documents. 

• PDFGoHTML: A free Adobe Acrobat plug-in that converts 

tagged PDF into HTML, which can be useful in debugging 

tagging structures. 
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Document Accessibility 
Resources 

Here is a curated list of resources brought to you by the editors of 

this resource. 

Courses on Document Accessibility 

• WebAIM: Document Accessibility Training 

• LinkedIn Learning: Creating Accessible Documents in 

Microsoft Office 

• PDF Accessibility Training (Video Tutorials) — This PDF 

Accessibility training series was provided to Microsoft 

employees on creating accessible PDF documents. Use these 

videos, along with documentation from Adobe Accessibility to 

learn to create, remediate, and check for accessibility issues. 

To test your knowledge, use the PDF sample documents at PDF 

Accessibility Training – Sample Docs. 

• LinkedIn Learning: Creating Accessible PDFs 

• LinkedIn Learning: Advanced Accessible PDFs 

Resources on Document Accessibility 

• Accessibility for Microsoft Word, PowerPoint, Excel (Penn 

State) 

• Creating Accessible Documents (University of Washington) 

• Accessible Documents (Ryerson University) 
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 Creating Accessible PDFs 

• Create and verify PDF accessibility (Acrobat Pro) 

• WebAIM PDF Accessibility 

Colour & Contrast Testing 

• WebAIM Contrast Checker 

• Accessible Color Palette Tool 
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